Bug 190346 - [handbook] Handbook modification to reduce dependencies
Summary: [handbook] Handbook modification to reduce dependencies
Status: Open
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-doc mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-28 15:40 UTC by Laurent Frigault
Modified: 2017-12-31 22:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Frigault 2014-05-28 15:40:00 UTC
The handbook advice to install devel/subversion in order to upgrade system/doc/port source :

http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/svn.html

Unfortunately subversion has many dependencies:
Port:	subversion-1.8.8_2
Path:	/usr/ports/devel/subversion
Info:	Version control system
Maint:	lev@FreeBSD.org
B-deps:	apr-1.5.1.1.5.3 db48-4.8.30.0 expat-2.1.0 gdbm-1.11 gettext-0.18.3.1 libiconv-1.14_3 libtool-2.4.2_2 pkgconf-0.9.5 serf-1.3.5 sqlite3-3.8.4.2
R-deps:	apr-1.5.1.1.5.3 db48-4.8.30.0 expat-2.1.0 gdbm-1.11 gettext-0.18.3.1 libiconv-1.14_3 serf-1.3.5 sqlite3-3.8.4.2
WWW:	http://subversion.apache.org/

under 10.0, the base system has svnlite which can be use for this task.
Before 10, the port/package net/svnup can be used.

Port:	svnup-1.05
Path:	/usr/ports/net/svnup
Info:	Lightweight program to pull source from an Apache Subversion server
Maint:	jcm@visi.com
B-deps:
R-deps:
WWW:	http://jcm.dsl.visi.com/freebsd/svnup/

svnup (and probably svnlite) was created to remove the need to install subversion and all its dependencies. The handbook should be modified to teach users to use them instead of subversion.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:34 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped