Bug 190351 - [UPDATE] devel/json-c update to version 0.12
Summary: [UPDATE] devel/json-c update to version 0.12
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 192687 (view as bug list)
Depends on:
Blocks: 192700
  Show dependency treegraph
 
Reported: 2014-05-28 22:20 UTC by Eero Hänninen
Modified: 2014-08-19 08:51 UTC (History)
3 users (show)

See Also:


Attachments
file.diff (1.28 KB, patch)
2014-05-28 22:20 UTC, Eero Hänninen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eero Hänninen 2014-05-28 22:20:00 UTC
- version update to 0.12
- added LICENSE
- added USES libtool
- added STRIP

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2014-05-28 22:20:05 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 2 Edwin Groothuis freebsd_committer 2014-05-28 22:20:05 UTC
Maintainer of devel/json-c,

Please note that PR ports/190351 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/190351

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 3 John Marino freebsd_committer 2014-08-16 10:19:36 UTC
miwi@, the maintainer, threw this back on the heap when he went on vacation.  Assume it's approved and move to patch ready.

However, that post-patch target looks suspicious, next committer should try INSTALL_TARGET=install-strip first.
Comment 4 John Marino freebsd_committer 2014-08-16 20:40:46 UTC
*** Bug 192687 has been marked as a duplicate of this bug. ***
Comment 5 John Marino freebsd_committer 2014-08-19 08:40:03 UTC
actually Bug 192687 looks more correct since it provides a new git hub tag.  I don't see how this one can update version without updating the tag.
Comment 6 Muhammad Moinur Rahman freebsd_committer 2014-08-19 08:43:32 UTC
In 192687 I have used USE_GITHUB properly. But in this one USE_GITHUB and MASTER_SITES both are present. I am not sure but these are mutually exclusive .. Isn't it?
Comment 7 John Marino freebsd_committer 2014-08-19 08:45:28 UTC
I used your patch but removed the post-install target and added INSTALL_TARGET=install-strip instead.
Comment 8 Muhammad Moinur Rahman freebsd_committer 2014-08-19 08:46:45 UTC
One more thing is from my poudriere log and diff it's obvious that there are some changes in pkg-plist too. The reflection of which I can't see in this patch.
Comment 9 commit-hook freebsd_committer 2014-08-19 08:49:10 UTC
A commit references this bug:

Author: marino
Date: Tue Aug 19 08:49:08 UTC 2014
New revision: 365366
URL: http://svnweb.freebsd.org/changeset/ports/365366

Log:
  devel/json-c: Upgrade version 0.11 => 0.12, add MIT license

  PR:		190351
  Submitted by:	Eoro Hanninen
  Alternate by:	Muhammad Rahman
  Tweaked by:	marino

Changes:
  head/devel/json-c/Makefile
  head/devel/json-c/distinfo
  head/devel/json-c/pkg-plist
Comment 10 John Marino freebsd_committer 2014-08-19 08:51:28 UTC
in any case, poudriere is happy with your version plus my tweak.