Bug 190791 - [patch] update astro/gpsbabel
Summary: [patch] update astro/gpsbabel
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-08 13:43 UTC by Gleb Smirnoff
Modified: 2014-06-10 22:07 UTC (History)
2 users (show)

See Also:


Attachments
the patch (2.48 KB, patch)
2014-06-08 13:44 UTC, Gleb Smirnoff
amdmi3: maintainer-approval? (dev2)
Details | Diff
New patch (1.37 KB, patch)
2014-06-10 10:42 UTC, Oliver Heesakkers
dev2: maintainer-approval+
Details | Diff
missing file from my original patch (579 bytes, patch)
2014-06-10 11:16 UTC, Gleb Smirnoff
no flags Details | Diff
Complete patch (2.45 KB, patch)
2014-06-10 11:57 UTC, Oliver Heesakkers
dev2: maintainer-approval+
Details | Diff
Revised patch (2.41 KB, patch)
2014-06-10 12:38 UTC, Oliver Heesakkers
dev2: maintainer-approval+
Details | Diff
final version (4.70 KB, patch)
2014-06-10 18:57 UTC, Dmitry Marakasov
amdmi3: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb Smirnoff freebsd_committer 2014-06-08 13:43:29 UTC
Update astro/gpsbabel to newest version.
Comment 1 Gleb Smirnoff freebsd_committer 2014-06-08 13:44:12 UTC
Created attachment 143527 [details]
the patch
Comment 2 Oliver Heesakkers 2014-06-10 10:38:59 UTC
Thanks for the headsup and patch.

I'm not too happy with gpsbabel requiring all that GUI stuff. But as far as I can tell, it can still be used from the CLI and syntax hasn't changed.

I've added the 1.5.1 tarball to the ohos server, so that can be left in.

I've added LICENSE (found in COPYING) and rewritten LIB_DEPENDS to please portlint.


You added:

EXTRA_PATCHES+=	${PATCHDIR}/extra-patch-mkstyle

but I don't see that file, so I'll remove that from the patch I'm about to attach here.
Comment 3 Oliver Heesakkers 2014-06-10 10:42:46 UTC
Created attachment 143612 [details]
New patch

New (intermediary) patch addressing some points. glebius@ might still want to add mkstyle patch.
Comment 4 Gleb Smirnoff freebsd_committer 2014-06-10 11:16:37 UTC
Created attachment 143613 [details]
missing file from my original patch
Comment 5 Gleb Smirnoff freebsd_committer 2014-06-10 11:17:15 UTC
QT != GUI, gpsbabel is still a command line tool.
Comment 6 Oliver Heesakkers 2014-06-10 11:55:54 UTC
(In reply to Gleb Smirnoff from comment #5)
> QT != GUI, gpsbabel is still a command line tool.

I'm aware of that, but just to build gpsbabel 1.5.1 I had to install or see getting pulled in:
qt4-xml-4.8.6
qt4-network-4.8.6
qt4-xmlpatterns-4.8.6
qt4-svg-4.8.6
qt4-opengl-4.8.6
qt4-script-4.8.6
qt4-sql-4.8.6
gstreamer-0.10.36_2
orc-0.4.19_2
qt4-doc-4.8.6
qt4-clucene-4.8.6
sqlite3-3.8.4.3
qt4-declarative-4.8.6
gstreamer-plugins-0.10.36_4,3
qt4-sqlite-plugin-4.8.6
qt4-webkit-4.8.6
qt4-help-4.8.6
qt4-assistant-4.8.6
qt4-linguist-4.8.6
qt4-qmake-4.8.6

The ldd output nearly triples in linecount compared to version 1.4.4.

I'm sure they had good reason, but I can't pretend to like it.

Anyway, I'll attach another patch that, as far as I'm concerned, is OK to be committed.
Comment 7 Oliver Heesakkers 2014-06-10 11:57:00 UTC
Created attachment 143615 [details]
Complete patch

Patch complete with mkstyle adjustment.
Comment 8 Dmitry Marakasov freebsd_committer 2014-06-10 11:58:01 UTC
The file was not missing, bugzilla just ate it. You can see it if you download original patch.

Also, EXTRA_PATCHES is for optional patches - here you should just rename extra-patch-* into patch-* and drop EXTRA_PATCHES.

The port also need LICENSE_FILE=${WRKSRC}/COPYING
Comment 9 Dmitry Marakasov freebsd_committer 2014-06-10 11:59:30 UTC
(I can do above mentioned changes myself if you're ok with them)
Comment 10 Dmitry Marakasov freebsd_committer 2014-06-10 12:00:53 UTC
Also we may consider preserving 1.4.4 as e.g. astro/gpsbabel14. I also don't like heavyweight depends for a simple commandline application.
Comment 11 Gleb Smirnoff freebsd_committer 2014-06-10 12:27:48 UTC
Erm, I don't see a lot of depends. There is a lot of build dependencies, but for runtime only QtCore is needed.
Comment 12 Oliver Heesakkers 2014-06-10 12:38:33 UTC
Created attachment 143617 [details]
Revised patch

Yes, I'm ok with those adjustments. New patch to reflect this.

Your comment (#10) about splitting up gpsbabel is certainly interesting. I would support such a move.
Comment 13 Gleb Smirnoff freebsd_committer 2014-06-10 12:44:20 UTC
I don't think this is a huge dependencies list:

glebius@think:~:|>ldd `which gpsbabel`
/usr/local/bin/gpsbabel:
        libusb.so.3 => /usr/lib/libusb.so.3 (0x8009c3000)
        libm.so.5 => /lib/libm.so.5 (0x800bd6000)
        libQtCore.so.4 => /usr/local/lib/qt4/libQtCore.so.4 (0x800e00000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x801303000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x8015c3000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x8017df000)
        libc.so.7 => /lib/libc.so.7 (0x8019ed000)
        libthr.so.3 => /lib/libthr.so.3 (0x801d86000)
        libz.so.6 => /lib/libz.so.6 (0x801fab000)
        libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0x8021c1000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x8023c2000)
        libintl.so.9 => /usr/local/lib/libintl.so.9 (0x8026ca000)
        libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x8028d4000)
        libpcre.so.3 => /usr/local/lib/libpcre.so.3 (0x802bce000)
glebius@think:~:|>pkg info -d gpsbabel
gpsbabel-1.5.1:
        qt4-corelib-4.8.6
        pcre-8.34_1
        glib-2.36.3_2
        gettext-0.18.3.1_1
glebius@think:~:|>
Comment 14 Dmitry Marakasov freebsd_committer 2014-06-10 18:57:23 UTC
Created attachment 143650 [details]
final version

 (In reply to Gleb Smirnoff from comment #13)
> I don't think this is a huge dependencies list:

It is. You're showing run depends, however it also has qt4-linguist as build-depend, and that in turn pulls qt4-gui and qt4-webkit, very heavy and completely unrelated ports. This may be the problem if Qt ports granularity, but it's still a problem.

Anyway, see the final version of a patch with minor additional fixes.

And if it's agreed, I'm repocopying gpsbabel14 before the update.
Comment 15 Oliver Heesakkers 2014-06-10 20:10:58 UTC
I (maintainer) approve the final version and agree with the repocopy.
Comment 16 commit-hook freebsd_committer 2014-06-10 22:04:52 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Jun 10 22:03:57 UTC 2014
New revision: 357391
URL: http://svnweb.freebsd.org/changeset/ports/357391

Log:
  - Preserve version 1.4.4 of astro/gpsbabel as astro/gpsbabel14

  Newer gpsbabel version needlessly pulls in heavyweight dependencies
  (such as qt4-gui, qt4-webkit) via qt4-linguist, and until that's
  resolved, it's useful to keep around older version which doesn't
  have such problem.

  PR:		190791
  Approved by:	dev2@heesakkers.info (maintainer)

Changes:
  head/astro/Makefile
  head/astro/gpsbabel14/
  head/astro/gpsbabel14/Makefile
  head/astro/gpsbabel14/files/extra-patch-libusb
  head/astro/gpsbabel14/files/patch-libusb
Comment 17 commit-hook freebsd_committer 2014-06-10 22:06:53 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Jun 10 22:06:17 UTC 2014
New revision: 357392
URL: http://svnweb.freebsd.org/changeset/ports/357392

Log:
  - Update to 1.5.1
  - Add LICENSE
  - Convert extra-patch'es to plain patches

  PR:		190791
  Submitted by:	glebius
  Approved by:	Oliver Heesakkers <dev2@heesakkers.info> (maintainer)

Changes:
  head/astro/gpsbabel/Makefile
  head/astro/gpsbabel/distinfo
  head/astro/gpsbabel/files/extra-patch-libusb
  head/astro/gpsbabel/files/patch-libusb
  head/astro/gpsbabel/files/patch-mkstyle