Bug 190939 - Panic when trying to boot FreeBSD-10.0-STABLE-amd64-20140608-r267232-bootonly.iso via USB-CDRW drive
Summary: Panic when trying to boot FreeBSD-10.0-STABLE-amd64-20140608-r267232-bootonly...
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.0-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-11 17:48 UTC by Vladislav V. Prodan
Modified: 2018-05-28 19:45 UTC (History)
7 users (show)

See Also:


Attachments
a picture with the phone the kernel panic (304.53 KB, image/jpeg)
2014-06-11 17:48 UTC, Vladislav V. Prodan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav V. Prodan 2014-06-11 17:48:05 UTC
Created attachment 143684 [details]
a picture with the phone the kernel panic

I tried to boot from the FreeBSD-10.0-STABLE-amd64-20140608-r267232-bootonly.iso via USB-CDRW drive, but got the kernel panic :(

I was able to boot from the live-CD MFSBSD 10.0 RELEASE without problems.

...
cd0 at umass-sim0 bus 0 scbus8 target 0 lun 0
cd0: <ASUS SDRW-08D2S-U B302> Removable CD-ROM SCSI-0 device
cd0: 40.000MB/s transfers
cd0: cd present [87875 x 2048 byte records]
cd0: quirks=0x10<10_BYTE_ONLY>
(cd0:umass-sim0:0:0:0): READ(10). CDB: 28 00 00 01 57 42 00 00 01 00
(cd0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(cd0:umass-sim0:0:0:0): SCSI status: Check Condition
(cd0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for t                                                             his track)
(cd0:umass-sim0:0:0:0): Error 6, Unretryable error
(cd0:umass-sim0:0:0:0): cddone: got error 0x6 back
(cd0:umass-sim0:0:0:0): READ(10). CDB: 28 00 00 01 57 42 00 00 01 00
(cd0:umass-sim0:0:0:0): CAM status: SCSI Status Error
(cd0:umass-sim0:0:0:0): SCSI status: Check Condition
(cd0:umass-sim0:0:0:0): SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for t                                                             his track)

...

hostb0@pci0:0:0:0:      class=0x060000 card=0x96001022 chip=0x96001022 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices [AMD]'
    device     = 'RS780 Host Bridge'
    class      = bridge
    subclass   = HOST-PCI
...
ohci4@pci0:0:20:5:      class=0x0c0310 card=0x37001565 chip=0x43991002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices [AMD] nee ATI'
    device     = 'SB7x0/SB8x0/SB9x0 USB OHCI2 Controller'
    class      = serial bus
    subclass   = USB
Comment 1 Andriy Gapon freebsd_committer 2014-06-12 09:25:59 UTC
Try burning a different disk. Could be bad media.
Comment 2 Vladislav V. Prodan 2014-06-12 10:13:16 UTC
(In reply to Andriy Gapon from comment #1)
> Try burning a different disk. Could be bad media.

So all the contents read and booting from this CD! 
The error occurred because of the failure to mount root partition!
Comment 3 Rick Miller 2014-07-01 15:26:31 UTC
I am also experiencing a similar, seemingly related, problem.  Here is a link to the message sent to -stable@ which includes dmesg output and screenshots of the error.

http://docs.freebsd.org/cgi/getmsg.cgi?fetch=9921776+0+current/freebsd-stable
Comment 4 Rick Miller 2014-07-09 12:07:43 UTC
Adding the fact that the firmware on the DL360p G8 was upgraded and continues to experience this issue with the FreeBSD project generated bootonly ISO.
Comment 5 Rick Miller 2014-07-17 12:53:02 UTC
This behavior has been observed on:

HP DL360p G8
Dell 1950
Dell R620
Comment 6 Sean Bruno freebsd_committer 2014-07-17 22:05:35 UTC
Hiren:

I suspect  you have access to these types of machines.  :-)

Can you validate this failure case?
Comment 7 Sean Bruno freebsd_committer 2014-07-17 22:08:40 UTC
Alexander:  There's a CAM error code in the attachment that seems odd.  Did the old ATA driver handle this?
Comment 8 Rick Miller 2014-08-19 12:39:35 UTC
I worked around this issue by replacing the bootonly ISO with a customized mfsBSD disk image.  The project's website is at http://mfsbsd.vx.sk with a link to it's github repo.
Comment 9 Sean Bruno freebsd_committer 2015-05-07 15:38:19 UTC
Glen:

Was there a time where the CD ISO images didn't work?
Comment 10 Glen Barber freebsd_committer 2015-05-07 15:42:17 UTC
It is very possible there was a problem with this image, but this is too far back (almost a year now) for me to remember specifically.
Comment 11 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:45:03 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.