Bug 190993 - devel/git failes on poudriere package phase [ fix patch included ]
devel/git failes on poudriere package phase [ fix patch included ]
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: --- Affects Some People
Assigned To: Wesley Shields
:
: 191032 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-13 08:08 UTC by Vikash Badal
Modified: 2014-06-16 16:06 UTC (History)
1 user (show)

See Also:


Attachments
patch to fix pkg-plist (1.64 KB, patch)
2014-06-13 08:08 UTC, Vikash Badal
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vikash Badal 2014-06-13 08:08:04 UTC
Created attachment 143735 [details]
patch to fix pkg-plist

to replicate:
poudriere testport -o devel/git -j RELENG_10_0_amd64



====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%PORTDOCS%%%%DOCSDIR%%/technical/api-hashmap.html
Error: Orphaned: %%PORTDOCS%%%%DOCSDIR%%/technical/api-hashmap.txt
Error: Orphaned: %%PORTDOCS%%%%DOCSDIR%%/technical/bitmap-format.txt
===> Checking for directories owned by MTREEs
===> Checking for directories handled by dependencies
===> Checking for items in pkg-plist which are not in STAGEDIR
Error: Missing: %%PORTDOCS%%%%DOCSDIR%%/RelNotes/1.9.4.txt
Error: Missing: %%PORTDOCS%%%%DOCSDIR%%/technical/api-hash.html
Error: Missing: %%PORTDOCS%%%%DOCSDIR%%/technical/api-hash.txt
===> Error: Plist issues found.
*** [check-plist] Error code 1


patch to fix attached:
Comment 1 Mark Linimon freebsd_committer 2014-06-13 08:42:34 UTC
Over to maintainer.
Comment 2 commit-hook freebsd_committer 2014-06-16 16:06:13 UTC
A commit references this bug:

Author: wxs
Date: Mon Jun 16 16:05:18 UTC 2014
New revision: 358019
URL: http://svnweb.freebsd.org/changeset/ports/358019

Log:
  Fix plist.

  PR:		190993
  Submitted by:	Vikash Badal <vikashb@where-ever.za.net>

Changes:
  head/devel/git/pkg-plist
Comment 3 Wesley Shields freebsd_committer 2014-06-16 16:06:48 UTC
*** Bug 191032 has been marked as a duplicate of this bug. ***