Bug 191040 - [em] netif hangs the system if interface is cabled and configured but there is no link
Summary: [em] netif hangs the system if interface is cabled and configured but there i...
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.0-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-net mailing list
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2014-06-14 22:09 UTC by jjasen
Modified: 2018-11-06 14:27 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jjasen 2014-06-14 22:09:21 UTC
In a case where an em interface is configured via rc.conf, where the network cable is plugged in, but there is no link on the cable, netif will hang the system as it attempts configuration. I believe permanently, but only observed for up to 15 minutes.

This does not happen when there is no cable connected, nor under normal circumstances of having an rc.conf configuration entry and having a live network cable.

ifconfig itself does not cause this problem, as I could plug the dead cable in and assign addresses/bring up the interface to my hearts content.

I believe the problem is in /etc/rc.d/netif, as repeating the above experiment and calling netif start em$dev-num causes it to hang. This is more curable than on boot, as netif will then respond to shell commands to background the process and responds to kill. On initial boot, there is no such luxury.

I also have not observed this case with other interface drivers.

While this scenario is a corner case, it can cause issues in situations where you are provisioning new services, or preparing a server for new services.

http://lists.freebsd.org/pipermail/freebsd-net/2014-June/038932.html
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-06-15 02:30:57 UTC
Over to maintainers.
Comment 2 Eugene Grosbein freebsd_committer 2018-10-04 05:24:08 UTC
Is it still a problem for 10.4-RELEASE or 11.2-RELEASE?