Bug 191061 - multimedia/totem fails to build python2.7/pthread.h:285:42: error: typedef redefinition with different types ('struct pthread_st *' vs 'struct pthread *')
Summary: multimedia/totem fails to build python2.7/pthread.h:285:42: error: typedef re...
Status: Closed DUPLICATE of bug 191744
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-15 15:06 UTC by mikhail.rokhin
Modified: 2014-07-11 16:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.rokhin 2014-06-15 15:06:18 UTC
gmake[6]: Entering directory `/usr/ports/multimedia/totem/work/totem-2.32.0/bindings/python'
  CC     totem_python_la-override_common.lo
  CC     totem_python_la-totem.lo
In file included from totem.override:7:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:285:42: error: typedef redefinition with
      different types ('struct pthread_st *' vs 'struct pthread *')
In file included from override_common.ctypedef struct  pthread_st              *pthread_t;:
32:
                                         ^In file included from 
/usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
/usr/include/sys/_pthreadtypes.h:65:27: note: previous definition is here
In file included from typedef struct  pthread                 *pthread_t;/usr/local/include/glib-2.0/glib/deprecated/gthread.h
:124                                         ^:

/usr/local/include/python2.7/pthread.h:285:42: error: typedef redefinition with
      In file included from differenttotem.override :types7 :
('struct pthread_st *' vs 'struct pthread *')In file included from /usr/local/include/pygtk-2.0/pygobject.h
:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:286:42: error: typedef redefinition with
      different types ('struct pthread_attr_st *' vs 'struct pthread_attr *')
typedef struct  pthread_st              *pthread_t;
                                         ^typedef struct  pthread_attr_st         *pthread_attr_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:68:31: note: previous definition is here

typedef struct  pthread_attr            *pthread_attr_t;/usr/include/sys/_pthreadtypes.h
:65                                         ^:
27: note: previous definition is here
In file included from totem.override:7:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:typedef struct  pthread                 *pthread_t;7
:
In file included from                                          ^/usr/local/include/glib-2.0/glib.h
:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:288:42: error: typedef redefinitionIn file included from  override_common.cwith:
32      :
differentIn file included from  /usr/local/include/pygtk-2.0/pygobject.htypes: 7('int' vs 'struct pthread_once'):
In file included from 
/usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:286:42: error: typedef redefinition with
      different types ('struct pthread_attr_st *' vs 'struct pthread_attr *')
typedef int                              pthread_once_t;typedef struct  pthread_attr_st         *pthread_attr_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:68:31: note: previous definition is here

                                         ^
typedef struct  pthread_attr            *pthread_attr_t;/usr/include/sys/_pthreadtypes.h
:74                                         ^:
30: note: previous definition is here
In file included from override_common.c:32:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from typedef struct  pthread_once            pthread_once_t;/usr/local/include/glib-2.0/glib.h
:109                                        ^:

In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:288:42: error: In file included from totem.override:7:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:289:42: error: typedef redefinition with
      different types ('int' vs 'struct pthread_mutex_attr *')
typedef redefinition with
      different types ('int' vs 'struct pthread_once')
typedef int                              pthread_mutexattr_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:70:36: notetypedef int                              pthread_once_t;: 
previous                                         ^ 
definition is here/usr/include/sys/_pthreadtypes.h
:74:30: note: previous definition is here
typedef struct  pthread_mutex_attr      *pthread_mutexattr_t;
                                         ^
typedef struct  pthread_once            pthread_once_t;
                                        ^
In file included from totem.override:7:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:In file included from 109override_common.c:
:In file included from 32/usr/local/include/glib-2.0/glib/deprecated/gthread.h:
:In file included from 124/usr/local/include/pygtk-2.0/pygobject.h:
:7/usr/local/include/python2.7/pthread.h:
:In file included from 290/usr/local/include/glib-2.0/glib.h::42109::
 In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:error124: :
/usr/local/include/python2.7/pthread.htypedef: 289redefinition: 42with:
       different errortypes:  ('struct pthread_mutex_st *' vs 'struct pthread_mutex *')typedef
 redefinition with
      different types ('int' vs 'struct pthread_mutex_attr *')
typedef int                              pthread_mutexattr_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:70:36: note: previous definition is here
typedef struct  pthread_mutex_attr      *pthread_mutexattr_t;
                                         ^
In file included from override_common.c:32:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:290:42: error: typedef redefinition with
      different types ('struct pthread_mutex_st *' vs 'struct pthread_mutex *')
typedef struct  pthread_mutex_st        *pthread_mutex_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:69:32: note: previous definition is here
typedef struct  pthread_mutex           *pthread_mutex_t;
                                         ^
In file included from override_common.c:32:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:291:42: error: typedef redefinition with
      different types ('int' vs 'struct pthread_cond_attr *')
typedef struct  pthread_mutex_st        *pthread_mutex_t;
typedef int                              pthread_condattr_t;
                                         ^
                                         ^
/usr/include/sys/_pthreadtypes.h:72:35:/usr/include/sys/_pthreadtypes.h :69:note32: : previous definition is here
typedef struct  pthread_cond_attr       *pthread_condattr_t;
                                         ^
In file included from override_common.c:32:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:292:42: error: typedef redefinition with
      different types ('struct pthread_cond_st *' vs 'struct pthread_cond *')
typedef struct  pthread_cond_st         *pthread_cond_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:71:31: note: previous definition is here
note: previous definition is heretypedef struct  pthread_cond            *pthread_cond_t;

                                         ^
typedef struct  pthread_mutex           *pthread_mutex_t;
In file included from override_common.c:32:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:293:42: error: typedef redefinition with
      different types                                          ^('int' vs 'struct pthread_rwlockattr *')

typedef int                              pthread_rwlockattr_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:76:36: note: In file included from totem.overrideprevious: 7definition:
 In file included from is/usr/local/include/pygtk-2.0/pygobject.h :here7:

In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:291:42: typedef struct  pthread_rwlockattr      *pthread_rwlockattr_t;
error:                                          ^
typedef redefinition with
      different types ('int' vs 'struct pthread_cond_attr *')
In file included from override_common.c:32:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from typedef int                              pthread_condattr_t;/usr/local/include/glib-2.0/glib.h
:109                                         ^:

In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/include/sys/_pthreadtypes.h:/usr/local/include/python2.7/pthread.h72::29435::42 : note: error: previous definitiontypedef  isredefinition  herewith

      different types
      ('struct pthread_rwlock_st *' vs 'struct pthread_rwlock *')
typedef struct  pthread_cond_attr       *pthread_condattr_t;
                                         ^
typedef struct  pthread_rwlock_st       *pthread_rwlock_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:75:33: note: previousIn file included from  totem.overridedefinition: 7is:
 In file included from here/usr/local/include/pygtk-2.0/pygobject.h:
7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:292:42typedef struct  pthread_rwlock          *pthread_rwlock_t;:
                                          ^
error: typedef redefinition with
      different types ('struct pthread_cond_st *' vs 'struct pthread_cond *')
typedef struct  pthread_cond_st         *pthread_cond_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:71:31: note: previous definition is here
typedef struct  pthread_cond            *pthread_cond_t;
                                         ^
In file included from totem.override:7:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:293:42: error: typedef redefinition with
      different types ('int' vs 'struct pthread_rwlockattr *')
typedef int                              pthread_rwlockattr_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:76:36: note: previous definition is here
typedef struct  pthread_rwlockattr      *pthread_rwlockattr_t;
                                         ^
In file included from totem.override:7:
In file included from /usr/local/include/pygtk-2.0/pygobject.h:7:
In file included from /usr/local/include/glib-2.0/glib.h:109:
In file included from /usr/local/include/glib-2.0/glib/deprecated/gthread.h:124:
/usr/local/include/python2.7/pthread.h:294:42: error: typedef redefinition with
      different types
      ('struct pthread_rwlock_st *' vs 'struct pthread_rwlock *')
typedef struct  pthread_rwlock_st       *pthread_rwlock_t;
                                         ^
/usr/include/sys/_pthreadtypes.h:75:33: note: previous definition is here
typedef struct  pthread_rwlock          *pthread_rwlock_t;
                                         ^
9 errors generated.
gmake[6]: *** [totem_python_la-override_common.lo] Error 1
gmake[6]: *** Waiting for unfinished jobs....
9 errors generated.
gmake[6]: *** [totem_python_la-totem.lo] Error 1
gmake[6]: Leaving directory `/usr/ports/multimedia/totem/work/totem-2.32.0/bindings/python'
gmake[5]: *** [all] Error 2
gmake[5]: Leaving directory `/usr/ports/multimedia/totem/work/totem-2.32.0/bindings/python'
gmake[4]: *** [all-recursive] Error 1
gmake[4]: Leaving directory `/usr/ports/multimedia/totem/work/totem-2.32.0/bindings'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/ports/multimedia/totem/work/totem-2.32.0'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/multimedia/totem/work/totem-2.32.0'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1


FreeBSD localhost 11.0-CURRENT FreeBSD 11.0-CURRENT #2 r267147: Fri Jun  6 15:14:17 MSK 2014     root@win98:/usr/obj/usr/src/sys/GENERIC  i386
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-06-16 02:17:23 UTC
Over to maintainers.
Comment 2 Jung-uk Kim freebsd_committer 2014-07-11 16:50:47 UTC

*** This bug has been marked as a duplicate of bug 191744 ***