Bug 191071 - net-im/loudmouth: Modernisation
Summary: net-im/loudmouth: Modernisation
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-15 21:10 UTC by Keith Gaughan
Modified: 2014-11-22 18:25 UTC (History)
2 users (show)

See Also:


Attachments
loudmouth.patch.txt (1.43 KB, patch)
2014-06-15 21:10 UTC, Keith Gaughan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Gaughan 2014-06-15 21:10:15 UTC
Created attachment 143816 [details]
loudmouth.patch.txt

The attached patch cleans up the port to use USES in place of USE_* where applicable, as well as setting LICENSE and using the modern LIB_DEPENDS style.

I haven't bumped PORTREVISION as none of the changes should require a rebuild.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-06-16 02:21:36 UTC
Over to maintainers.
Comment 2 commit-hook freebsd_committer 2014-11-22 18:25:34 UTC
A commit references this bug:

Author: kwm
Date: Sat Nov 22 18:25:09 UTC 2014
New revision: 373084
URL: https://svnweb.freebsd.org/changeset/ports/373084

Log:
  Add license lines.

  PR:		191071
  Submitted by:	Keith Gaughan <k@stereochro.me>

Changes:
  head/net-im/loudmouth/Makefile
Comment 3 Koop Mast freebsd_committer 2014-11-22 18:25:58 UTC
Added the license line, the rest of the changes where already done during general port cleanup sweeps. Thanks for the patch!