Bug 191424 - sysutils/cdrtools broken on powerpc64
Summary: sysutils/cdrtools broken on powerpc64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Marius Strobl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-26 21:31 UTC by Justin Hibbits
Modified: 2015-12-30 01:57 UTC (History)
2 users (show)

See Also:


Attachments
Log file for failed cdrtools build. (381.40 KB, text/plain)
2014-06-29 18:00 UTC, Justin Hibbits
no flags Details
Ports makefile that works (346 bytes, patch)
2014-06-30 04:04 UTC, Justin Hibbits
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Hibbits freebsd_committer 2014-06-26 21:31:04 UTC
When building sysutils/cdrtools for powerpc64, it fails on install with the following:

install: /wrkdirs/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/btcflash/OBJ/powerpc-freebsd-cc/btcflash: No such file or directory

Removing the line

CDRTLSTARGET=   ${ARCH:S/powerpc64/powerpc/}-freebsd-cc

From the makefile allows it to build and install just fine.
Comment 1 Marius Strobl freebsd_committer 2014-06-29 14:11:56 UTC
Could you please provide:
o the output of `uname -p` on powerpc64,
o the output of `make -VARCH` for powerpc64 in the directory of that port,
o its full build log on powerpc64 when not removing the CDRTLSTARGET line,
o the content of /wrkdirs/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/btcflash/OBJ/ after the build on powerpc64 when not removing the CDRTLSTARGET line.
Comment 2 Justin Hibbits freebsd_committer 2014-06-29 17:58:48 UTC
Seems I was incorrect in my thinking that removing the line fixed it.  This time it didn't. (Was going by memory)

(In reply to Marius Strobl from comment #1)
> Could you please provide:
> o the output of `uname -p` on powerpc64,

powerpc64

> o the output of `make -VARCH` for powerpc64 in the directory of that port,

powerpc64

> o its full build log on powerpc64 when not removing the CDRTLSTARGET line,

I'll attach.

> o the content of
> /wrkdirs/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/btcflash/OBJ/ after
> the build on powerpc64 when not removing the CDRTLSTARGET line.

work/cdrtools-3.00/btcflash/OBJ/powerpc64-freebsd-cc/
Comment 3 Justin Hibbits freebsd_committer 2014-06-29 18:00:24 UTC
Created attachment 144260 [details]
Log file for failed cdrtools build.
Comment 4 Justin Hibbits freebsd_committer 2014-06-30 04:04:23 UTC
Created attachment 144284 [details]
Ports makefile that works

The attached file is a working makefile diff for the port.  Since powerpc64 was the only correction, and only needed in one place, this makes that correction.
Comment 5 Marius Strobl freebsd_committer 2014-06-30 08:50:39 UTC
Hrm, confusing, previously the output of `uname -p` with powerpc64 on PS3 has been reported to be "powerpc" rather than "powerpc64". However, looking at the kernel source that should not have been the case, i. e. it ought to always have been "powerpc64". It's also unclear to me why your patch w/ ID 144284 makes a difference without any further patches at all given that ${CDRTLSTARGET} no longer should contain the string "powerpc64" in the first place at that point.

Anyway, could you please test how things work when you just, i. e. revert any other patches you may have, change:
CDRTLSTARGET=   ${ARCH:S/powerpc64/powerpc/}-freebsd-cc
to:
CDRTLSTARGET=   ${ARCH}-freebsd-cc
in the Makefile of the port?
Comment 6 Justin Hibbits freebsd_committer 2014-06-30 15:07:22 UTC
That's actually what I first tried, and got a compile error.  It appears cdrtools uses both `uname -p` and `uname -m` (just by behavior, haven't grepped).

My last patch actually already had the change you requested (CDRTLSTARGET=${ARCH}-freebsd-cc), so the full diff includes both changes.
Comment 7 John Marino freebsd_committer 2014-08-31 10:29:23 UTC
remove the word "stage" from title to prevent it from showing in search for unstaged ports.
Comment 8 RoadK1LL 2014-10-18 00:41:11 UTC
Exact same error on PowerMac G5 Dual Proc. FreeBSD 10.0 - Stable

Applied changes to makefile, stops at same location, same error & missing file location.
Comment 9 commit-hook freebsd_committer 2015-12-29 00:33:22 UTC
A commit references this bug:

Author: marius
Date: Tue Dec 29 00:33:00 UTC 2015
New revision: 404710
URL: https://svnweb.freebsd.org/changeset/ports/404710

Log:
  - Update to 3.01
  - Fix build when `uname -m` != `uname -p` [1]

  PR:		191424, 197794 [1]

Changes:
  head/sysutils/cdrtools/Makefile
  head/sysutils/cdrtools/distinfo
  head/sysutils/cdrtools/files/patch-DEFAULTS__Defaults.freebsd
  head/sysutils/cdrtools/files/patch-RULES__cc-gcc.rul
  head/sysutils/cdrtools/files/patch-include__schily__sha2.h
  head/sysutils/cdrtools/files/patch-readcd__readcd.1
  head/sysutils/cdrtools/pkg-descr
Comment 10 Marius Strobl freebsd_committer 2015-12-29 13:43:32 UTC
Please give the cdrtools port as of r404710 a try.
Comment 11 Marius Strobl freebsd_committer 2015-12-29 14:57:51 UTC
*** Bug 198287 has been marked as a duplicate of this bug. ***
Comment 12 Justin Hibbits freebsd_committer 2015-12-30 00:35:44 UTC
It built successfully, thanks!