Bug 191461 - Stage-enabled ports are not installed at all when NO_PKG_REGISTER is used.
Summary: Stage-enabled ports are not installed at all when NO_PKG_REGISTER is used.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Port Management Team
URL:
Keywords:
: 182347 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-28 15:02 UTC by kpaasial
Modified: 2021-09-21 08:43 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kpaasial 2014-06-28 15:02:13 UTC
I'm using comms/minicom here as an example. This is end of the log when I run 'make install NO_PKG_REGISTER=1' on it:

Making install in lib
Making install in src
 /bin/mkdir -p '/var/tmp/usr/ports/comms/minicom/work/stage/usr/local/bin'
  install  -s -o root -g wheel -m 555 minicom runscript ascii-xfr '/var/tmp/usr/ports/comms/minicom/work/stage/usr/local/bin'
 /bin/mkdir -p '/var/tmp/usr/ports/comms/minicom/work/stage/usr/local/bin'
 install  -o root -g wheel -m 555 xminicom '/var/tmp/usr/ports/comms/minicom/work/stage/usr/local/bin'
install -d -m 0755 /var/tmp/usr/ports/comms/minicom/work/stage/usr/local/etc/minicom
install -d -o root -g wheel -m 0755 /var/tmp/usr/ports/comms/minicom/work/stage/usr/local/share/doc/minicom
install  -o root -g wheel -m 444 /var/tmp/usr/ports/comms/minicom/work/minicom-2.7/AUTHORS /var/tmp/usr/ports/comms/minicom/work/stage/usr/local/share/doc/minicom/
install  -o root -g wheel -m 444 /var/tmp/usr/ports/comms/minicom/work/minicom-2.7/COPYING /var/tmp/usr/ports/comms/minicom/work/stage/usr/local/share/doc/minicom/
install  -o root -g wheel -m 444 /var/tmp/usr/ports/comms/minicom/work/minicom-2.7/ChangeLog /var/tmp/usr/ports/comms/minicom/work/stage/usr/local/share/doc/minicom/
(umask 022 && cd /var/tmp/usr/ports/comms/minicom/work/minicom-2.7 && /usr/bin/tar --exclude '*/Makefile*'  --exclude '*.orig' -chf - extras doc | /usr/bin/tar  -xf - -C  /var/tmp/usr/ports/comms/minicom/work/stage/usr/local/share/doc/minicom)
====> Compressing man pages (compress-man)
===>  Installing for minicom-2.7


It's clear that the install is done only on the stage directory and not for real on the system.

Should the NO_PKG_REGISTER feature work with stage-enable ports? The feature was working before staging was introduced and I can think of a few uses for it.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-07-04 01:18:33 UTC
Over to maintainers.
Comment 2 Baptiste Daroussin freebsd_committer 2021-08-18 13:06:13 UTC
*** Bug 182347 has been marked as a duplicate of this bug. ***
Comment 3 Baptiste Daroussin freebsd_committer 2021-08-18 13:06:54 UTC
the machinery is now in pkg, pkg register -N it what is required will be in pkg 1.17.3 or 1.18
Comment 4 commit-hook freebsd_committer 2021-09-21 08:43:06 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=aedc18359a342d7a3a1bb7c09820059175a24542

commit aedc18359a342d7a3a1bb7c09820059175a24542
Author:     Baptiste Daroussin <bapt@FreeBSD.org>
AuthorDate: 2021-09-21 08:40:03 +0000
Commit:     Baptiste Daroussin <bapt@FreeBSD.org>
CommitDate: 2021-09-21 08:40:03 +0000

    Mk/bsd.port.mk: fix NO_PKG_REGISTER

    Since we switched to pkg, NO_PKG_REGISTER was not working anymore.
    Since pkg 1.17.2 the pkg register command do support -N option which
    allows to bring back NO_PKG_REGISTER.

    PR:     191461

 Mk/bsd.port.mk | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)