Bug 191591 - [vt] vt_vga driver produces corrupted output with fonts other than 8 pixels wide
Summary: [vt] vt_vga driver produces corrupted output with fonts other than 8 pixels wide
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: Jean-Sébastien Pédron
URL:
Keywords: vt
Depends on:
Blocks:
 
Reported: 2014-07-03 21:35 UTC by Ed Maste
Modified: 2014-08-23 02:37 UTC (History)
1 user (show)

See Also:


Attachments
QEMU screenshot of vt_vga with gallant font loaded (12.21 KB, image/png)
2014-07-03 21:36 UTC, Ed Maste
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2014-07-03 21:35:52 UTC
To reproduce run "vidcontrol -f gallant" when using the vt_vga driver.
Resulting output appears as in the attached screenshot.  
vt_efifb or i915 framebuffer is fine.


Gallant is 12 px wide.  It looks like character positions that don't start at an 8-bit boundary (i.e., every other column) get shifted left to the previous 8-bit boundary, overwriting part of the previous column's character.
Comment 1 Ed Maste freebsd_committer 2014-07-03 21:36:32 UTC
Created attachment 144382 [details]
QEMU screenshot of vt_vga with gallant font loaded
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2014-07-08 02:09:44 UTC
Notify possibly interested party.
Comment 3 Ed Maste freebsd_committer 2014-08-23 02:37:59 UTC
Original fix for this issue (r269471) introduced a significant performance regression. New interface introduced in r270322 restores adequate console speed.