Bug 191635 - Update port mail/assp to 14158, add STAGE support, fix MySQL dependency
Summary: Update port mail/assp to 14158, add STAGE support, fix MySQL dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
: 186610 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-05 16:13 UTC by rnejdl
Modified: 2014-07-06 15:33 UTC (History)
1 user (show)

See Also:


Attachments
assp-14158.diff (12.82 KB, patch)
2014-07-05 16:13 UTC, rnejdl
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rnejdl 2014-07-05 16:13:18 UTC
Created attachment 144428 [details]
assp-14158.diff

This PR/patch updates ASSP to 14158 version.  It rebuilds the port significantly to support STAGE (thanks to Guido Falsi) for his significantly help.  Fixes a missing dependency when MySQL is selected.
Comment 1 Guido Falsi freebsd_committer 2014-07-05 22:34:16 UTC
*** Bug 186610 has been marked as a duplicate of this bug. ***
Comment 2 Guido Falsi freebsd_committer 2014-07-05 23:15:47 UTC
I'm testing the port.

DO you confirm you want to take maintainership for this port? The patch does not include such change.

Thanks!
Comment 3 rnejdl 2014-07-06 00:38:25 UTC
Sorry, yes, I confirm I want to retain maintainership.   I hadn't had to fix that ever so that's why it got missed.

Rusty Nejdl
Comment 4 Guido Falsi freebsd_committer 2014-07-06 15:33:37 UTC
Committed. Thanks!
Comment 5 commit-hook freebsd_committer 2014-07-06 15:33:39 UTC
A commit references this bug:

Author: madpilot
Date: Sun Jul  6 15:32:48 UTC 2014
New revision: 360926
URL: http://svnweb.freebsd.org/changeset/ports/360926

Log:
  - Update to 1.9.9.14158
  - Stagify
  - Add missing dependency when MYSQL option is enabled
  - Assign maintainership to submitter

  PR:		191635
  Sumitted by:	rnejdl@ringofsaturn.com

Changes:
  head/mail/assp/Makefile
  head/mail/assp/distinfo
  head/mail/assp/files/patch-assp.pl
  head/mail/assp/files/pkg-install.in
  head/mail/assp/pkg-plist