Bug 191758 - [PATCH][STAGE] lang/twelf: Update to 1.7.1, Take MAINTAINERship
[PATCH][STAGE] lang/twelf: Update to 1.7.1, Take MAINTAINERship
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: --- Affects Some People
Assigned To: FreeBSD ports mailing list
: easy
Depends on:
  Show dependency treegraph
Reported: 2014-07-09 06:18 UTC by Timothy Beyer
Modified: 2014-09-06 05:16 UTC (History)
2 users (show)

See Also:

twelf.diff (35.08 KB, patch)
2014-07-09 06:18 UTC, Timothy Beyer
no flags Details | Diff
Output of "port test" (15.49 KB, text/x-log)
2014-07-09 08:38 UTC, Timothy Beyer
no flags Details
twelfv3.diff (35.13 KB, patch)
2014-07-15 07:33 UTC, Timothy Beyer
no flags Details | Diff
twelf-success_redports.diff (35.20 KB, patch)
2014-07-15 08:45 UTC, Timothy Beyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Beyer 2014-07-09 06:18:27 UTC
Created attachment 144533 [details]

- Update port to latest version (tested targets: stage, check-plist, package,
install and verified that it loaded twelf .elf files correctly)

- Implemented STAGE support

- Implement support for license (now 2-clause BSD, no longer restricted)

- Modernized build significantly, simplifying several steps

- Set my email as the maintainer (I would like to maintain it if possible, no
one is currently the maintainer at the moment).

- Only use mlton for build for now (if smlnj port gets fixed, then I could
implement smlnj support as well, but mlton is far more industrial strength

Apply patch and build port

The included patch
Comment 1 Kubilay Kocak freebsd_committer 2014-07-09 07:29:50 UTC
To help get eyes on this and expedite committing your changes, may I suggest documenting the following in this issue:

1) portlint output (-AC flags)
2) Builds logs (attached or urls) for a few FreeBSD version/arch combinations

Tip: The following can help you with (2):

a) RedPorts(.org) - Sign up, wait for activation, test
b) poudriere (testport) on a few jails (#poudriere on freenode IRC for help)
c) ports-mgmt/porttools (`port test`) to test the full build/package cycle

This should give a committer the confidence they need to get this into the tree for you.
Comment 2 Timothy Beyer 2014-07-09 08:36:19 UTC
Here is the portlint output:

--- portlint_output.log begins here ---
> portlint -AC
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
WARN: Consider to set DEVELOPER=yes in /etc/make.conf
0 fatal errors and 2 warnings found.
--- portlint_output.log ends here ---

I use portlint with the -CA arguments on most of my submissions, but many of the other tools I have yet to become familiar.  I'll look into using one or all of them, particularly Redports.  I have an account there, I just haven't taken the time to use it yet.

In the meantime, I just ran "port test" to a log file, and I'll include that as an attachment.
Comment 3 Timothy Beyer 2014-07-09 08:38:18 UTC
Created attachment 144536 [details]
Output of "port test"

The following is an output of the command:

"sudo port test >>& test.log"
Comment 4 Timothy Beyer 2014-07-15 07:33:06 UTC
Created attachment 144680 [details]

- Same as the first patch, but handles INFO/texinfo dependencies properly.

For some reason on RedPorts when it tries to build print/texinfo, it fails on devel/gmake-lite.

I don't know the cause of the issue, but I strongly suspect that it has something to do with the way RedPorts works.  If that is not the case, I have no idea what else print/texinfo would actually need, perhaps that port should have additional dependencies.
Comment 5 Timothy Beyer 2014-07-15 08:45:48 UTC
Created attachment 144681 [details]

- Same as previous patches, except with smarter handling of print/texinfo and print/dvipsk-tetex as dependencies

10.0-RELEASE/amd64	success	4 minutes	Buildlog
10.0-RELEASE/i386	success	3 minutes	Buildlog

The "leftovers" on 9.2-RELEASE isn't very meaningful, as those were left over by dvipsk-tetex, not the port itself...

Comment 6 commit-hook freebsd_committer 2014-07-16 20:37:36 UTC
A commit references this bug:

Author: riggs
Date: Wed Jul 16 20:37:20 UTC 2014
New revision: 362110
URL: http://svnweb.freebsd.org/changeset/ports/362110

  - Update to latest upstream release 1.7.1
  - Assign maintainership to Timothy Beyer <beyert@cs.ucr.edu>
    (previously ports@)
  - General cleanup
  - Remove twelf from LEGAL (port is now BSD2CLAUSE licensed)

  PR:		191758
  Submitted by:	Timothy Beyer <beyert@cs.ucr.edu>
  Approved by:	mentors (implicit)