Bug 191834 - math/sage port fails with sub-package pynac during configure
Summary: math/sage port fails with sub-package pynac during configure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Stephen Montgomery-Smith
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-12 09:33 UTC by claus
Modified: 2014-07-21 12:57 UTC (History)
0 users

See Also:


Attachments
Replacement for files/patch-build_pkgs_pynac_spkg-install (484 bytes, patch)
2014-07-21 04:53 UTC, Stephen Montgomery-Smith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description claus 2014-07-12 09:33:27 UTC
The "configure" run for sub-package pynac of port math/sage fails because of
improper file mode of the extracted archive pynac-0.3.2.tar.bz2. All files in this
archive have group write enabled, and python module sys posts a warning, which
causes "configure" to interpret this as a missing python package "distutils".

Workaround (tested): extract pynac-0.3.2.tar.bz to some arbitrary location, remove group write permission from all files, set owner to root:wheel, and re-create the archive. Adjust SHA checksum in
work/sage-6.2/build/pkgs/pynac/checksums.ini.

Workaround2: change permissions for the port and make the port as a user.

Suggested fix: change build procedures to extract pynac-0.3.2.tar.bz2 with
"--no-same-permissions" OR get author of the pynac archive to set proper
permissions
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-07-20 18:42:58 UTC
Over to maintainer.
Comment 2 Stephen Montgomery-Smith freebsd_committer 2014-07-21 04:53:27 UTC
Created attachment 144828 [details]
Replacement for files/patch-build_pkgs_pynac_spkg-install
Comment 3 Stephen Montgomery-Smith freebsd_committer 2014-07-21 04:55:44 UTC
(In reply to claus from comment #0)
> The "configure" run for sub-package pynac of port math/sage fails because of
> improper file mode of the extracted archive pynac-0.3.2.tar.bz2. All files
> in this
> archive have group write enabled, and python module sys posts a warning,
> which
> causes "configure" to interpret this as a missing python package "distutils".
> 
> Workaround (tested): extract pynac-0.3.2.tar.bz to some arbitrary location,
> remove group write permission from all files, set owner to root:wheel, and
> re-create the archive. Adjust SHA checksum in
> work/sage-6.2/build/pkgs/pynac/checksums.ini.
> 
> Workaround2: change permissions for the port and make the port as a user.
> 
> Suggested fix: change build procedures to extract pynac-0.3.2.tar.bz2 with
> "--no-same-permissions" OR get author of the pynac archive to set proper
> permissions

I am going to try using the attached patch, which is a replacement for files/patch-build_pkgs_pynac_spkg-install.  So far the tests look good.  If it works, I'll probably commit it tomorrow.

Thank you for taking the time to identify the cause of this problem.

I'll also see about getting the fix upstream.
Comment 4 commit-hook freebsd_committer 2014-07-21 12:55:50 UTC
A commit references this bug:

Author: stephen
Date: Mon Jul 21 12:55:41 UTC 2014
New revision: 362432
URL: http://svnweb.freebsd.org/changeset/ports/362432

Log:
  - Unset group write priveleges in the pynac subpackage, so that it will build
    as root.

  PR:		191834
  Submitted by:	claus@endresconsulting.com

Changes:
  head/math/sage/files/patch-build_pkgs_pynac_spkg-install