Bug 191853 - dns/ldns: Fix issues with LibreSSL
Summary: dns/ldns: Fix issues with LibreSSL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Mark Felder
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2014-07-13 15:58 UTC by Vsevolod Stakhov
Modified: 2015-02-25 14:45 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
patch-ldns (4.68 KB, patch)
2014-07-13 15:58 UTC, Vsevolod Stakhov
no flags Details | Diff
Updated patch for ldns-1.6.17_3 (5.40 KB, patch)
2015-01-24 11:39 UTC, Bernard Spil
koobs: maintainer-approval+
Details | Diff
Poudriere build log with latest patch (47.21 KB, text/plain)
2015-01-24 11:40 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vsevolod Stakhov freebsd_committer 2014-07-13 15:58:38 UTC
Created attachment 144636 [details]
patch-ldns

The patch attached implements the following:
- remove ENGINE_load_cryptodev since it is not supported by libressl and unlikely required for openssl as well
- strip binaries during installation
- remove .la file from plist
- switch from USE_AUTOTOOLS= libtool to USES= libtool
Comment 1 Jaap Akkerhuis 2014-07-15 20:49:29 UTC
I have to check with upstream whether removing ENGINE_load_cryptodev is acceptable.
I understand that they are working on libressl support as well and there is no hurry yet.

       jaap
Comment 2 Jaap Akkerhuis 2014-07-17 11:32:43 UTC
The developers tell me that they solve this in the developer branch during the configure fase, so it will be in the next release and then the patch won't be necessary. You could consider using that method as base for a patch in case you cannot wait for a new release.

See <http://git.nlnetlabs.nl/ldns/> for details.

        jaap
Comment 3 Bernard Spil freebsd_committer 2015-01-24 10:22:16 UTC
Nothing in upstream ldns git changed for over a year. Suggest we implement a patch and assume next upstream version has this fixed.
Alternatively use https://github.com/Sp1l/ports/tree/master/dns/ldns with patch borrowed from OpenBSD.
Comment 4 Bernard Spil freebsd_committer 2015-01-24 11:39:13 UTC
Created attachment 152091 [details]
Updated patch for ldns-1.6.17_3

Some of the changes in the earlier patch by vsevolod@ have already appeared in the port. This is a merge of the remainder and making ENGINE_load_cryptodev conditional using autotools.
Comment 5 Bernard Spil freebsd_committer 2015-01-24 11:40:00 UTC
Created attachment 152092 [details]
Poudriere build log with latest patch
Comment 6 Jaap Akkerhuis 2015-01-26 11:52:04 UTC
Upstreams tells me that there will be a new Release out soon, to quote "over a week or so". It will have bug fixes and official support for new RRtypes. If you cannot wait that long ir if it gets delayed, we can always do the proposed patch.

BTW, latest change in the develop branch is less then two weeks ago, see <http://git.nlnetlabs.nl/ldns/?h=develop>.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-01-26 12:01:46 UTC
If you could approve the attached patch, that would be great :)
Comment 8 Bernard Spil freebsd_committer 2015-01-26 12:45:52 UTC
Oops... Sorry Jaap, hadn't checked all branches. There's still changes in the branch indeed.
Comment 9 Jaap Akkerhuis 2015-01-26 13:36:34 UTC
(In reply to Kubilay Kocak from comment #7)
The patch works fine, no problem with that.
Comment 10 Bernard Spil freebsd_committer 2015-02-22 10:11:01 UTC
Hi Jaap,

Any sight of a new version of ldns to be released? A month ago the next release was "soon"...

Kind regards, Bernard.
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-22 11:03:44 UTC
Bernard, the issue is approved and blocking on me. I'll get to this in the next 24 hours.
Comment 12 Jaap Akkerhuis 2015-02-23 15:50:04 UTC
(In reply to Bernard Spil from comment #10)
I checked what the wait is and gor told that implementing DANE unearthed quite some unexpected problems. Apologies from the upstream as well.

They say, ASAP, but won't commit to an estimate how log it will take.
Comment 13 commit-hook freebsd_committer 2015-02-25 14:45:39 UTC
A commit references this bug:

Author: feld
Date: Wed Feb 25 14:44:43 UTC 2015
New revision: 379920
URL: https://svnweb.freebsd.org/changeset/ports/379920

Log:
  Fix issues with LibreSSL

  PR:		191853
  Approved by:	maintainer

Changes:
  head/dns/ldns/Makefile
  head/dns/ldns/files/
  head/dns/ldns/files/patch-drill_Makefile.in
  head/dns/ldns/files/patch-examples_Makefile.in
  head/dns/ldns/files/patch-examples_configure.ac
  head/dns/ldns/files/patch-examples_ldns-signzone.c