Bug 191877 - New port: devel/libosmocore - Common library for all Osmocom projects
New port: devel/libosmocore - Common library for all Osmocom projects
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: --- Affects Only Me
Assigned To: Kurt Jaeger
:
Depends on:
Blocks: 191878 191879
  Show dependency treegraph
 
Reported: 2014-07-15 14:18 UTC by Nikola Kolev
Modified: 2014-08-11 18:14 UTC (History)
2 users (show)

See Also:


Attachments
devel/libosmocore files (5.85 KB, text/plain)
2014-07-15 14:18 UTC, Nikola Kolev
no flags Details
fixed issues after make check-plist and make stage-qa (6.19 KB, text/plain)
2014-08-01 09:26 UTC, Nikola Kolev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikola Kolev 2014-07-15 14:18:41 UTC
Created attachment 144687 [details]
devel/libosmocore files
Comment 1 Kurt Jaeger freebsd_committer 2014-07-16 06:45:33 UTC
I'll take it.
Comment 2 Kurt Jaeger freebsd_committer 2014-07-17 04:24:15 UTC
pkg-plist issue with the new doxygen.

I'm already working on this in PR 190943
Comment 3 Nikola Kolev 2014-07-29 08:17:38 UTC
Can you provide some log with the issue with pkg-plist so I will try to fix it?
Comment 4 Nikola Kolev 2014-08-01 09:26:04 UTC
Created attachment 145201 [details]
fixed issues after make check-plist and make stage-qa

I missed to execute 'make check-plist' and 'make stage-qa' before commit the previous files. This one contains the fixed issues reported by check-plist and stage-qa.
Comment 5 Kurt Jaeger freebsd_committer 2014-08-01 11:16:47 UTC
I'll test, having a stretch of time the next few days.
Comment 6 Nikola Kolev 2014-08-07 06:41:47 UTC
Hi Kurt,

I've submitted few more ports dependent from this one and they are ready to be committed to the ports tree but it cannot be done until this one is missing. Please give me information how to reproduce the doxygen issue and I will try to fix it. I don't have any problems making the port.
Comment 7 commit-hook freebsd_committer 2014-08-10 07:17:21 UTC
A commit references this bug:

Author: pi
Date: Sun Aug 10 07:16:24 UTC 2014
New revision: 364505
URL: http://svnweb.freebsd.org/changeset/ports/364505

Log:
  New port: devel/libosmocore

  libosmocore is a library with various utility functions that were
  originally developed as part of the OpenBSC project, but which are
  of a more generic nature and thus useful to (at least) other programs
  that we develop in the sphere of Free Software / Open Source mobile
  communications.

  WWW: http://bb.osmocom.org/trac/wiki/libosmocore

  PR:		191877
  Submitted by:	koue@chaosophia.net

Changes:
  head/devel/Makefile
  head/devel/libosmocore/
  head/devel/libosmocore/Makefile
  head/devel/libosmocore/distinfo
  head/devel/libosmocore/files/
  head/devel/libosmocore/files/patch-Doxyfile.codec.in
  head/devel/libosmocore/files/patch-Doxyfile.core.in
  head/devel/libosmocore/files/patch-Doxyfile.gsm.in
  head/devel/libosmocore/files/patch-Doxyfile.vty.in
  head/devel/libosmocore/pkg-descr
  head/devel/libosmocore/pkg-plist
Comment 8 Kurt Jaeger freebsd_committer 2014-08-10 07:18:09 UTC
Comitted with all the doxygen-glory 8-}

Thank you very much!
Comment 9 Kurt Jaeger freebsd_committer 2014-08-10 08:54:13 UTC
Build fails on 9.1 amd64:

http://people.freebsd.org/~pi/misc/libosmocore-0.6.6.log
Comment 10 John Marino freebsd_committer 2014-08-11 09:31:10 UTC
(In reply to Kurt Jaeger from comment #9)
> Build fails on 9.1 amd64:
> 
> http://people.freebsd.org/~pi/misc/libosmocore-0.6.6.log

Koue, can you investigate?  I can't close out the follow-on PRs because this one got reopened.
Comment 11 Kurt Jaeger freebsd_committer 2014-08-11 10:47:01 UTC
> Koue, can you investigate?  I can't close out the follow-on PRs because this
> one got reopened.

He's at it. That's a case where I would like to assign the PR to the
submitter 8-)
Comment 12 Nikola Kolev 2014-08-11 10:59:17 UTC
Yes, will try to find out why build fails.
Comment 13 Nikola Kolev 2014-08-11 13:11:32 UTC
(In reply to John Marino from comment #10)
> (In reply to Kurt Jaeger from comment #9)
> > Build fails on 9.1 amd64:
> > 
> > http://people.freebsd.org/~pi/misc/libosmocore-0.6.6.log
> 
> Koue, can you investigate?  I can't close out the follow-on PRs because this
> one got reopened.

If following line in Makefile is commented

#LDFLAGS+=      -lexecinfo

there is no problem with building of the port on 9.1 amd64. Configure scripts fails with:

configure:3352: cc -O2 -pipe -fno-strict-aliasing   -lexecinfo conftest.c  >&5
/usr/bin/ld: cannot find -lexecinfo

Ideas how to fix this?
Comment 14 Nikola Kolev 2014-08-11 14:27:26 UTC
LIB_DEPENDS=    libexecinfo.so:${PORTSDIR}/devel/libexecinfo

LDFLAGS+=       -L${LOCALBASE}/lib -lexecinfo
Comment 15 John Marino freebsd_committer 2014-08-11 14:29:19 UTC
I think USES+= execinfo was introduced recently.  Look at Mk/Uses and see if that's better (search other ports that use it)
Comment 16 commit-hook freebsd_committer 2014-08-11 18:09:25 UTC
A commit references this bug:

Author: pi
Date: Mon Aug 11 18:08:34 UTC 2014
New revision: 364632
URL: http://svnweb.freebsd.org/changeset/ports/364632

Log:
  devel/libosmocore: cleanup port

  - fix build dependencies
  - make DOCS optional and default-off
  - now builds on 8.4 and 9.1

  PR:		191877
  Submitted by:	Nikola Kolev <koue@chaosophia.net>

Changes:
  head/devel/libosmocore/Makefile
  head/devel/libosmocore/files/patch-Doxyfile.codec.in
  head/devel/libosmocore/files/patch-Doxyfile.core.in
  head/devel/libosmocore/files/patch-Doxyfile.gsm.in
  head/devel/libosmocore/files/patch-Doxyfile.vty.in
  head/devel/libosmocore/files/patch-Makefile.am
Comment 17 commit-hook freebsd_committer 2014-08-11 18:14:27 UTC
A commit references this bug:

Author: pi
Date: Mon Aug 11 18:14:07 UTC 2014
New revision: 364633
URL: http://svnweb.freebsd.org/changeset/ports/364633

Log:
  devel/libosmocore: fix DOCS option build hook

  PR:		191877

Changes:
  head/devel/libosmocore/Makefile