Bug 191885 - I have patched x11-fm/caja to solve a desktop text rendering issue (https://github.com/mate-desktop/caja/issues/105)
Summary: I have patched x11-fm/caja to solve a desktop text rendering issue (https://g...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-15 18:46 UTC by Douglas Carmichael
Modified: 2015-07-27 20:25 UTC (History)
1 user (show)

See Also:


Attachments
Caja icon container patch (https://github.com/bl0ckeduser/caja/commit/8dacfccb119ef2e295fc51d1bf509ba6d3ea533f) (938 bytes, text/plain)
2014-07-15 18:46 UTC, Douglas Carmichael
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Douglas Carmichael 2014-07-15 18:46:18 UTC
Created attachment 144694 [details]
Caja icon container patch (https://github.com/bl0ckeduser/caja/commit/8dacfccb119ef2e295fc51d1bf509ba6d3ea533f)

I had been experiencing a desktop text rendering bug with caja (text on the desktop is rendered as dark text even when it is not specified) and did some research regarding that issue.

I found that it is a known issue with caja 1.6.x (https://github.com/mate-desktop/caja/issues/105) and that a patch had been made to fix it (https://github.com/bl0ckeduser/caja/commit/8dacfccb119ef2e295fc51d1bf509ba6d3ea533f).

I have merged this patch into the mate-file-manager port, and a patch for the port is attached.

--Douglas
Comment 1 John Marino freebsd_committer 2014-07-20 15:26:02 UTC
over to maintainer
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2014-11-30 19:55:54 UTC
Port was renamed on 2014-09-10.
Comment 3 commit-hook freebsd_committer 2015-07-27 20:20:49 UTC
A commit references this bug:

Author: kwm
Date: Mon Jul 27 20:19:49 UTC 2015
New revision: 393031
URL: https://svnweb.freebsd.org/changeset/ports/393031

Log:
  Update MATE DE to 1.10.0.

  This MATE is still build agains GTK+2.
  Sort USES here and there.
  Replace mate-dialogs with zenity and mate-calc with galculator.

  This update fixes the following PR's:
  PR:		193942, 191885
  Submitted by:	Gustau Perez <gustau.perez@gmail.com> via Gnome devel repo
  Obtained from:	gnome devel repo.

Changes:
  head/MOVED
  head/Mk/bsd.mate.mk
  head/archivers/engrampa/Makefile
  head/archivers/engrampa/distinfo
  head/archivers/engrampa/files/patch-src_fr-command-tar.c
  head/archivers/engrampa/pkg-plist
  head/audio/Makefile
  head/audio/libmatemixer/
  head/audio/libmatemixer/Makefile
  head/audio/libmatemixer/distinfo
  head/audio/libmatemixer/pkg-descr
  head/audio/libmatemixer/pkg-plist
  head/audio/mate-media/Makefile
  head/audio/mate-media/distinfo
  head/audio/mate-media/pkg-plist
  head/deskutils/caja-extensions/Makefile
  head/deskutils/caja-extensions/distinfo
  head/deskutils/caja-extensions/pkg-descr
  head/deskutils/caja-extensions/pkg-plist
  head/deskutils/mate-notification-daemon/Makefile
  head/deskutils/mate-notification-daemon/distinfo
  head/deskutils/mate-notification-daemon/pkg-plist
  head/deskutils/mate-utils/Makefile
  head/deskutils/mate-utils/distinfo
  head/deskutils/mate-utils/files/patch-logview_logview-utils.c
  head/deskutils/mate-utils/pkg-plist
  head/deskutils/mozo/Makefile
  head/deskutils/mozo/distinfo
  head/deskutils/mozo/pkg-plist
  head/devel/mate-common/Makefile
  head/devel/mate-common/distinfo
  head/devel/mate-common/files/patch-macros_mate-autogen
  head/editors/pluma/Makefile
  head/editors/pluma/distinfo
  head/editors/pluma/pkg-plist
  head/graphics/atril/Makefile
  head/graphics/atril/distinfo
  head/graphics/atril/files/
  head/graphics/atril/pkg-plist
  head/graphics/eom/Makefile
  head/graphics/eom/distinfo
  head/graphics/eom/pkg-plist
  head/math/Makefile
  head/math/mate-calc/
  head/net/libmateweather/Makefile
  head/net/libmateweather/distinfo
  head/net/libmateweather/pkg-plist
  head/sysutils/mate-control-center/Makefile
  head/sysutils/mate-control-center/distinfo
  head/sysutils/mate-control-center/pkg-plist
  head/sysutils/mate-polkit/Makefile
  head/sysutils/mate-polkit/distinfo
  head/sysutils/mate-polkit/pkg-plist
  head/sysutils/mate-power-manager/Makefile
  head/sysutils/mate-power-manager/distinfo
  head/sysutils/mate-power-manager/files/patch-src_Makefile.in
  head/sysutils/mate-power-manager/files/patch-src_gpm-backlight-helper.c
  head/sysutils/mate-power-manager/pkg-plist
  head/sysutils/mate-settings-daemon/Makefile
  head/sysutils/mate-settings-daemon/distinfo
  head/sysutils/mate-settings-daemon/pkg-plist
  head/sysutils/mate-system-monitor/Makefile
  head/sysutils/mate-system-monitor/distinfo
  head/sysutils/mate-system-monitor/files/patch-src_load-graph.cpp
  head/sysutils/mate-system-monitor/files/patch-src_openfiles.cpp
  head/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
  head/sysutils/mate-system-monitor/pkg-plist
  head/x11/Makefile
  head/x11/libmatekbd/Makefile
  head/x11/libmatekbd/distinfo
  head/x11/libmatekbd/pkg-plist
  head/x11/mate/Makefile
  head/x11/mate-applets/Makefile
  head/x11/mate-applets/distinfo
  head/x11/mate-applets/files/accessx-status_Makefile.am
  head/x11/mate-applets/files/battstat_Makefile.am
  head/x11/mate-applets/files/command_Makefile.am
  head/x11/mate-applets/files/patch-accessx-status_Makefile.in
  head/x11/mate-applets/files/patch-battstat_Makefile.in
  head/x11/mate-applets/files/patch-battstat_power-management.c
  head/x11/mate-applets/files/patch-charpick_Makefile.in
  head/x11/mate-applets/files/patch-command_Makefile.in
  head/x11/mate-applets/files/patch-drivemount_Makefile.in
  head/x11/mate-applets/files/patch-geyes_Makefile.in
  head/x11/mate-applets/files/patch-multiload_Makefile.in
  head/x11/mate-applets/files/patch-stickynotes_Makefile.in
  head/x11/mate-applets/files/patch-timer-applet_Makefile.in
  head/x11/mate-applets/files/patch-timerapplet_Makefile.in
  head/x11/mate-applets/files/patch-trashapplet_src_Makefile.in
  head/x11/mate-applets/files/stickynotes_Makefile.am
  head/x11/mate-applets/files/timerapplet_Makefile.am
  head/x11/mate-applets/files/trashapplet_src_Makefile.am
  head/x11/mate-applets/pkg-plist
  head/x11/mate-base/Makefile
  head/x11/mate-desktop/Makefile
  head/x11/mate-desktop/distinfo
  head/x11/mate-desktop/pkg-plist
  head/x11/mate-dialogs/
  head/x11/mate-menus/Makefile
  head/x11/mate-menus/distinfo
  head/x11/mate-menus/pkg-plist
  head/x11/mate-panel/Makefile
  head/x11/mate-panel/distinfo
  head/x11/mate-panel/files/patch-applets_wncklet_workspace-switcher.c
  head/x11/mate-panel/pkg-plist
  head/x11/mate-screensaver/Makefile
  head/x11/mate-screensaver/distinfo
  head/x11/mate-session-manager/Makefile
  head/x11/mate-session-manager/distinfo
  head/x11/mate-session-manager/pkg-plist
  head/x11/mate-terminal/Makefile
  head/x11/mate-terminal/distinfo
  head/x11/mate-terminal/pkg-plist
  head/x11-fm/caja/Makefile
  head/x11-fm/caja/distinfo
  head/x11-fm/caja/pkg-plist
  head/x11-themes/mate-backgrounds/Makefile
  head/x11-themes/mate-backgrounds/distinfo
  head/x11-themes/mate-backgrounds/pkg-plist
  head/x11-themes/mate-icon-theme/Makefile
  head/x11-themes/mate-icon-theme/distinfo
  head/x11-themes/mate-icon-theme/pkg-plist
  head/x11-themes/mate-icon-theme-faenza/Makefile
  head/x11-themes/mate-icon-theme-faenza/distinfo
  head/x11-themes/mate-icon-theme-faenza/pkg-plist
  head/x11-themes/mate-themes/Makefile
  head/x11-themes/mate-themes/distinfo
  head/x11-themes/mate-themes/pkg-plist
  head/x11-wm/marco/Makefile
  head/x11-wm/marco/distinfo
Comment 4 Koop Mast freebsd_committer 2015-07-27 20:25:31 UTC
I couldn't reproduce it with MATE 1.10. Please reopen if it still a issue.