Bug 191889 - ipv6_activate_all_interfaces="NO" not working as expected for lagg interfaces and laggports
Summary: ipv6_activate_all_interfaces="NO" not working as expected for lagg interfaces...
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 10.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-15 21:21 UTC by clint
Modified: 2014-07-15 21:21 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clint 2014-07-15 21:21:32 UTC
I have 2 nics on my system, em0 and em1. They are configured as laggports on lagg0. lagg0 is a member of bridge0 which is where I'd like to configure the host IP address. I would like only bridge0 to get a link local address. I have a third physical interface, re0 that I'm not using at all. I have no configuration for re0 in my rc.conf, it works as expected.

Steps to reproduce:

# rc.conf
ipv6_activate_all_interfaces="NO"
cloned_interfaces="lagg0 bridge0"
ifconfig_em0="up"
ifconfig_em1="up"
ifconfig_lagg0="up laggport em0 laggport em1 laggproto roundrobin"
ifconfig_bridge0="up addm lagg0 addm tap0 192.168.10.10/24"
ifconfig_bridge0_ipv6="inet6 auto_linklocal accept_rtadv"

Expected result:

em0, em1 and lagg0 should have no IPV4 or IPV6 addresses. bridge0 should have a link local address.

Actual result: All interfaces get link local addresses.

# ifconfig
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
        ether 50:e5:49:WW:WW:WW
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
em0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=4019b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,VLAN_HWTSO>
        ether 00:15:17:XX:XX:XX
        inet6 fe80::215:17ff:feXX:XXXX%em0 prefixlen 64 scopeid 0x2
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
em1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=4019b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,VLAN_HWTSO>
        ether 00:15:17:0b:13:86
        inet6 fe80::215:17ff:feXX:XXXY%em1 prefixlen 64 scopeid 0x3
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
lagg0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=4019b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,VLAN_HWTSO>
        ether 00:15:17:XX:XX:XX
        inet6 fe80::52e5:49ff:feYY:YYYY%lagg0 prefixlen 64 scopeid 0x5
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet autoselect
        status: active
        laggproto roundrobin lagghash l2,l3,l4
        laggport: em1 flags=4<ACTIVE>
        laggport: em0 flags=4<ACTIVE>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 02:34:2f:ZZ:ZZ:ZZ
        inet 192.168.10.10 netmask 0xffffff00 broadcast 192.168.10.255
        inet6 fe80::34:2fff:feZZ:ZZZZ%bridge0 prefixlen 64 scopeid 0x6
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: lagg0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 5 priority 128 path cost 55