Bug 191908 - [zfs] newer kernel and old userland binary compatibility broken
Summary: [zfs] newer kernel and old userland binary compatibility broken
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.0-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Xin LI
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-17 04:01 UTC by Yoshiaki Kasahara
Modified: 2014-07-17 07:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yoshiaki Kasahara 2014-07-17 04:01:26 UTC
I tried to update my 10-STABLE machine (full ZFS including root)
from r268480 (built on Jul 10) to r268734 (built on Jul 16), but after
make installkernel and reboot into single user mode, I couldn't proceed
further because "zfs mount -a" crashed immediately with segfault.  

Because only read-only root fs was available, I couldn't do any
debugging (/usr resides in a separate fs).  Actually any zfs or 
zpool commands seemed to crash immediately.  Of course I couldn't 
make installworld.

I guess this incompatibility had been introduced by recent several ZFS 
related MFC/MFV between two builds.  I believe old userland should be 
usable with a newer kernel (or I cannot follow the standard install
procedure).  If it is an expected behavior, it should be mentioned in 
/usr/src/UPDATING.

% uname -a
FreeBSD elvenbow.cc.kyushu-u.ac.jp 10.0-STABLE FreeBSD 10.0-STABLE #0 r268480: Thu Jul 10 15:25:15 JST 2014     root@elvenbow.cc.kyushu-u.ac.jp:/usr/obj/usr/src/sys/ELVENBOW  amd64

% what /boot/kernel.new/kernel
/boot/kernel.new/kernel:
        FreeBSD 10.0-STABLE #0 r268734: Wed Jul 16 12:36:48 JST 2014
Comment 1 Xin LI freebsd_committer 2014-07-17 05:21:19 UTC
Fixed in r268786.

For your existing system, please try booting previous kernel, sorry for the inconvenience.
Comment 2 Yoshiaki Kasahara 2014-07-17 07:19:13 UTC
I confirmed that the problem was fixed.

Thank you!