Bug 191956 - [PATCH] www/w3m - fix build with libressl
Summary: [PATCH] www/w3m - fix build with libressl
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: MANTANI Nobutaka
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-18 15:30 UTC by meyer.arne83
Modified: 2014-08-03 12:07 UTC (History)
1 user (show)

See Also:


Attachments
Disable use of egd api in w3m to fix build against libressl (292 bytes, patch)
2014-07-18 15:30 UTC, meyer.arne83
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description meyer.arne83 2014-07-18 15:30:20 UTC
Created attachment 144780 [details]
Disable use of egd api in w3m to fix build against libressl

w3m fails to build because libressl has axed the egd api. Attached patch disables use of egd in w3m unconditionally. egd is a bad idea and AFAIK not needed on FreeBSD anyway.
Comment 1 John Marino freebsd_committer 2014-07-20 14:45:34 UTC
over to maintainer
Comment 2 Jamie Landeg-Jones 2014-07-20 19:17:29 UTC
Duplcate of https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=191852
Comment 3 MANTANI Nobutaka freebsd_committer 2014-08-03 12:07:01 UTC
Fixed by r363883.
http://svnweb.freebsd.org/changeset/ports/363883