Bug 191988 - ftp/wget: Fails to work with LibreSSL
Summary: ftp/wget: Fails to work with LibreSSL
Status: Closed DUPLICATE of bug 199316
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2014-07-20 17:06 UTC by Jens K. Loewe
Modified: 2015-04-21 07:41 UTC (History)
4 users (show)

See Also:
koobs: maintainer-feedback-


Attachments
Patch init.c for wget 1.16 removing rand_EGD (619 bytes, patch)
2014-11-10 09:50 UTC, Bernard Spil
no flags Details | Diff
Patch openssl.c for wget 1.16 removing rand_EGD (355 bytes, patch)
2014-11-10 09:51 UTC, Bernard Spil
no flags Details | Diff
Patch options.h for wget 1.16 removing rand_EGD (446 bytes, patch)
2014-11-10 09:54 UTC, Bernard Spil
no flags Details | Diff
Build log wget 1.16 with patches applied (132.63 KB, text/plain)
2014-11-10 09:55 UTC, Bernard Spil
no flags Details
svn diff for ftp/wget (5.96 KB, patch)
2015-02-20 18:18 UTC, Bernard Spil
no flags Details | Diff
Build log of wget 1.16 incl patches (130.73 KB, text/plain)
2015-02-20 18:22 UTC, Bernard Spil
no flags Details
Poudriere build log for ftp/wget (143.34 KB, text/plain)
2015-03-07 10:41 UTC, Bernard Spil
no flags Details
svn diff for ftp/wget (775 bytes, patch)
2015-04-21 07:32 UTC, Bernard Spil
no flags Details | Diff
Poudriere build log ftp/wget (142.84 KB, text/plain)
2015-04-21 07:33 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens K. Loewe 2014-07-20 17:06:15 UTC
When using LibreSSL instead of OpenSSL, wget can't compile. This patch fixes the problem:

https://github.com/gentoo/libressl/blob/master/net-misc/wget/files/wget-1.14-libressl.patch
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-07-20 17:40:00 UTC
Over to maintainer.
Comment 2 Bernard Spil freebsd_committer 2014-11-10 09:50:26 UTC
Created attachment 149242 [details]
Patch init.c for wget 1.16 removing rand_EGD

Patch init.c for wget 1.16 removing rand_EGD
Comment 3 Bernard Spil freebsd_committer 2014-11-10 09:51:25 UTC
Created attachment 149243 [details]
Patch openssl.c for wget 1.16 removing rand_EGD
Comment 4 Bernard Spil freebsd_committer 2014-11-10 09:54:29 UTC
Created attachment 149244 [details]
Patch options.h for wget 1.16 removing rand_EGD

These patches can be dropped into ftp/wget/files and it will compile again
Comment 5 Bernard Spil freebsd_committer 2014-11-10 09:55:40 UTC
Created attachment 149245 [details]
Build log wget 1.16 with patches applied
Comment 6 Bernard Spil freebsd_committer 2014-11-10 10:06:04 UTC
Can pull this from 
https://github.com/Sp1l/ports/tree/master/ftp/wget
as well
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-20 09:06:36 UTC
Maintainer timeout, open to take.

Bernard, please provide the same patches, but again against the latest port version (not against upstream sources)
Comment 8 Bernard Spil freebsd_committer 2015-02-20 18:18:44 UTC
Created attachment 153228 [details]
svn diff for ftp/wget

Replaces earlier patches
Comment 9 Bernard Spil freebsd_committer 2015-02-20 18:22:25 UTC
Created attachment 153229 [details]
Build log of wget 1.16 incl patches
Comment 10 Kurt Jaeger freebsd_committer 2015-02-22 13:04:11 UTC
Tested the build on 10.1a, which does not use libressl per default.

How would I test against libressl instead ? Would it help if there's an
option to select libressl instead of openssl or gnutls?
Comment 11 Kurt Jaeger freebsd_committer 2015-02-22 13:05:03 UTC
Hmm, libressl conflicts with ports openssl.
Comment 12 Bernard Spil freebsd_committer 2015-03-03 19:45:07 UTC
Hi Kurt,

Please check https://wiki.freebsd.org/LibreSSL#How_to_use_LibreSSL for the additions to your make.conf. Let me know if any questions remain.

For a Poudriere build (on -CURRENT) please check http://builds.pcbsd.org:8880/data/pcbsd-110-CURRENTMAR2015-11current/2015-03-01_20h22m26s/logs/curl-7.41.0.log
Comment 13 Kurt Jaeger freebsd_committer 2015-03-03 20:08:05 UTC
Thanks for the 'how-to'. Building on 10.1a via poudriere worked now.

I'll be offline for the next few days, so I'll have no time to test other
archs.
Comment 14 Bernard Spil freebsd_committer 2015-03-03 20:13:45 UTC
Waiting for the GNU Savannah registration email to arrive so I can provide the patches upstream... Will update progress here.
Comment 15 Bernard Spil freebsd_committer 2015-03-07 10:41:26 UTC
Created attachment 153952 [details]
Poudriere build log for ftp/wget

Builds succesfully. Bug was opened July 2014 and upstream fixed this with 
https://github.com/mirror/wget/commit/b5778699f0fd65efb78ac8fc0777128a7069b856
Comment 16 Johannes Jost Meixner freebsd_committer 2015-03-30 09:56:20 UTC
Patch being attached, remove needs-patch flag.
Comment 17 Bernard Spil freebsd_committer 2015-04-21 07:32:18 UTC
Created attachment 155792 [details]
svn diff for ftp/wget

Update wget port to 1.6.3.
This also fixes the LibreSSL build issues with https://github.com/mirror/wget/commit/b5778699f0fd65efb78ac8fc0777128a7069b856
Comment 18 Bernard Spil freebsd_committer 2015-04-21 07:33:19 UTC
Created attachment 155793 [details]
Poudriere build log ftp/wget
Comment 19 Johannes Jost Meixner freebsd_committer 2015-04-21 07:41:47 UTC

*** This bug has been marked as a duplicate of bug 199316 ***