Bug 192048 - emulators/pipelight fails to build with base gcc
emulators/pipelight fails to build with base gcc
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: --- Affects Many People
Assigned To: Kris Moore
Depends on:
  Show dependency treegraph
Reported: 2014-07-22 22:53 UTC by Joseph Mingrone
Modified: 2014-07-23 13:17 UTC (History)
1 user (show)

See Also:

Makefile patch for emulators/pipelight (528 bytes, patch)
2014-07-22 22:53 UTC, Joseph Mingrone
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Mingrone 2014-07-22 22:53:35 UTC
Created attachment 144895 [details]
Makefile patch for emulators/pipelight

The port failed to build for me on 9-STABLE.  It gave the error

cc1plus: error: unrecognized command line option "-std=gnu++0x"

because, I believe, the base gcc is too old.  I've attached a diff that makes it build with gcc (g++) from ports.
Comment 1 Kris Moore freebsd_committer 2014-07-23 13:16:52 UTC
Patch committed, thanks!
Comment 2 commit-hook freebsd_committer 2014-07-23 13:17:07 UTC
A commit references this bug:

Author: kmoore
Date: Wed Jul 23 13:16:29 UTC 2014
New revision: 362683
URL: http://svnweb.freebsd.org/changeset/ports/362683

  - Fix building pipelight on FreeBSD 9 and earlier

  PR: 192048
  Submitted by: Joseph Mingrone <jrm@ftfl.ca>