Bug 192061 - archivers/rpm4: needs python 2.7
Summary: archivers/rpm4: needs python 2.7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Johan van Selst
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-23 11:44 UTC by Kurt Jaeger
Modified: 2014-07-23 12:12 UTC (History)
0 users

See Also:


Attachments
python-version-fix (426 bytes, patch)
2014-07-23 11:44 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2014-07-23 11:44:48 UTC
Created attachment 144907 [details]
python-version-fix

rpm4 does not build if default python is 3.x. Patch sets python for the build to 2.7.
Comment 1 Johan van Selst freebsd_committer 2014-07-23 12:11:38 UTC
Committed, thanks.
Comment 2 commit-hook freebsd_committer 2014-07-23 12:12:03 UTC
A commit references this bug:

Author: johans
Date: Wed Jul 23 12:11:14 UTC 2014
New revision: 362665
URL: http://svnweb.freebsd.org/changeset/ports/362665

Log:
  rpm4 does not build if default python is 3.x - force use of python 2.7

  PR:		192061
  Submitted by:	pi

Changes:
  head/archivers/rpm4/Makefile