Bug 192068 - [UPDATE] graphics/poppler to 0.26.3 and slaves ports
Summary: [UPDATE] graphics/poppler to 0.26.3 and slaves ports
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Antoine Brodin
URL:
Keywords: patch-ready
: 194992 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-23 18:56 UTC by Olivier Duchateau
Modified: 2014-11-25 13:04 UTC (History)
3 users (show)

See Also:
kwm: maintainer-feedback+
makc: exp-run?


Attachments
Update of graphics/poppler (8.58 KB, patch)
2014-07-23 18:56 UTC, Olivier Duchateau
no flags Details | Diff
Update of graphics/poppler-glib (2.32 KB, patch)
2014-07-23 18:58 UTC, Olivier Duchateau
no flags Details | Diff
Update of graphics/poppler-qt4 (812 bytes, patch)
2014-07-23 18:59 UTC, Olivier Duchateau
no flags Details | Diff
Add graphics/poppler-qt5 (1.27 KB, application/x-shar)
2014-07-23 19:02 UTC, Olivier Duchateau
no flags Details
Complete diff to update graphics/poppler and related ports (12.23 KB, patch)
2014-11-17 12:47 UTC, Olivier Duchateau
no flags Details | Diff
Full patch to upgrade graphics/poppler to 0.26.3 (13.76 KB, patch)
2014-11-20 17:42 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau freebsd_committer 2014-07-23 18:56:00 UTC
Created attachment 144916 [details]
Update of graphics/poppler

- Update to 0.26.3 (the latest stable release)
- Add LICENSE_FILE
- Adjust dependencies
- Add new option, CURL
- switch to USES= libtool tar:xz
- Add Qt5 support

Build log on RedPorts: https://redports.org/buildarchive/20140723173301-15852/
Comment 1 Olivier Duchateau freebsd_committer 2014-07-23 18:58:16 UTC
Created attachment 144917 [details]
Update of graphics/poppler-glib

- Don't install API documentation
- Switch to USES= libtool
Comment 2 Olivier Duchateau freebsd_committer 2014-07-23 18:59:24 UTC
Created attachment 144918 [details]
Update of graphics/poppler-qt4

- Switch to USES= libtool
Comment 3 Olivier Duchateau freebsd_committer 2014-07-23 19:02:57 UTC
Created attachment 144919 [details]
Add graphics/poppler-qt5

- Add graphics/poppler-qt5
- Fix dependencies
- Use ${MOC} variable, define in Mk/bsd.qt.mk (because moc utility is installed in ${LOCALBASE}/lib/qt5/bin/)

Build log on RedPorts: https://redports.org/buildarchive/20140723174101-40357/
Comment 4 Olivier Duchateau freebsd_committer 2014-11-13 18:49:40 UTC
*** Bug 194992 has been marked as a duplicate of this bug. ***
Comment 5 Max Brazhnikov freebsd_committer 2014-11-15 15:31:34 UTC
(In reply to Olivier Duchateau from comment #4)
> *** Bug 194992 has been marked as a duplicate of this bug. ***

Hi Olivier,

I didn't notice your patch has -qt5 port already. Could you merge some changes from my patch, particularly USE_QT5 list. Any plans to commit this soon?
Comment 6 Olivier Duchateau freebsd_committer 2014-11-17 12:47:37 UTC
Created attachment 149510 [details]
Complete diff to update graphics/poppler and related ports

New patch, to update graphics/poppler to 0.26.3 (and related ports) with Max's remark (regarding Qt5 support).

In this new one, static libraries removed.
Comment 7 Olivier Duchateau freebsd_committer 2014-11-17 12:50:16 UTC
(In reply to Max Brazhnikov from comment #5)
> (In reply to Olivier Duchateau from comment #4)
> > *** Bug 194992 has been marked as a duplicate of this bug. ***
> 
> Hi Olivier,
> 
> I didn't notice your patch has -qt5 port already. Could you merge some
> changes from my patch, particularly USE_QT5 list. Any plans to commit this
> soon?

These ports belong to kwm@.
Comment 8 Max Brazhnikov freebsd_committer 2014-11-17 13:28:20 UTC
(In reply to Olivier Duchateau from comment #7)
> (In reply to Max Brazhnikov from comment #5)
> > (In reply to Olivier Duchateau from comment #4)
> > > *** Bug 194992 has been marked as a duplicate of this bug. ***
> > 
> > Hi Olivier,
> > 
> > I didn't notice your patch has -qt5 port already. Could you merge some
> > changes from my patch, particularly USE_QT5 list. Any plans to commit this
> > soon?
> 
> These ports belong to kwm@.

Koop, do you have time for this update?

Olivier, have you tested all dependent ports? Do we need exp-run?
Comment 9 Olivier Duchateau freebsd_committer 2014-11-17 15:42:52 UTC
(In reply to Max Brazhnikov from comment #8)
> (In reply to Olivier Duchateau from comment #7)
> > (In reply to Max Brazhnikov from comment #5)
> > > (In reply to Olivier Duchateau from comment #4)
> > > > *** Bug 194992 has been marked as a duplicate of this bug. ***
> > > 
> > > Hi Olivier,
> > > 
> > > I didn't notice your patch has -qt5 port already. Could you merge some
> > > changes from my patch, particularly USE_QT5 list. Any plans to commit this
> > > soon?
> > 
> > These ports belong to kwm@.
> 
> Koop, do you have time for this update?
> 
> Olivier, have you tested all dependent ports? Do we need exp-run?

I use poppler-glib for a while, and I've not noticed any problems. Not tested Qt ports, just check if everything build fine.

I think exp-run is needed, but feel free to ask.
Comment 10 Max Brazhnikov freebsd_committer 2014-11-17 21:21:09 UTC
Request exp-run.
Comment 11 Antoine Brodin freebsd_committer 2014-11-17 22:54:09 UTC
Take
Comment 12 Antoine Brodin freebsd_committer 2014-11-20 00:06:11 UTC
Take
Comment 13 Antoine Brodin freebsd_committer 2014-11-20 15:48:25 UTC
poppler-qt5 fails to build,  it probably needs a patch similar to patch-qt4_src_Makefile.in:

http://package18.nyi.freebsd.org/data/91amd64-default-PR192068/2014-11-20_00h12m46s/logs/errors/poppler-qt5-0.26.3.log
Comment 14 Olivier Duchateau freebsd_committer 2014-11-20 17:40:47 UTC
(In reply to Antoine Brodin from comment #13)
> poppler-qt5 fails to build,  it probably needs a patch similar to
> patch-qt4_src_Makefile.in:
> 
> http://package18.nyi.freebsd.org/data/91amd64-default-PR192068/2014-11-
> 20_00h12m46s/logs/errors/poppler-qt5-0.26.3.log

It's right, I forget to add patches in latest diff.
Comment 15 Olivier Duchateau freebsd_committer 2014-11-20 17:42:11 UTC
Created attachment 149647 [details]
Full patch to upgrade graphics/poppler to 0.26.3
Comment 16 Max Brazhnikov freebsd_committer 2014-11-21 09:25:03 UTC
(In reply to Antoine Brodin from comment #13)
> poppler-qt5 fails to build,  it probably needs a patch similar to
> patch-qt4_src_Makefile.in:
> 
> http://package18.nyi.freebsd.org/data/91amd64-default-PR192068/2014-11-
> 20_00h12m46s/logs/errors/poppler-qt5-0.26.3.log

Is there any other problem?
Comment 17 Antoine Brodin freebsd_committer 2014-11-21 09:38:58 UTC
Exp-run results on 91amd64:
http://package18.nyi.freebsd.org/jail.html?mastername=91amd64-default-PR192068
No new failures

Limited exp-run (only ports using poppler) results on 10.1 amd64:
http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-PR192068&build=2014-11-20_20h05m47s
No new failures

I don't know if you want i386 too, it's probably not necessary if you tested the 5 ports already
Comment 18 Max Brazhnikov freebsd_committer 2014-11-21 10:41:23 UTC
(In reply to Antoine Brodin from comment #17)
> Exp-run results on 91amd64:
> http://package18.nyi.freebsd.org/jail.html?mastername=91amd64-default-
> PR192068
> No new failures
> 
> Limited exp-run (only ports using poppler) results on 10.1 amd64:
> http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-
> PR192068&build=2014-11-20_20h05m47s
> No new failures

Great!

> 
> I don't know if you want i386 too, it's probably not necessary if you tested
> the 5 ports already

I believe testing on 9/10-amd64 is enough.

Olivier, will you commit the update?
Comment 19 Koop Mast freebsd_committer 2014-11-21 10:50:00 UTC
if you remove the bogus @dirrm in poppler-qt4/pkg-plist, it good.
Comment 20 Olivier Duchateau freebsd_committer 2014-11-21 12:45:11 UTC
(In reply to Max Brazhnikov from comment #18)
> (In reply to Antoine Brodin from comment #17)
> > Exp-run results on 91amd64:
> > http://package18.nyi.freebsd.org/jail.html?mastername=91amd64-default-
> > PR192068
> > No new failures
> > 
> > Limited exp-run (only ports using poppler) results on 10.1 amd64:
> > http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-
> > PR192068&build=2014-11-20_20h05m47s
> > No new failures
> 
> Great!
> 
> > 
> > I don't know if you want i386 too, it's probably not necessary if you tested
> > the 5 ports already
> 
> I believe testing on 9/10-amd64 is enough.
> 
> Olivier, will you commit the update?

No (I would like to update some ports, now GNOME3 is present), you can or let Koop do it.
Comment 21 Koop Mast freebsd_committer 2014-11-21 12:54:44 UTC
If makc doesn't do it I will tackle it after I'm done with gstreamer.
Comment 22 Antoine Brodin freebsd_committer 2014-11-22 18:48:25 UTC
makc, do you want to do it?
Comment 23 Max Brazhnikov freebsd_committer 2014-11-24 12:01:50 UTC
(In reply to Antoine Brodin from comment #22)
> makc, do you want to do it?

I've already promised kwm to finish it.
Comment 24 Max Brazhnikov freebsd_committer 2014-11-25 13:04:24 UTC
Committed. Thanks all!