Bug 192330 - games/openxcom: update to 1.0.0
Summary: games/openxcom: update to 1.0.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
: 187191 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-02 09:02 UTC by Guido Falsi
Modified: 2014-09-11 18:08 UTC (History)
3 users (show)

See Also:


Attachments
openxcom 1.0.0 update (2.52 KB, patch)
2014-08-02 09:02 UTC, Guido Falsi
madpilot: maintainer-approval? (amdmi3)
Details | Diff
new yaml-cpp05 port (4.32 KB, application/x-shar)
2014-08-02 09:03 UTC, Guido Falsi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2014-08-02 09:02:07 UTC
Created attachment 145239 [details]
openxcom 1.0.0 update

I have updated games/openxcom to 1.0.0.

This new version depends on devel/yaml-cpp 0.5.1, which is a newer version with an incompatible API from the 0.3.x we have in the ports tree.

To accommodate for this I have created a devel/yaml-cpp05 port. This is yaml-cpp 0.5.1 modified to install with a "05" suffix, so it can live on the same system as yaml-cpp. I then modified the openxcom port to use this yaml-cpp05 installation.

I'd like to get your approval for the openxcom update before committing this new port though, since openxcom would be the only consumer.

I'm attaching both the shar for the new port and the openxcom update to this PR.

Note: the files/patch-src__Engine__RNG.h patch should be submitted upstream. I can do that once committed.

Thanks!
Comment 1 Guido Falsi freebsd_committer 2014-08-02 09:03:48 UTC
Created attachment 145240 [details]
new yaml-cpp05 port
Comment 2 John Marino freebsd_committer 2014-08-02 14:35:23 UTC
There's no bugzilla automatically assignment, so I'll just manually assign it to Dmitry....
Comment 3 Guido Falsi freebsd_committer 2014-08-03 21:52:01 UTC
*** Bug 187191 has been marked as a duplicate of this bug. ***
Comment 4 Guido Falsi freebsd_committer 2014-08-22 14:16:35 UTC
Hi Dmitry,

You did not followup to this PR, regarding the openxcom part.

Can you approve it? I'd like to commit this soon, and I'd rather have some feedback from you before calling timeout.

Thanks in advance.
Comment 5 Dmitry Marakasov freebsd_committer 2014-08-27 21:27:01 UTC
Tim, what do you think of moving current version of yaml-cpp to yaml-cpp03 and updating yaml-cpp to 0.5 instead? There are only 2 consumers of yaml-cpp (chinese/librime, graphics/opencolorio) apart from OpenXCom, and it'd be quite easy to hack them to use yaml-cpp03. New software will likely need new version of the library so I'd like it to be the default one.
Comment 6 Dmitry Marakasov freebsd_committer 2014-08-27 21:40:30 UTC
Apart from this, changes look good, though I haven't playtested it yet (pending).

Also I'd like to resolve maintainer issue - IMO both ports should have a single maintainer.
Comment 7 Guido Falsi freebsd_committer 2014-08-27 22:03:09 UTC
(In reply to Dmitry Marakasov from comment #6)

> 
> Also I'd like to resolve maintainer issue - IMO both ports should have a
> single maintainer.

I put myself as maintainer of yaml-cpp05 since I was creating the port.

I admit I don't see a reason why openxcom and yaml-cpp05 should be maintained by the same person. They are two separate projects, one is a multi purpose library the other one is a program using that library just like many others.

Anyway what would be your preference regarding to this issue you see?
Comment 8 Dmitry Marakasov freebsd_committer 2014-08-30 18:53:12 UTC
> I put myself as maintainer of yaml-cpp05 since I was creating the port.

That's not really creating, since it should be repocopied from yaml-cpp.

> I don't see a reason why openxcom and yaml-cpp05 should be maintained by the same person

Not "openxcom and yaml-cpp05", but "yaml-cpp and yaml-cpp05".

I'd really like to hear from yaml-cpp maintainer.
Comment 9 Dmitry Marakasov freebsd_committer 2014-09-11 15:24:57 UTC
Everything's ready. I'll commit it after some testing
Comment 10 commit-hook freebsd_committer 2014-09-11 17:49:58 UTC
A commit references this bug:

Author: amdmi3
Date: Thu Sep 11 17:49:39 UTC 2014
New revision: 367957
URL: http://svnweb.freebsd.org/changeset/ports/367957

Log:
  - Preserve devel/yaml-cpp as devel/yaml-cpp03 in preparation to update to 0.5
  - Introduce changes necessary to allow both versions to coexist

  PR:		192330
  Submitted by:	madpilot@FreeBSD.org
  Approved by:	maintainer timeout

Changes:
  head/devel/Makefile
  head/devel/yaml-cpp03/
  head/devel/yaml-cpp03/Makefile
  head/devel/yaml-cpp03/files/patch-CMakeLists.txt
  head/devel/yaml-cpp03/pkg-plist
Comment 11 commit-hook freebsd_committer 2014-09-11 17:52:00 UTC
A commit references this bug:

Author: amdmi3
Date: Thu Sep 11 17:51:15 UTC 2014
New revision: 367958
URL: http://svnweb.freebsd.org/changeset/ports/367958

Log:
  - Switch graphics/opencolorio and chinese/librime to yaml-cpp03, as they are incompatible with newer version

  PR:		192330

Changes:
  head/chinese/librime/Makefile
  head/graphics/opencolorio/Makefile
Comment 12 commit-hook freebsd_committer 2014-09-11 17:56:01 UTC
A commit references this bug:

Author: amdmi3
Date: Thu Sep 11 17:55:52 UTC 2014
New revision: 367959
URL: http://svnweb.freebsd.org/changeset/ports/367959

Log:
  - Update to 0.5.1
  - Add LICENSE_FILE
  - Pass maintainership to submitter

  PR:		192330
  Submitted by:	madpilot@FreeBSD.org
  Approved by:	maintainer timeout

Changes:
  head/devel/yaml-cpp/Makefile
  head/devel/yaml-cpp/distinfo
  head/devel/yaml-cpp/files/patch-CMakeLists.txt
  head/devel/yaml-cpp/pkg-plist