Bug 192495 - [PORT UPDATE] databases/mariadb55-{client,server}: update to 5.5.39
Summary: [PORT UPDATE] databases/mariadb55-{client,server}: update to 5.5.39
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bartek Rutkowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-08 00:23 UTC by iron.udjin
Modified: 2014-09-04 16:18 UTC (History)
3 users (show)

See Also:


Attachments
mariadb55-{client,server}-5.5.39 patch (2.65 KB, patch)
2014-08-08 00:23 UTC, iron.udjin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description iron.udjin 2014-08-08 00:23:58 UTC
Created attachment 145495 [details]
mariadb55-{client,server}-5.5.39 patch

Update MariaDB 5.5 client and server to version 5.5.39.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-08-10 00:48:37 UTC
Notify maintainer.
Comment 2 John Marino freebsd_committer 2014-08-10 07:25:23 UTC
I must have spaced and thought the submitter was the maintainer.  Since that's not true, this moves to "Approval Needed" status.  The maintainer has 2 weeks to give a disposition, otherwise it's considered approved.
Comment 3 John Marino freebsd_committer 2014-08-25 20:08:03 UTC
the maintainer timed out, his approval is no longer required.  Moving to patch-ready for committer evaluation.
Comment 4 Bartek Rutkowski freebsd_committer 2014-08-28 19:01:43 UTC
Hi,

I've tested the patch and it seems it is incomplete and the build is failing on wrong pkg-plist: http://pd.valinor.palantiri.org/data/latest-per-pkg/mariadb55-server/5.5.39/11amd64-default.log

Can you please look at it, test it and provide fixed patch?
Comment 5 iron.udjin 2014-08-29 23:54:54 UTC
Hmm... I can't reproduce on my 10-STABLE such error: http://pastebin.com/Cr73NnaG
Unfortunately I don't have 11-CURRENT to test it there.
Comment 6 commit-hook freebsd_committer 2014-09-04 16:14:58 UTC
A commit references this bug:

Author: robak
Date: Thu Sep  4 16:14:26 UTC 2014
New revision: 367285
URL: http://svnweb.freebsd.org/changeset/ports/367285

Log:
  databases/mariadb55-server: update 5.5.38 -> 5.5.39

  PR:		192495
  Submitted by:	iron@mail.ua
  Approved by:	mentors (implicit)

Changes:
  head/databases/mariadb55-server/Makefile
  head/databases/mariadb55-server/distinfo
  head/databases/mariadb55-server/pkg-plist
Comment 7 commit-hook freebsd_committer 2014-09-04 16:17:00 UTC
A commit references this bug:

Author: robak
Date: Thu Sep  4 16:16:00 UTC 2014
New revision: 367286
URL: http://svnweb.freebsd.org/changeset/ports/367286

Log:
  databases/mariadb55-client: update 5.5.38 -> 5.5.39

  PR:		192495
  Submitted by:	iron@mail.ua
  Approved by:	mentors (implicit)

Changes:
  head/databases/mariadb55-client/files/patch-CMakeLists.txt
Comment 8 Bartek Rutkowski freebsd_committer 2014-09-04 16:18:05 UTC
Committed (after fixing the plist issues and testing on all OS versions), thanks for your work!