Bug 192511 - lang/python27: Fix build with LibreSSL
Summary: lang/python27: Fix build with LibreSSL
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Bernard Spil
URL: http://bugs.python.org/issue21356
Keywords: needs-patch, needs-qa
: 199826 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-08 12:15 UTC by meyer.arne83
Modified: 2015-07-07 06:52 UTC (History)
14 users (show)

See Also:


Attachments
fix lang/python27 build with libressl (1.67 KB, patch)
2014-08-08 12:15 UTC, meyer.arne83
no flags Details | Diff
Patch the port to detect RAND_egd and disable it conditionally (9.33 KB, patch)
2014-11-28 10:46 UTC, Bernard Spil
no flags Details | Diff
Single patch for this PR for the source tree (5.20 KB, patch)
2014-11-28 20:47 UTC, Bernard Spil
no flags Details | Diff
Patch for Makefile (645 bytes, patch)
2014-11-28 20:50 UTC, Bernard Spil
no flags Details | Diff
Output of the test_ssl unit test (13.50 KB, text/plain)
2014-11-28 20:52 UTC, Bernard Spil
no flags Details
Single patch for this PR for the source tree (6.45 KB, patch)
2014-11-29 21:26 UTC, Bernard Spil
no flags Details | Diff
Output of the test_ssl unit test (13.50 KB, text/plain)
2014-11-29 21:27 UTC, Bernard Spil
no flags Details
Build log (537.37 KB, text/x-log)
2014-11-29 21:28 UTC, Bernard Spil
no flags Details
Patch for Makefile (538 bytes, patch)
2014-12-23 14:43 UTC, Bernard Spil
no flags Details | Diff
Single patch for this PR for the source tree (6.24 KB, patch)
2014-12-23 14:44 UTC, Bernard Spil
no flags Details | Diff
Poudriere build log (556.13 KB, text/x-log)
2014-12-24 18:35 UTC, Bernard Spil
no flags Details
Patch for Makefile (544 bytes, patch)
2015-01-02 11:31 UTC, Bernard Spil
no flags Details | Diff
Build log with LibreSSL installed (534.86 KB, text/plain)
2015-01-02 11:34 UTC, Bernard Spil
no flags Details
svn diff for lang/python27 (3.25 KB, patch)
2015-03-04 15:26 UTC, Bernard Spil
brnrd: maintainer-approval+
Details | Diff
Poudriere build log python27 linking to libcrypto.so.32.0.0 (562.59 KB, text/plain)
2015-03-04 15:26 UTC, Bernard Spil
no flags Details
svn diff for lang/python27 (31.11 KB, patch)
2015-03-04 15:41 UTC, Bernard Spil
no flags Details | Diff
svn diff for lang/python27 (31.11 KB, patch)
2015-03-05 08:34 UTC, Bernard Spil
no flags Details | Diff
svn diff for lang/python27 (32.71 KB, patch)
2015-03-05 12:41 UTC, Bernard Spil
no flags Details | Diff
svn diff for lang/python27 (31.94 KB, patch)
2015-03-13 12:49 UTC, Bernard Spil
no flags Details | Diff
Poudriere build log python27 linking to libcrypto.so.32.0.0 (563.27 KB, text/plain)
2015-03-13 22:19 UTC, Bernard Spil
no flags Details
non-svn diff for lang/python27 (32.69 KB, patch)
2015-03-13 22:19 UTC, Bernard Spil
no flags Details | Diff
shar of lang/python27 (199.22 KB, text/plain)
2015-03-13 22:20 UTC, Bernard Spil
no flags Details
Tarball of the re-rolled port (28.92 KB, application/octet-stream)
2015-03-13 22:20 UTC, Bernard Spil
no flags Details
svn diff for lang/python27 (36.55 KB, patch)
2015-03-15 12:19 UTC, Bernard Spil
no flags Details | Diff
Poudriere build log python27 linking to libcrypto.so.32.0.0 (563.05 KB, text/plain)
2015-03-15 12:20 UTC, Bernard Spil
no flags Details
regression-test output for lang/python27 (45.41 KB, text/plain)
2015-03-15 12:21 UTC, Bernard Spil
no flags Details
non-svn diff for lang/python27 2.7.9_1 and LibreSSL 2.1.6 (561.63 KB, text/plain)
2015-04-10 19:44 UTC, Bernard Spil
no flags Details
Make regression-test output (16.34 KB, text/plain)
2015-05-24 10:48 UTC, Bernard Spil
no flags Details
Updated patch for python27-2.7.10 (13.89 KB, patch)
2015-05-31 22:31 UTC, Robert Zelaya
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description meyer.arne83 2014-08-08 12:15:03 UTC
Created attachment 145517 [details]
fix lang/python27 build with libressl
Comment 1 Marcus von Appen freebsd_committer freebsd_triage 2014-08-08 12:55:28 UTC
Root problem:
As soon as libressl is installed via ports, lang/pythonXX and other ports will try to pick it up, most likely due to the include and linker flags order. This is problematic in two regards:

* lang/python27 does not have an explicit BUILD/RUN_DEPENDS on libressl, since libressl is not officially supported by upstream (yet)
* libressl is API and ABI incompatible with OpenSSL, so depending on the system status (libressl installed or not), python will take the one or other.

I do not like the patch, since it would disable the function for both, OpenSSL and libressl and thus effectively change the behaviour of lang/pythonXX.

We need to get two things right:

* handle OpenSSL support correctly and explicitly use OpenSSL, so that an installed SSL replacement does not cause a wrong and unintended behaviour
* offer users to link against libressl explicitly (via an OPTION), which can cause different behaviour.
Comment 2 meyer.arne83 2014-08-08 14:44:53 UTC
(In reply to Marcus von Appen from comment #1)
> Root problem:
> As soon as libressl is installed via ports, lang/pythonXX and other ports
> will try to pick it up, most likely due to the include and linker flags
> order. This is problematic in two regards:
> 
> * lang/python27 does not have an explicit BUILD/RUN_DEPENDS on libressl,
> since libressl is not officially supported by upstream (yet)
> * libressl is API and ABI incompatible with OpenSSL, so depending on the
> system status (libressl installed or not), python will take the one or other.
> 
> I do not like the patch, since it would disable the function for both,
> OpenSSL and libressl and thus effectively change the behaviour of
> lang/pythonXX.
Does RAND_egd even work on FreeBSD? 
I also tried to preserve the python ssl api by having PySSL_RAND_egd just return an error. So I don't think it's behaviour has changed. Might have missed something, tho.
> We need to get two things right:
> 
> * handle OpenSSL support correctly and explicitly use OpenSSL, so that an
> installed SSL replacement does not cause a wrong and unintended behaviour
> * offer users to link against libressl explicitly (via an OPTION), which can
> cause different behaviour.
How about this:
* Add smt. like WITH_OPENSSL_LIBRE and some logic to bsd.openssl.mk
* Have the libressl port fail to build without that flag set.
* Add a static library or c file with dummy functions(RAND_egd, ...) to libressl.
Comment 3 Marcus von Appen freebsd_committer freebsd_triage 2014-08-08 15:51:35 UTC
(In reply to meyer.arne83 from comment #2)
> (In reply to Marcus von Appen from comment #1)
> > Root problem:
> > As soon as libressl is installed via ports, lang/pythonXX and other ports
> > will try to pick it up, most likely due to the include and linker flags
> > order. This is problematic in two regards:
> > 
> > * lang/python27 does not have an explicit BUILD/RUN_DEPENDS on libressl,
> > since libressl is not officially supported by upstream (yet)
> > * libressl is API and ABI incompatible with OpenSSL, so depending on the
> > system status (libressl installed or not), python will take the one or other.
> > 
> > I do not like the patch, since it would disable the function for both,
> > OpenSSL and libressl and thus effectively change the behaviour of
> > lang/pythonXX.
> Does RAND_egd even work on FreeBSD? 
> I also tried to preserve the python ssl api by having PySSL_RAND_egd just
> return an error. So I don't think it's behaviour has changed. Might have
> missed something, tho.

This is just the minor part of the issue. The bigger problem is the library being pulled in.

> > We need to get two things right:
> > 
> > * handle OpenSSL support correctly and explicitly use OpenSSL, so that an
> > installed SSL replacement does not cause a wrong and unintended behaviour
> > * offer users to link against libressl explicitly (via an OPTION), which can
> > cause different behaviour.
> How about this:
> * Add smt. like WITH_OPENSSL_LIBRE and some logic to bsd.openssl.mk
> * Have the libressl port fail to build without that flag set.

That sounds reasonable. I added the libressl maintainer and portmgr@ to this issue to get their feedback on it.

> * Add a static library or c file with dummy functions(RAND_egd, ...) to
> libressl.

That might contradict the purpose of libressl and adds a can of worms (local patches), which should be avoided. Best'd be to ask the upstream developers of libressl about such things, I think.
Comment 4 meyer.arne83 2014-08-08 17:51:10 UTC
(In reply to Marcus von Appen from comment #3)
> (In reply to meyer.arne83 from comment #2)
> > (In reply to Marcus von Appen from comment #1)

[...]

> > > We need to get two things right:
> > > 
> > > * handle OpenSSL support correctly and explicitly use OpenSSL, so that an
> > > installed SSL replacement does not cause a wrong and unintended behaviour
> > > * offer users to link against libressl explicitly (via an OPTION), which can
> > > cause different behaviour.
> > How about this:
> > * Add smt. like WITH_OPENSSL_LIBRE and some logic to bsd.openssl.mk
> > * Have the libressl port fail to build without that flag set.
> 
> That sounds reasonable. I added the libressl maintainer and portmgr@ to this
> issue to get their feedback on it.
> 
I implemented the WITH_OPENSSL_LIBRE logic on my laptop. Tested it. Looks good so far. The only issue is: Are there ports who have a hard dependency on openssl/ports?
> > * Add a static library or c file with dummy functions(RAND_egd, ...) to
> > libressl.
> 
> That might contradict the purpose of libressl and adds a can of worms (local
> patches), which should be avoided. Best'd be to ask the upstream developers
> of libressl about such things, I think.
Yeah. You're right about that. I have a patch for libressl that adds back the RAND_egd api. But the functions just return -1 (means no connection to egd). As RAND_egd is the main reason for breakage, and basically useless, that seems like a tolerable approach to me. That way, we don't have to patch every user of that api. With that patch and the change to bsd.openssl.mk I can compile python27 without my first patch.

I can open up a new bug with my patches, if anyone is interested...
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-05 15:19:54 UTC
Canonicalise python@ assignment.
Comment 6 Jens K. Loewe 2014-11-11 16:46:06 UTC
Annoyingly, everything that needs py27 as a dependence (like py-fail2ban) stops installation with "signal 11" if LibreSSL is installed.

The main problem is that "touch .../_ssl.so" is required for python27 before "make install" works as it should.
Comment 7 Bernard Spil freebsd_committer 2014-11-28 09:44:25 UTC
Created a patch that makes the build figure out RAND_egd support.
This has been submitted upstream in http://bugs.python.org/issue21356, a Python committer has indicated they willing to include this in their code.
"We're still willing to fix this if someone tells us how to test for LibreSSL in C code."
Comment 8 Bernard Spil freebsd_committer 2014-11-28 10:46:53 UTC
Created attachment 149952 [details]
Patch the port to detect RAND_egd and disable it conditionally
Comment 9 Bernard Spil freebsd_committer 2014-11-28 20:47:32 UTC
Created attachment 149974 [details]
Single patch for this PR for the source tree

This requires the Makefile patch as well!
Comment 10 Bernard Spil freebsd_committer 2014-11-28 20:50:58 UTC
Created attachment 149975 [details]
Patch for Makefile

Primarily passes LDFLAGS and CPPFLAGS to configure otherwise it will not pick up OpenSSL/LibreSSL from ports
Comment 11 Bernard Spil freebsd_committer 2014-11-28 20:52:39 UTC
Created attachment 149976 [details]
Output of the test_ssl unit test

There are expected failures/errors in this test, SSLv23 and SSLv3 are not supported by LibreSSL
Comment 12 Bernard Spil freebsd_committer 2014-11-29 21:26:58 UTC
Created attachment 149998 [details]
Single patch for this PR for the source tree

Lib/ssl.py was missing
Tested again, see build.log
Comment 13 Bernard Spil freebsd_committer 2014-11-29 21:27:50 UTC
Created attachment 149999 [details]
Output of the test_ssl unit test
Comment 14 Bernard Spil freebsd_committer 2014-11-29 21:28:15 UTC
Created attachment 150000 [details]
Build log
Comment 15 Bernard Spil freebsd_committer 2014-12-23 14:43:09 UTC
Created attachment 150909 [details]
Patch for Makefile

Adapted for python27-2.7.9
Comment 16 Bernard Spil freebsd_committer 2014-12-23 14:44:04 UTC
Created attachment 150910 [details]
Single patch for this PR for the source tree
Comment 17 Jens K. Loewe 2014-12-24 00:56:28 UTC
^ this fails with Python 2.7.9 yet:


===>   Registering installation for python27-2.7.9
pkg-static: Unable to access file /usr/ports/lang/python27/work/stage/usr/local/bin/2to3-2.7: No such file or directory
pkg-static: Unable to access file /usr/ports/lang/python27/work/stage/usr/local/bin/idle2.7: No such file or directory
pkg-static: Unable to access file /usr/ports/lang/python27/work/stage/usr/local/bin/pydoc2.7: No such file or directory
pkg-static: Unable to access file /usr/ports/lang/python27/work/stage/usr/local/lib/python2.7/lib-dynload/ossaudiodev.so: No such file or directory
*** Error code 74
Comment 18 Bernard Spil freebsd_committer 2014-12-24 18:35:55 UTC
Created attachment 150944 [details]
Poudriere build log

Can't reproduce the pkg-static errors, see poudriere build log.
Jens: Did you use the latest patch or the original one?

After install of the package I have
lrwxr-xr-x  1 root  wheel    6 Oct  3 01:49 /usr/local/bin/2to3 -> 2to3-2
lrwxr-xr-x  1 root  wheel    8 Oct  3 01:46 /usr/local/bin/2to3-2 -> 2to3-2.7
-rwxr-xr-x  1 root  wheel  101 Dec 24 19:25 /usr/local/bin/2to3-2.7
Comment 19 Jens K. Loewe 2014-12-24 19:40:38 UTC
I used the latest one.
Comment 20 Kevin Zheng 2015-01-02 03:03:39 UTC
Using the version in the ports tree, I'm getting this error:
*** WARNING: renaming "_ssl" since importing it failed: build/lib.freebsd-10.1-RELEASE-p2-amd64-2.7/_ssl.so: Undefined symbol "SSLv2_method"

This probably happened because LibreSSL ripped out SSLv2 support, which causes the ssl module to not be built, leading to a package failure later on:

Failed to build these modules:
_ssl

pkg-static: Unable to access file /wrkdirs/usr/ports/lang/python27/work/stage/usr/local/lib/python2.7/lib-dynload/_ssl.so: No such file or directory
*** Error code 1

I've reported this problem here because all of the above patches seem to deal only with the RAND_egd() issue.
Comment 21 Bernard Spil freebsd_committer 2015-01-02 11:31:43 UTC
Created attachment 151207 [details]
Patch for Makefile

Revised patch, previous patch would fail when WITH_OPENSSL_PORT was NOT set. This construct works whether WITH_OPENSSL_PORT is defined or not.
Comment 22 Bernard Spil freebsd_committer 2015-01-02 11:34:03 UTC
Created attachment 151208 [details]
Build log with LibreSSL installed

This is just the make output with LibreSSL 2.1.2 installed and in make.conf
WITH_OPENSSL_PORT=    yes
OPENSSL_SHLIBVER=     30
OPENSSL_PORT=         security/libressl

The Poudriere build log is built without LibreSSL as a regression check for the port.
Comment 23 Bernard Spil freebsd_committer 2015-01-02 11:41:54 UTC
Jens, Kevin,

How are you building? You will need to have LibreSSL (2.1.2 at the moment) installed and the following in your /etc/make.conf
WITH_OPENSSL_PORT=    yes
OPENSSL_SHLIBVER=     30
OPENSSL_PORT=         security/libressl

Python has been modified to cope with SSLv2 not being available some time ago.
Comment 24 Kevin Zheng 2015-01-02 16:11:13 UTC
Bernard,

Thanks for the quick response. Indeed, I didn't set OPENSSL_SHLIBVER, is this documented somewhere ('bsd.openssl.mk' has default set to 8)?

After setting OPENSSL_SHLIBVER and applying both patches Python built correctly. Thanks for investigating this issue and working out a patch!
Comment 25 Jens K. Loewe 2015-02-02 11:01:15 UTC
Latest Python 2.7.9 has the _ssl.so error even with the make.conf entries again.
Comment 26 Johannes Jost Meixner freebsd_committer 2015-02-03 20:29:19 UTC
What are we missing to get python 2.7.9 and libressl running, then?
Comment 27 Bernard Spil freebsd_committer 2015-03-04 09:04:13 UTC
See https://bugs.freebsd.org/bugzilla/attachment.cgi?id=153769 for a successful Poudriere build log of Python 2.7 with LibreSSL 2.1.4
Comment 28 Kubilay Kocak freebsd_committer freebsd_triage 2015-03-04 11:04:27 UTC
Bernard will be:

- Obsoleting all current attachments
- Attaching a new combined diff, AND
- Attaching new QA logs
Comment 29 Bernard Spil freebsd_committer 2015-03-04 15:26:06 UTC
Created attachment 153781 [details]
svn diff for lang/python27

Beware that this also renames a number of patches as make makepatch generates them.
Comment 30 Bernard Spil freebsd_committer 2015-03-04 15:26:37 UTC
Created attachment 153782 [details]
Poudriere build log python27 linking to libcrypto.so.32.0.0
Comment 31 Bernard Spil freebsd_committer 2015-03-04 15:41:06 UTC
Created attachment 153783 [details]
svn diff for lang/python27

Forgot to svn rm the old patches... Fixed!
Comment 32 Bernard Spil freebsd_committer 2015-03-05 08:34:17 UTC
Created attachment 153820 [details]
svn diff for lang/python27

Updated patches as per koobs@' request
Comment 33 Bernard Spil freebsd_committer 2015-03-05 12:41:29 UTC
Created attachment 153828 [details]
svn diff for lang/python27

Now with the new patch
 1. Comments from code to the patch header
 2. Patches generated by make makepatch and info from original patches merged
Comment 34 Bernard Spil freebsd_committer 2015-03-13 12:49:18 UTC
Created attachment 154266 [details]
svn diff for lang/python27
Comment 35 Bernard Spil freebsd_committer 2015-03-13 22:18:26 UTC
I'm out of my wits now... 
This whole patch thing is just becoming way to convoluted. Of the existing 10 (TEN) patches currently in files only 3 (THREE) are according to the naming standard of make makepatch, one is not named after the file it modifies but after a PR number so an svn diff is effectively deleting most of the patches and then adding them again. I've re-rolled these patches a large number of times now and although I want to adhere to all of the policies I feel this port is beyond repair. First bring this port in line with all of the policies and _then_ I will provide an svn diff. Until then, use the tarball or the non-svn diff or the shar. Every make makepatch trashes the comments preceding the actual patch and require manual re-adding... ... ...

The CPPFLAGS and LDFLAGS additions in the Makefile are required to fix RAND_egd detection in configure, without it checks libcrypto / RAND_egd from base.
Comment 36 Bernard Spil freebsd_committer 2015-03-13 22:19:10 UTC
Created attachment 154280 [details]
Poudriere build log python27 linking to libcrypto.so.32.0.0
Comment 37 Bernard Spil freebsd_committer 2015-03-13 22:19:52 UTC
Created attachment 154281 [details]
non-svn diff for lang/python27

from /usr/ports
Comment 38 Bernard Spil freebsd_committer 2015-03-13 22:20:14 UTC
Created attachment 154282 [details]
shar of lang/python27
Comment 39 Bernard Spil freebsd_committer 2015-03-13 22:20:47 UTC
Created attachment 154283 [details]
Tarball of the re-rolled port
Comment 40 Bernard Spil freebsd_committer 2015-03-15 12:19:58 UTC
Created attachment 154342 [details]
svn diff for lang/python27

Now a proper svn diff, tested and used to generate regression-test and poudriere logs
Comment 41 Bernard Spil freebsd_committer 2015-03-15 12:20:32 UTC
Created attachment 154344 [details]
Poudriere build log python27 linking to libcrypto.so.32.0.0
Comment 42 Bernard Spil freebsd_committer 2015-03-15 12:21:02 UTC
Created attachment 154345 [details]
regression-test output for lang/python27
Comment 43 Craig Rodrigues freebsd_committer 2015-03-23 01:10:47 UTC
I just installed these ports on a CURRENT system:

mercurial-3.3.2
python27-2.7.9

I then typed:

hg clone https://bitbucket.org/mcdeck/cunit-to-junit/

and got this:

abort: /usr/local/lib/python2.7/lib-dynload/_ssl.so: Undefined symbol "SSLv2_method"!

Is there a fix for this available?
Comment 44 Bernard Spil freebsd_committer 2015-03-23 08:31:18 UTC
Hi Rodrigo, SSLv2 was completely removed from LibreSSL, so any fixing will need to be done in the mercurial code.
Comment 45 Seth 2015-04-10 14:06:40 UTC
Has the diff been tested against LibreSSL 2.1.6?

Just tried to build python27-2.7.9_1 from ports against libressl 2.1.6 and it failed during pkg installation with error:

===>   Registering installation for python27-2.7.9_1 as automatic
pkg-static: Unable to access file /usr/pkg/usr/ports/lang/python27/work/stage/usr/local/lib/python2.7/lib-dynload/_ssl.so: No such file or directory
*** [fake-pkg] Error code 74

Stop in /usr/ports/lang/python27.
Comment 46 Bernard Spil freebsd_committer 2015-04-10 19:42:26 UTC
(In reply to Seth from comment #45)
Hi Seth,

Yes this has been tested against 2.1.6 with Python-2.7.9_1 will add an updated poudriere build log.
Comment 47 Bernard Spil freebsd_committer 2015-04-10 19:44:01 UTC
Created attachment 155432 [details]
non-svn diff for lang/python27 2.7.9_1 and LibreSSL 2.1.6

_1 was only a version bump for the -HEAD tracking people
Comment 48 Seth 2015-04-11 15:20:10 UTC
Thanks, I'll give it a try. 

Is there a rough time frame for committing the patch to the ports tree?
Comment 49 Mathieu Arnold freebsd_committer 2015-05-04 10:56:58 UTC
Any reason this has not been applied yet ?
This, or the upstream version, https://hg.python.org/cpython/rev/eddcb6671a48 that should be about the same.
Comment 50 Kevin Zheng 2015-05-04 21:36:29 UTC
(In reply to Mathieu Arnold from comment #49)
I've been using this patch locally for several months; it works fine! Considering that the same patch has been upstreamed, someone on python@ should really go ahead and commit this.
Comment 51 Franco Fichtner 2015-05-07 06:31:31 UTC
+1 for merging this :)
Comment 52 Johannes Jost Meixner freebsd_committer 2015-05-12 18:36:17 UTC
*** Bug 199826 has been marked as a duplicate of this bug. ***
Comment 53 Bernard Spil freebsd_committer 2015-05-13 13:47:00 UTC
By now we're close to 2.7.10 which is planned for release this month
2.7.10rc1 2015-05-09
2.7.10 2015-05-23
Can someone start the port for 2.7.10rc1?
Comment 54 Bernard Spil freebsd_committer 2015-05-24 10:46:27 UTC
Comment on attachment 154342 [details]
svn diff for lang/python27

Superseeded by 2.7.10
Comment 55 Bernard Spil freebsd_committer 2015-05-24 10:48:07 UTC
Created attachment 157097 [details]
Make regression-test output

Built with base openssl
When built with libressl regression-test fails on a version-test
Comment 56 Bernard Spil freebsd_committer 2015-05-24 10:53:44 UTC
See https://reviews.freebsd.org/D2637
or https://github.com/Sp1l/ports/blob/master/patches/patch-lang_python27-2.7.10

CONFIGURE_ENV still requires modification with the new 2.7.10 version
Patches renamed as per makepatch standard
Comment 57 Robert Zelaya 2015-05-31 22:29:53 UTC
(In reply to Bernard Spil from comment #56)

There is a simple path error in this patch.
https://github.com/Sp1l/ports/blob/master/patches/patch-lang_python27-2.7.10

Attached is the fixed patch. After the applied patch poudriere built python with out issues.
Comment 58 Robert Zelaya 2015-05-31 22:31:50 UTC
Created attachment 157316 [details]
Updated patch for python27-2.7.10

(In reply to Bernard Spil from comment #56)

There is a simple path error in this patch.
https://github.com/Sp1l/ports/blob/master/patches/patch-lang_python27-2.7.10

Attached is the fixed patch. After the applied patch poudriere built python with out issues.
Comment 59 elij 2015-06-24 04:00:22 UTC
I ran into this today, when trying to build ports with libressl. Any update?
Comment 60 Bernard Spil freebsd_committer 2015-06-24 06:54:40 UTC
Better check https://reviews.freebsd.org/D2637 it contains the latest patches.
Comment 61 commit-hook freebsd_committer 2015-07-03 13:28:23 UTC
A commit references this bug:

Author: brnrd
Date: Fri Jul  3 13:27:44 UTC 2015
New revision: 391238
URL: https://svnweb.freebsd.org/changeset/ports/391238

Log:
  lang/python: Update to 2.7.10

  The FreeBSD Python team welcomes Python 2.7.10 to the Ports tree!

  Announcement:	https://www.python.org/downloads/release/python-2710/
  Changelog:	https://hg.python.org/cpython/raw-file/v2.7.10/Misc/NEWS

  Important changes for this release:
   - Python 2.7.10 is a bug fix release of the Python 2.7.x series.
   - Fixes issues with LibreSSL 2.2+

  PR: 		192511, 201088
  Differentialr Revision:	D2637
  Reviewed by:	koobs (mentor), vsevolod (mentor), antoine
  Approved by:	koobs (mentor)

Changes:
  head/lang/python27/Makefile
  head/lang/python27/distinfo
  head/lang/python27/files/patch-Doc__library__fcntl.rst
  head/lang/python27/files/patch-Lib__distutils__unixccompiler.py
  head/lang/python27/files/patch-Lib_distutils_command_build__scripts.py
  head/lang/python27/files/patch-Lib_distutils_command_build_scripts.py
  head/lang/python27/files/patch-Makefile.pre.in
  head/lang/python27/files/patch-Modules-_ctypes-libffi-configure
  head/lang/python27/files/patch-Modules___ctypes__libffi__src__arm__ffi.c
  head/lang/python27/files/patch-Modules___ssl.c
  head/lang/python27/files/patch-Modules__fcntlmodule.c
  head/lang/python27/files/patch-setup.py
  head/lang/python27/pkg-plist
Comment 62 commit-hook freebsd_committer 2015-07-03 13:35:33 UTC
A commit references this bug:

Author: brnrd
Date: Fri Jul  3 13:34:42 UTC 2015
New revision: 391239
URL: https://svnweb.freebsd.org/changeset/ports/391239

Log:
  lang/python-(tools,doc-html): Update to 2.7.10

  The FreeBSD Python team welcomes Python 2.7.10 to the Ports tree!

  Announcement:	https://www.python.org/downloads/release/python-2710/
  Changelog:	https://hg.python.org/cpython/raw-file/v2.7.10/Misc/NEWS

  Important changes for this release:
   - Python 2.7.10 is a bug fix release of the Python 2.7.x series.
   - Fixes issues with LibreSSL 2.2+

  PR: 		192511, 201088
  Differentialr Revision:	D2637
  Reviewed by:	koobs (mentor), vsevolod (mentor), antoine
  Approved by:	koobs (mentor)

Changes:
  head/lang/python-tools/Makefile
Comment 63 commit-hook freebsd_committer 2015-07-03 13:38:38 UTC
A commit references this bug:

Author: brnrd
Date: Fri Jul  3 13:37:43 UTC 2015
New revision: 391240
URL: https://svnweb.freebsd.org/changeset/ports/391240

Log:
  lang/python-doc-html: Update to 2.7.10

  The FreeBSD Python team welcomes Python 2.7.10 to the Ports tree!

  Announcement:	https://www.python.org/downloads/release/python-2710/
  Changelog:	https://hg.python.org/cpython/raw-file/v2.7.10/Misc/NEWS

  Important changes for this release:
   - Python 2.7.10 is a bug fix release of the Python 2.7.x series.
   - Fixes issues with LibreSSL 2.2+

  PR: 		192511, 201088
  Differentialr Revision:	D2637
  Reviewed by:	koobs (mentor), vsevolod (mentor), antoine
  Approved by:	koobs (mentor)

Changes:
  head/lang/python-doc-html/distinfo
Comment 64 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-07 06:02:54 UTC
Over to Bernard to close if complete.