Bug 192537 - Port Update: devel/boost-*
Summary: Port Update: devel/boost-*
Status: Closed DUPLICATE of bug 199601
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-office mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-09 21:24 UTC by Jordan Irwin
Modified: 2015-04-22 06:55 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jordan Irwin 2014-08-09 21:24:33 UTC
Update available for Boost libraries. New upstream version: 1.56.0. Current ports version 1.55.0.

Ports affected (I think):
  devel/boost-all
  devel/boost-docs
  devel/boost-jam
  devel/boost-libs
  devel/boost-python-libs

http://sourceforge.net/projects/boost/
Comment 1 Jordan Irwin 2014-08-09 21:25:21 UTC
CC'd maintaner.
Comment 2 John Marino freebsd_committer 2014-08-09 22:30:16 UTC
Jordan, I'm assigning this to the maintainer as well, but I am curious about the motivation.

Do you realize that each time boost is updated, dozens of ports break?  The fact that office@ owns it tells me openoffice / libreoffice are also sensitive the version.  I think at the very least you are looking a an EXP-RUN to figure out what the damage would be.

So that said, why are proposing to the boost maintainer to update this before they feel it's necessary?  Like I said, I am mainly curious.  There's no wrong answer.
Comment 3 Jordan Irwin 2014-08-09 22:44:31 UTC
No, I didn't know that it caused port breaks. I simply got an email notification from SF that Boost had been updated. So I thought I would notify the maintainer about it. Perhaps it would be better for me to email maintainers directly rather than post to bugs for updates?
Comment 4 John Marino freebsd_committer 2014-08-09 22:48:07 UTC
PRs are cheap and public, and appropriate if you have patches.  If it's just "hey, there's a newer version available" then PRs are not appropriate.

Especially if it's on sourceforge, the maintainers already know about updated versions availability because portscout sends an email and tracks it.

Anyway, it's fine.  office@ knows now and can close the PR if they want.
Comment 5 Jordan Irwin 2014-08-09 22:49:47 UTC
Okay, thanks. From now on if I feel the need to contact a maintainer about updates I will do so directly.
Comment 6 Baptiste Daroussin freebsd_committer 2014-08-26 05:55:07 UTC
boost is always a big beast to upgrade, and we do try to upgrade it with caution.
1.56.0 will happen but we first need to determine what is breaks :)
Comment 7 John Marino freebsd_committer 2015-02-13 14:37:00 UTC
1.57 is out now.

1.55 cannot be built with gcc-5 without patches due to c++11 errors.

Can office@ think about upgrading?  1.57 is one year ahead of 1.55.  For boost, that's a long time.
Comment 8 Kurt Jaeger freebsd_committer 2015-04-16 14:20:09 UTC
The upgrade is being worked on in

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=198751
Comment 9 Baptiste Daroussin freebsd_committer 2015-04-22 06:55:12 UTC

*** This bug has been marked as a duplicate of bug 199601 ***