Bug 192550 - net/mDNSResponder conflicts with net/howl
Summary: net/mDNSResponder conflicts with net/howl
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-10 13:32 UTC by Eir Nym
Modified: 2014-08-12 18:26 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eir Nym 2014-08-10 13:32:56 UTC
This is duplicate of 96126, but it is actual again.

===>  Installing for howl-1.0.0_2
===>  Checking if howl already installed
===>   Registering installation for howl-1.0.0_2
+ set -- howl-1.0.0_2
+ /sbin/ldconfig -m /usr/local/lib
+ cd /usr/local
Installing howl-1.0.0_2...pkg-static: howl-1.0.0_2 conflicts with mDNSResponder-544_1 (installs files into the same place).  Problematic file: /usr/local/etc/rc.d/mdnsresponder
*** Error code 70

Stop.
make: stopped in /usr/ports/net/howl
Comment 1 John Marino freebsd_committer 2014-08-10 13:42:15 UTC
bug 96126 returned.

Eir, who is the culprit?  Howl or mdnsresponder?  One of them must have changed since then.
Comment 2 Eir Nym 2014-08-10 13:51:52 UTC
Dependency conflicts are:

mDNSresponder conflicts with avahi-libdns-[0-9]*
avahi-ldns conflicts with mDNSResponder-[0-9]*

howl conflicts with avahi-[0-9]*
avahi-app conflicts with howl-[0-9]* (only if *not* slave)
Comment 3 John Marino freebsd_committer 2014-08-10 13:58:57 UTC
that wasn't really my question.

A conflict is 2 ports trying to install a file in the same place.  At first glance, *both* ports are at fault, but one has to change.

In the case, the previous bug cleared the conflict, but the conflict returned.  That means one of the two ports made a change that restored the conflict and thus is at fault (it needs to change back).

So I was asking who the bad citizen was.
Comment 4 Eir Nym 2014-08-10 14:19:55 UTC
As I see howl plist, problematic file should not be here. howl doesn't provide mDNSResponderPosix executable.
Comment 5 Po-Chuan Hsieh freebsd_committer 2014-08-10 17:48:16 UTC
The conflict in PR/96126 is bin/mDNSResponder. Now it's about etc/rc.d/mdnsresponder.

I added ${PREFIX}/etc/rc.d/mdnsresponder to net/mDNSResponder in r332470 (PR/182721). This could be changed to mdnsresponderposix if necessary.
Comment 6 John Marino freebsd_committer 2014-08-10 17:50:46 UTC
I was just in the middle of posting that it was an RC script conflict.

Sunpoet, why don't you take this PR if your commit introduced the conflict?  You can fix it (or document it) however you want to.
Comment 7 commit-hook freebsd_committer 2014-08-12 18:25:51 UTC
A commit references this bug:

Author: sunpoet
Date: Tue Aug 12 18:25:26 UTC 2014
New revision: 364730
URL: http://svnweb.freebsd.org/changeset/ports/364730

Log:
  - Rename rc script to mdnsresponderposix to avoid conflicts with net/howl
  - Bump PORTREVISION for package change

  PR:		ports/192550
  Submitted by:	Eir Nym

Changes:
  head/net/mDNSResponder/Makefile
  head/net/mDNSResponder/files/mdnsresponder.in
  head/net/mDNSResponder/files/mdnsresponderposix.in
Comment 8 Po-Chuan Hsieh freebsd_committer 2014-08-12 18:26:23 UTC
Committed. Thanks!