Bug 192647 - [PATCH] sysutils/LPRng 3.8.C updates broke config file locations
Summary: [PATCH] sysutils/LPRng 3.8.C updates broke config file locations
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-14 04:03 UTC by Adam McDougall
Modified: 2014-08-14 22:08 UTC (History)
1 user (show)

See Also:


Attachments
Fix config path regression, improve sample config installation (1.72 KB, patch)
2014-08-14 04:03 UTC, Adam McDougall
no flags Details | Diff
Revised patch (bump portrevision) (1.87 KB, patch)
2014-08-14 12:46 UTC, Adam McDougall
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam McDougall 2014-08-14 04:03:00 UTC
Created attachment 145766 [details]
Fix config path regression, improve sample config installation

Short version: patch included to fix regression (wrong compiled config path in binaries), and switch port to @sample in plist.

I upgraded to the latest lprng 3.8.C port today and found lpq/lpr/(other?) were miscompiled with a broken path:

# lpq -Pprinter
Read_file_list: cannot stat required or included file '/lpd.conf' - No such file or directory

After investigation, I found the following two lines in the Makefile are breaking it.  Simply remove them (tested).
 --with-lpd_conf_path=${SYSCONFDIR}/lpd.conf \
 --with-lpd_perms_path=${SYSCONFDIR}/lpd.perms \

Additionally, I saw @sample was not being used in pkg-plist so I decided to try it out as an improvement.  Since the paths compiled above expect config files in /usr/local/etc, I thought that seems like a better place for the config files so I switched from DATADIR to PREFIX/etc which saves a few lines here and there.  If this part is contentious, I'm happy to leave it out, but the binaries do need to get fixed.  Thanks.
Comment 1 John Marino freebsd_committer 2014-08-14 06:37:01 UTC
no maintainer to move to patch-ready
Comment 2 Adam McDougall 2014-08-14 12:46:57 UTC
Created attachment 145771 [details]
Revised patch (bump portrevision)

Oops, forgot portrevision bump, uploading new patch.
Comment 3 John Marino freebsd_committer 2014-08-14 20:48:09 UTC
i already fixed this but commit messages are delayed a while, take so nobody duplicates work.
Comment 4 commit-hook freebsd_committer 2014-08-14 22:01:09 UTC
A commit references this bug:

Author: marino
Date: Thu Aug 14 20:43:49 UTC 2014
New revision: 364866
URL: http://svnweb.freebsd.org/changeset/ports/364866

Log:
  sysutils/LPRng: previous update broke config file locations, so fix them

  PR:		192647
  Submitted by:	Adam McDougall
  Approved by:	Nobody; port is unmaintained

Changes:
  head/sysutils/LPRng/Makefile
  head/sysutils/LPRng/pkg-plist