Bug 192696 - [Maintainer] Set a default theme and external browser for Eclipse
Summary: [Maintainer] Set a default theme and external browser for Eclipse
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Bartek Rutkowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-16 00:30 UTC by Jimmy Kelley
Modified: 2014-08-27 14:25 UTC (History)
3 users (show)

See Also:


Attachments
Port patch (3.61 KB, patch)
2014-08-16 00:30 UTC, Jimmy Kelley
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy Kelley 2014-08-16 00:30:42 UTC
Created attachment 145850 [details]
Port patch

Some eclipse plugin settings need to be modified to include the "freebsd" OS for the default UI theme (GTK) and a default external web browser (Firefox).
Make the build quieter in the pre-patch script.
Comment 1 John Marino freebsd_committer 2014-08-16 07:16:52 UTC
stupid diff viewer is eating half the patch.

This is a simple update from the maintainer, moving to patch-ready.
Comment 2 Bartek Rutkowski freebsd_committer 2014-08-24 15:07:45 UTC
Unfortunately I cant take care of this PR - the patch fails to build for me on 9.3 due to some Maven out of memory error, what's strange, since my testing machine has 16GB of RAM and 4GB of swap available, and it was building fine for 11 and 10 amd64/i386 - numerous attempts to build on 9.3 failed for me.
Comment 3 John Marino freebsd_committer 2014-08-24 17:34:26 UTC
Robak,
I don't see anything in the patch that is platform specific, so if 9.3 has a problem it was there before and not caused by patch.

I'll sign off on this if you want to commit it.
Comment 4 Bartek Rutkowski freebsd_committer 2014-08-24 17:58:28 UTC
I'd rather not, since I can't really get this thing built on 9.x and below. I will talk to Steve if he can try testing this on his setup, and if it goes well, I could take care of committing it. Until I can be sure it actually builds on all supported platforms, I'd rather not commit it.
Comment 5 John Marino freebsd_committer 2014-08-24 18:01:22 UTC
well, can you build it on 9.x without any modification?

http://portsmon.freebsd.org/portoverview.py?category=java&portname=eclipse



I suspect your poudriere just has a memory limit on tmpfs somewhere that's way too low.
Comment 6 Daniel Austin 2014-08-24 20:38:26 UTC
I've got a high ram, dedicated poudriere machine.

poudriere testport logs for 10.0/amd64 and 9.3/amd64 at:

http://poudriere.dan.tm/latest-per-pkg/eclipse/4.3.2_2/

(and if you wait another hour or so, 8.4/amd64 will be there also)
No problems building 9.3 package here.
Comment 7 John Marino freebsd_committer 2014-08-25 08:40:03 UTC
Thanks, Daniel.

I think that's sufficient proof to go ahead and commit the PR as-is now.
Comment 8 commit-hook freebsd_committer 2014-08-27 14:24:24 UTC
A commit references this bug:

Author: robak
Date: Wed Aug 27 14:23:58 UTC 2014
New revision: 366329
URL: http://svnweb.freebsd.org/changeset/ports/366329

Log:
  java/eclipse: Set a default theme and external browser

  PR:		192696
  Submitted by:	Jimmy Kelley <ljboiler@gmail.com>
  Reviewed by:	swills (mentor), marino (mentor)
  Approved by:	mentors (implicit)

Changes:
  head/java/eclipse/Makefile
  head/java/eclipse/files/patch-submodules
  head/java/eclipse/scripts/pre-patch
Comment 9 Bartek Rutkowski freebsd_committer 2014-08-27 14:25:15 UTC
Committed, thanks for your work!