Bug 192821 - www/chromium crashes when signing into chrome
www/chromium crashes when signing into chrome
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
amd64 Any
: --- Affects Only Me
Assigned To: chromium
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-18 21:29 UTC by Guillaume Bibaut
Modified: 2014-08-30 20:53 UTC (History)
10 users (show)

See Also:


Attachments
patch for devel/protobuf (643 bytes, patch)
2014-08-30 14:36 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Bibaut 2014-08-18 21:29:04 UTC

    
Comment 1 Guillaume Bibaut 2014-08-18 21:30:48 UTC
Chromium is crashing when I'm trying to sign in to Chromium.
Here is what I'm getting from terminal :

$ chrome
[1789:385901568:0818/231951:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.fr/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[1789:385901568:0818/231951:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.fr/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[1789:387692544:0818/231956:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:387692544:0818/232006:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:385901568:0818/232009:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.fr/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[1789:385901568:0818/232009:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.fr/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[1789:387692544:0818/232016:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:385901568:0818/232022:ERROR:CONSOLE(90)] "Uncaught TypeError: Cannot set property 'onclick' of null", source: chrome://components/components.js (90)
[1789:387692544:0818/232031:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:387692544:0818/232125:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:387692544:0818/232145:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:385901568:0818/232145:ERROR:raw_channel_posix.cc(218)] sendmsg/write/writev: Broken pipe
[1789:387692544:0818/232202:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:427998208:0818/232257:ERROR:get_updates_processor.cc(240)] PostClientToServerMessage() failed during GetUpdates
[1789:387692544:0818/232257:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:387692544:0818/232257:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:387692544:0818/232257:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[1789:387692544:0818/232257:ERROR:gservices_settings.cc(103)] Setting not found: checkin_interval
Segmentation fault
Comment 2 John Marino freebsd_committer 2014-08-18 21:31:46 UTC
over to chromium team...
Comment 3 Yanhui Shen 2014-08-19 03:36:37 UTC
I have this problem too.
Get segmentation fault immediately after login with my google account.

FreeBSD ThinkPad.local 10.0-STABLE FreeBSD 10.0-STABLE #0 r269851: Tue Aug 12 16:05:58 CST 2014     root@ThinkPad.local:/usr/obj/usr/src/sys/ThinkPad  amd64
Comment 4 Guillaume Bibaut 2014-08-19 06:35:24 UTC
Sorry I forgot to tell what version of FreeBSD :

$ uname -r
10.0-RELEASE-p7
Comment 5 miguelmclara 2014-08-19 11:13:05 UTC
I'm getting the same issue. Compilation was successful only using poudriere (Couldn't compile in the live host)

I was using Google Account to sync (using Encryption) and now It just crashes after opening.

I used --user-data-dir to change to a temp dir, it works and once I login to chrome it crashes!


chrome --user-data-dir=/tmp
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[62830:339764224:0819/120957:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.pt/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[62830:339764224:0819/120957:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.pt/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[62830:341495808:0819/121013:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[62830:339764224:0819/121036:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.pt/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[62830:339764224:0819/121036:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.pt/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[62830:341495808:0819/121109:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[62830:394674176:0819/121124:ERROR:get_updates_processor.cc(240)] PostClientToServerMessage() failed during GetUpdates
[62830:341495808:0819/121124:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[62830:341495808:0819/121124:ERROR:channel.cc(297)] RawChannel fatal error (type 1)
[62830:339764224:0819/121124:ERROR:profile_sync_service.cc(1292)] History Delete Directives datatype error was encountered: Delete directives not supported with encryption.
[62830:341495808:0819/121124:ERROR:gservices_settings.cc(103)] Setting not found: checkin_interval
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Bookmarks cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Preferences cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Passwords cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Autofill Profiles cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Autofill cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Themes cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Typed URLs cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Extensions cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Search Engines cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Sessions cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Apps cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] App settings cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Extension settings cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Favicon Images cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] Favicon Tracking cryptographer error was encountered: 
[62830:339764224:0819/121124:ERROR:data_type_manager_impl.cc(39)] App List cryptographer error was encountered: 
[62830:339764224:0819/121125:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.pt/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
[62830:339764224:0819/121125:ERROR:CONSOLE(113)] "Uncaught Strict get failed, invalid object.", source: https://www.google.pt/xjs/_/js/k=xjs.ntp.en_US.m8-TqNudpcQ.O/m=jsa,ntp,pcc,csi/rt=j/d=1/t=zcms/rs=AItRSTM4GKqdrFOr4RvvDHNSr57H62qpGw (113)
Segmentation fault (core dumped)
Comment 6 Rene Ladan freebsd_committer 2014-08-19 18:54:04 UTC
Reproducable here on 10.0-RELEASE using a poudriere build, but no culprit yet...
Comment 7 Rene Ladan freebsd_committer 2014-08-26 16:48:03 UTC
(In reply to Rene Ladan from comment #6)
> Reproducable here on 10.0-RELEASE using a poudriere build, but no culprit
> yet...

Self-replying... this is a catch-22 between not being able to build with the bundled protobuf on FreeBSD 8 and 9 and on one side and the ports protobuf crashing because the bundled version is a few SVN revision ahead :(
Comment 8 Jonathan Chen 2014-08-27 07:05:39 UTC
I tweaked the Makefile and can confirm that a port built with the bundled protobuf works fine on my  10/STABLE-amd64.
Comment 9 jiashiun 2014-08-27 13:08:32 UTC
According to stack trace in the dumped core file, 
(frame #0 libcxxrt, #1 libprotobuf, ...),
and in protobuf it seemed to crash at a point related to RTTI,
so I added -DGOOGLE_PROTOBUF_NO_RTTI to CFLAGS and rebuilt & reinstalled protobuf ports.

This solves the sign-in crash too for me on Chromium 37/-current, without using built-in protobuf or rebuilding Chromium.

Not sure if clang in base has enough RTTI support, or is it that protobuf failed to correctly detect whatever it needs during building.
Comment 10 Carlos J Puga Medina 2014-08-27 19:28:35 UTC
Yes, adding GOOGLE_PROTOBUF_NO_RTTI solves the issue. In protobuf.gyp is defined like this:

'defines': [
              'USE_SYSTEM_PROTOBUF',

              # This macro must be defined to suppress the use
              # of dynamic_cast<>, which requires RTTI.
              'GOOGLE_PROTOBUF_NO_RTTI',
              'GOOGLE_PROTOBUF_NO_STATIC_INITIALIZER',
            ],
Comment 11 Guillaume Bibaut 2014-08-28 01:09:56 UTC
This seems to work fine also for me, just installed Chromiun 37, and recompiled protobuf with that CFLAGS added.

(In reply to jiashiun from comment #9)
> According to stack trace in the dumped core file, 
> (frame #0 libcxxrt, #1 libprotobuf, ...),
> and in protobuf it seemed to crash at a point related to RTTI,
> so I added -DGOOGLE_PROTOBUF_NO_RTTI to CFLAGS and rebuilt & reinstalled
> protobuf ports.
> 
> This solves the sign-in crash too for me on Chromium 37/-current, without
> using built-in protobuf or rebuilding Chromium.
> 
> Not sure if clang in base has enough RTTI support, or is it that protobuf
> failed to correctly detect whatever it needs during building.
Comment 12 Steve Wills freebsd_committer 2014-08-30 14:36:52 UTC
Created attachment 146538 [details]
patch for devel/protobuf

Yep, this patch to devel/protobuf fixes chrome for me.
Comment 13 Vanilla I. Shu freebsd_committer 2014-08-30 15:21:30 UTC
Sure, Just Do It, it's ok to me.
Comment 14 commit-hook freebsd_committer 2014-08-30 17:49:13 UTC
A commit references this bug:

Author: swills
Date: Sat Aug 30 17:48:20 UTC 2014
New revision: 366656
URL: http://svnweb.freebsd.org/changeset/ports/366656

Log:
  devel/protobuf: disable RTTI to fix chrome

  Add -DGOOGLE_PROTOBUF_NO_RTTI to CFLAGS to fix chrome

  PR:		192821
  Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es>
  Approved by:	vanilla (maintainer)

Changes:
  head/devel/protobuf/Makefile
Comment 15 Steve Wills freebsd_committer 2014-08-30 20:50:51 UTC
Fix committed, seems to work. Re-open if you still have issues.