Bug 192844 - [stage] chinese/sunpinyin: stagify, fix build
[stage] chinese/sunpinyin: stagify, fix build
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: --- Affects Some People
Assigned To: John Marino
:
: 182221 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-20 03:56 UTC by Henry Hu
Modified: 2014-08-20 23:37 UTC (History)
2 users (show)

See Also:


Attachments
stagify and fix build (1.02 KB, patch)
2014-08-20 03:56 UTC, Henry Hu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Henry Hu 2014-08-20 03:56:10 UTC
Created attachment 146056 [details]
stagify and fix build

Stagify sunpinyin, and fix build with libc++: add missing stdlib.h include.
The fix is essentially the same as
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=182221
but that one is not committed. Instead of patching individual files, this patch patches portability.h which is included by most source files.
redports:
https://redports.org/buildarchive/20140820012101-62445/
Comment 1 John Marino freebsd_committer 2014-08-20 06:06:07 UTC
maintained by lichray but staging PRs don't need maintainer approval*, so moving to patch-ready


* This should have been reset but the referenced PR prevented the maintainer reset.
Comment 2 John Marino freebsd_committer 2014-08-20 06:06:53 UTC
*** Bug 182221 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2014-08-20 23:37:10 UTC
A commit references this bug:

Author: marino
Date: Wed Aug 20 23:36:36 UTC 2014
New revision: 365520
URL: http://svnweb.freebsd.org/changeset/ports/365520

Log:
  Stage chinese/sunpinyin and unbreak on FreeBSD 10+

  PR:		192844
  Submitted by:	Henry Hu

Changes:
  head/chinese/sunpinyin/Makefile
  head/chinese/sunpinyin/files/patch-src_portability.h
Comment 4 John Marino freebsd_committer 2014-08-20 23:37:54 UTC
I had to add the post-install target to pass stage-qa check without warnings.  Thanks for the PR!