Bug 192845 - [comconsole] kernel panic when using comconsole
Summary: [comconsole] kernel panic when using comconsole
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.3-RELEASE
Hardware: i386 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-20 05:55 UTC by ping1
Modified: 2014-08-20 05:55 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ping1 2014-08-20 05:55:46 UTC
When activating comconsole on an IBM host (IBM xseries 336 hardware), the boot fails when activating the com port using console="comconsole,vidconsole" in /boot/loader.conf.
This does *not* happen with 9.1-RELEASE but happen when using either 9.3-RELEASE or 10.0-RELEASE.


The stacktrace:

    [...]
    bge0: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev. 0x004101> mem 0xdcff0000-0xdcffffff irq 16 at device 0.0 on pci6
    bge0: CHIP ID 0x00004101; ASIC REV 0x04; CHIP REV 0x41; PCI-E
    miibus0: <MII bus> on bge0
    ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
    ukphy0:  no media present
    ifmedia_set: no match for 0x0/0xfffffff
    panic: ifmedia_set
    cpuid = 0
    KDB: stack backtrace:
    #0 0xc0af6f12 at kdb_backtrace+0x52
    #1 0xc0abce21 at panic+0x121
    #2 0xc0b86744 at ifmedia_set+0x64
    #3 0xc0794dc1 at miibus_mediainit+0x91
    #4 0xc07965b3 at mii_phy_dev_attach+0x273
    #5 0xc079d8a5 at ukphy_attach+0x35
    #6 0xc0aede68 at device_attach+0x3d8
    #7 0xc0aeeeeb at bus_generic_attach+0x2b
    #8 0xc0794780 at miibus_attach+0xb0
    #9 0xc0aede68 at device_attach+0x3d8
    #10 0xc0aeeeeb at bus_generic_attach+0x2b
    #11 0xc0794353 at mii_attach+0x4a3
    #12 0xc0670912 at bge_attach+0x43e2
    #13 0xc0aede68 at device_attach+0x3d8
    #14 0xc0aeeeeb at bus_generic_attach+0x2b
    #15 0xc0540dba at acpi_pci_attach+0x19a
    #16 0xc0aede68 at device_attach+0x3d8
    #17 0xc0aeeeeb at bus_generic_attach+0x2b
    Uptime: 1s


When disabling the comconsole (ie using only vidconsole), the boot succeeds nicely:

    [...]
    bge0: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev. 0x004101> mem 0xdcff0000-0xdcffffff irq 16 at device 0.0 on pci6
    bge0: CHIP ID 0x00004101; ASIC REV 0x04; CHIP REV 0x41; PCI-E
    miibus0: <MII bus> on bge0
    ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
    ukphy0:  none, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto, auto-flow
    bge0: Ethernet address: 00:14:5e:80:83:32
    pcib6: <ACPI PCI-PCI bridge> at device 7.0 on pci0
    pci7: <ACPI PCI bus> on pcib6
    bge1: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev. 0x004101> mem 0xdaff0000-0xdaffffff irq 16 at device 0.0 on pci7
    bge1: CHIP ID 0x00004101; ASIC REV 0x04; CHIP REV 0x41; PCI-E
    miibus1: <MII bus> on bge1
    brgphy0: <BCM5750 1000BASE-T media interface> PHY 1 on miibus1
    brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, auto, auto-flow
    bge1: Ethernet address: 00:14:5e:80:83:33
    [...]