Bug 192954 - [new port] net-im/uTox
Summary: [new port] net-im/uTox
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL: https://redports.org/browser/fidaj/ne...
Keywords:
: 192955 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-23 22:45 UTC by Ivan Klymenko
Modified: 2014-08-28 12:27 UTC (History)
1 user (show)

See Also:


Attachments
shar file port net-im/uTox (11.21 KB, application/x-shar)
2014-08-24 08:59 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox 'USES=desktop-file-utils' fix (11.22 KB, text/plain)
2014-08-24 09:17 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox (13.78 KB, text/plain)
2014-08-24 10:33 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox (13.75 KB, text/plain)
2014-08-24 10:41 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox (14.87 KB, text/plain)
2014-08-24 19:50 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox (6.87 KB, text/plain)
2014-08-27 20:27 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox (6.73 KB, text/plain)
2014-08-27 20:30 UTC, Ivan Klymenko
no flags Details
shar file port net-im/uTox (4.23 KB, text/plain)
2014-08-28 11:15 UTC, Ivan Klymenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ivan Klymenko 2014-08-23 23:03:16 UTC
*** Bug 192955 has been marked as a duplicate of this bug. ***
Comment 2 John Marino freebsd_committer 2014-08-24 08:34:46 UTC
Thanks!  Do you have any verification available?  In order of preference, examples of what I'm looking for are:

1) "poudriere testport" or "poudriere bulk -t" logs
2) Redports or tinderbox logs
3) "make check-plist" followed by "make stage-qa" output  (https://www.freebsd.org/doc/en/books/porters-handbook/porting-testing.html)

Also, please run "portlint" and paste the output.



^^^  that is a form letter, the following is tailored


Please follow the directions here: https://www.freebsd.org/doc/en/books/porters-handbook/porting-submitting.html

We expect a shar file to be attached.  A link to redports repo isn't good enough, thanks in advance for providing one and a link to redports logs (but attaching poudriere logs is *much* preferred)
Comment 3 Ivan Klymenko 2014-08-24 08:59:46 UTC
Created attachment 146202 [details]
shar file port net-im/uTox
Comment 4 Ivan Klymenko 2014-08-24 09:06:45 UTC
make check-plist
===>  License GPLv3 accepted by the user
===>   uTox-0.1.3 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by uTox-0.1.3 for building
===>  Extracting for uTox-0.1.3
=> SHA256 Checksum OK for uTox-0.1.3.tar.gz.
===>  Patching for uTox-0.1.3
===>  Applying FreeBSD patches for uTox-0.1.3
===>   uTox-0.1.3 depends on file: /usr/local/lib/libtoxcore.a - found
===>   uTox-0.1.3 depends on file: /usr/local/include/linux/videodev2.h - found
===>   uTox-0.1.3 depends on executable: gmake - found
===>   uTox-0.1.3 depends on executable: pkgconf - found
===>   uTox-0.1.3 depends on file: /usr/local/bin/ccache - found
===>   uTox-0.1.3 depends on shared library: libdbus-1.so - found (/usr/local/lib/libdbus-1.so.3.8.6)
===>   uTox-0.1.3 depends on shared library: libXft.so - found (/usr/local/lib/libXft.so.2.3.1)
===>  Configuring for uTox-0.1.3
===>  Building for uTox-0.1.3
gmake[1]: Вход в каталог `/media/da0s1/obj/usr/ports/net-im/uTox/work/notsecure-uTox-c943d2e'
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o contextmenu.o -c contextmenu.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o tox.o -c tox.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o messages.o -c messages.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o button.o -c button.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o main.o -c main.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o edit.o -c edit.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o util.o -c util.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o dns.o -c dns.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o text.o -c text.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o list.o -c list.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o ui.o -c ui.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o dropdown.o -c dropdown.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o scrollable.o -c scrollable.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o svg.o -c svg.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o friend.o -c friend.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o png/png.o -c png/png.c
cc -O2 -pipe -Ofast -march=native  -fstack-protector -fno-strict-aliasing -I/usr/local/include/freetype2 -I/usr/local/include/libpng15 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/AL   -I/usr/local/include/dbus-1.0 -I/usr/local/include/dbus-1.0/include   -g -pthread -std=gnu99 -o utox contextmenu.o tox.o messages.o button.o main.o edit.o util.o dns.o text.o list.o ui.o dropdown.o scrollable.o svg.o friend.o png/png.o  -fstack-protector -lfreetype -lX11 -L/usr/local/lib -lopenal   -L/usr/local/lib -ldbus-1   -lX11 -lXft -lXrender -ltoxcore -ltoxav -ltoxdns -lopenal -pthread -lm -lfontconfig -lv4lconvert -lvpx -lXext
gmake[1]: Выход из каталога `/media/da0s1/obj/usr/ports/net-im/uTox/work/notsecure-uTox-c943d2e'
===>  Staging for uTox-0.1.3
===>   Generating temporary packing list
gmake[1]: Вход в каталог `/media/da0s1/obj/usr/ports/net-im/uTox/work/notsecure-uTox-c943d2e'
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/bin
install -m 0755 utox /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/bin/utox
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/14x14/apps
install -m 644 icons/utox-14x14.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/14x14/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/16x16/apps
install -m 644 icons/utox-16x16.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/16x16/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/22x22/apps
install -m 644 icons/utox-22x22.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/22x22/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/24x24/apps
install -m 644 icons/utox-24x24.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/24x24/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/32x32/apps
install -m 644 icons/utox-32x32.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/32x32/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/36x36/apps
install -m 644 icons/utox-36x36.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/36x36/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/48x48/apps
install -m 644 icons/utox-48x48.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/48x48/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/64x64/apps
install -m 644 icons/utox-64x64.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/64x64/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/72x72/apps
install -m 644 icons/utox-72x72.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/72x72/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/96x96/apps
install -m 644 icons/utox-96x96.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/96x96/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/128x128/apps
install -m 644 icons/utox-128x128.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/128x128/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/192x192/apps
install -m 644 icons/utox-192x192.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/192x192/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/256x256/apps
install -m 644 icons/utox-256x256.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/256x256/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/512x512/apps
install -m 644 icons/utox-512x512.png /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/512x512/apps/utox.png
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/scalable/apps
install -m 644 icons/utox.svg /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/icons/hicolor/scalable/apps/utox.svg
mkdir -p /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/applications
install -m 644 utox.desktop /media/da0s1/obj/usr/ports/net-im/uTox/work/stage/usr/local/share/applications/utox.desktop
gmake[1]: Выход из каталога `/media/da0s1/obj/usr/ports/net-im/uTox/work/notsecure-uTox-c943d2e'
====> Compressing man pages (compress-man)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for directories owned by MTREEs
===> Checking for directories handled by dependencies
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
Comment 5 John Marino freebsd_committer 2014-08-24 09:13:16 UTC
and just to be complete, how about "make stage-qa" ?  Is that clean?
Comment 6 Ivan Klymenko 2014-08-24 09:17:29 UTC
Created attachment 146204 [details]
shar file port net-im/uTox 'USES=desktop-file-utils' fix
Comment 7 Ivan Klymenko 2014-08-24 09:19:07 UTC
make stage-qa
====> Running Q/A tests (stage-qa)
Warning: 'bin/utox' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Comment 8 John Marino freebsd_committer 2014-08-24 09:25:16 UTC
oh my, I just took a look at the shar itsef.  (by the way, please set mime to text/plain on the next shar)

1) you don't need to set owner/group to root in the pkg-plist as the first lines, that is the default

2) The reason why you get that error is because your provided Makefile is hardcoded.  Do not use "install -m etc".  Use ${INSTALL_PROGRAM}, ${INSTALL_SCRIPT}, ${INSTALL_DATA}, ${INSTALL_MAN} etc.

try "make -V MAKE_ENV" to see all the macros your makefile can use.  Change the makefile to use those commands please.  A side effect is that your executable will be properly stripped when it needs to be.  The permissions and ownership will also be correct.
Comment 9 Ivan Klymenko 2014-08-24 10:10:54 UTC
(In reply to John Marino from comment #8)
> oh my, I just took a look at the shar itsef.  (by the way, please set mime
> to text/plain on the next shar)
> 
> 1) you don't need to set owner/group to root in the pkg-plist as the first
> lines, that is the default
> 
> 2) The reason why you get that error is because your provided Makefile is
> hardcoded.  Do not use "install -m etc".  Use ${INSTALL_PROGRAM},
> ${INSTALL_SCRIPT}, ${INSTALL_DATA}, ${INSTALL_MAN} etc.
> 
> try "make -V MAKE_ENV" to see all the macros your makefile can use.  Change
> the makefile to use those commands please.  A side effect is that your
> executable will be properly stripped when it needs to be.  The permissions
> and ownership will also be correct.

you know for sure that I just have to add the ${INSTALL_XXX} in Makefile as was done previously?
like this:
https://redports.org/changeset?reponame=&new=30972%40fidaj%2Fnet-im%2FuTox%2FMakefile&old=30864%40fidaj%2Fnet-im%2FuTox%2FMakefile
Comment 10 John Marino freebsd_committer 2014-08-24 10:17:59 UTC
Mostly, but 
      @${SETENV} ${MAKE_ENV} DESTDIR=${STAGEDIR} PREFIX=${PREFIX} \ 
 	33	        ${GMAKE} -C ${WRKSRC} ${INSTALL_TARGET} 
 	34	 
 	35	post-install: 
 	36	        ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/utox 

^^ that is not good

1) You don't need port-install anymore.  You fixed the stripping problem

2) DO NOT REINVENT THE WHEEL.  MAKE_ARGS is already set with DEST

in fact, why are you doing it his way at all?  move the do-install to post-install and use the default install target which should work.

3) Please don't have 30 mkdir commands.  You one mkdir command with 30 directory arguments separated by "\" (one directory per line)
Comment 11 Ivan Klymenko 2014-08-24 10:33:34 UTC
Created attachment 146205 [details]
shar file port net-im/uTox
Comment 12 Ivan Klymenko 2014-08-24 10:41:38 UTC
Created attachment 146206 [details]
shar file port net-im/uTox
Comment 13 John Marino freebsd_committer 2014-08-24 11:43:51 UTC
okay, we are getting close.

1) your pkg-descr is:
Lightweight Tox (https://github.com/irungentoo/ProjectTox-Core) client.

WWW: http://utox.org/


That is way too light.  You can't beef that out for people that don't know what the port is, what Tox is, or why they'd want to use it?  You need a much better description


2) What is the point of the files/patch-Makefile?  If you are overriding the install target, why are you bother to patch something that's not used anyway?
Comment 14 Ivan Klymenko 2014-08-24 12:05:52 UTC
(In reply to John Marino from comment #13)
> okay, we are getting close.
> 
>...
> 
> 2) What is the point of the files/patch-Makefile?  If you are overriding the
> install target, why are you bother to patch something that's not used anyway?

this patch is more temporary, as the expected change in the upstream:
https://github.com/notsecure/uTox/pull/295
https://github.com/notsecure/uTox/pull/294
Comment 15 Ivan Klymenko 2014-08-24 12:10:11 UTC
(In reply to John Marino from comment #13)
> okay, we are getting close.
> 
> 1) your pkg-descr is:
> Lightweight Tox (https://github.com/irungentoo/ProjectTox-Core) client.
> 
> WWW: http://utox.org/
> 
> 
> That is way too light.  You can't beef that out for people that don't know
> what the port is, what Tox is, or why they'd want to use it?  You need a
> much better description
> 

unfortunately I have presented only the official information, to add something more - it will not be fit of objective reality
https://github.com/notsecure/uTox/blob/master/README.md
as soon as the developers will expand the description - I immediately update the information about it.
Comment 16 John Marino freebsd_committer 2014-08-24 12:10:43 UTC
I still don't get why the install target is being modified since it's not used.

Plus, as an example, "install -m 644"

That should be "${BSD_INSTALL_DATA}" not "install -m 644"

if you were going to patch it, patch it to use the standard BSD_INSTALL_* macros
Comment 17 John Marino freebsd_committer 2014-08-24 12:12:20 UTC
(In reply to Ivan Klymenko from comment #15)
> unfortunately I have presented only the official information, to add
> something more - it will not be fit of objective reality
> https://github.com/notsecure/uTox/blob/master/README.md
> as soon as the developers will expand the description - I immediately update
> the information about it.

Don't blame the developers.  You can provide your own description.

I don't know what tox is or why FreeBSD should support it.  And nobody that reads your description will know it either.

It doesn't have to be official, it needs to be descriptive.  I know you can do better than that.
Comment 18 Ivan Klymenko 2014-08-24 19:50:28 UTC
(In reply to John Marino from comment #17)

> Don't blame the developers.  You can provide your own description.

I'm not going to do it ... :)
Comment 19 Ivan Klymenko 2014-08-24 19:50:56 UTC
Created attachment 146225 [details]
shar file port net-im/uTox
Comment 20 Ivan Klymenko 2014-08-27 20:27:59 UTC
Created attachment 146400 [details]
shar file port net-im/uTox
Comment 21 Ivan Klymenko 2014-08-27 20:30:32 UTC
Created attachment 146404 [details]
shar file port net-im/uTox
Comment 22 John Marino freebsd_committer 2014-08-27 20:33:20 UTC
okay, looks decent.  Let's get up in the patch-ready queue.
Comment 23 Dmitry Marakasov freebsd_committer 2014-08-27 21:45:44 UTC
My changes for upstream Makefile which made install target usable on FreeBSD were accepted (https://github.com/notsecure/uTox/commit/c2317a5afe59a25d875c97a1473ddf78980afca4), so do-install: may finally be dropped. Also @cwd is the plist is not needed. Apart from that, it's ready to be committed.
Comment 24 Dmitry Marakasov freebsd_committer 2014-08-27 22:16:27 UTC
Also fails on 8.x:

messages.c:314:21: error: invalid suffix "b011" on integer constant
messages.c:315:21: error: invalid suffix "b001" on integer constant
messages.c:317:21: error: invalid suffix "b011" on integer constant
messages.c:318:21: error: invalid suffix "b011" on integer constant
messages.c:320:21: error: invalid suffix "b011" on integer constant
messages.c:321:21: error: invalid suffix "b011" on integer constant
messages.c:323:21: error: invalid suffix "b001" on integer constant
messages.c:324:21: error: invalid suffix "b001" on integer constant
messages.c:326:21: error: invalid suffix "b001" on integer constant
messages.c:327:21: error: invalid suffix "b001" on integer constant
messages.c:329:21: error: invalid suffix "b000" on integer constant
messages.c:330:21: error: invalid suffix "b000" on integer constant
messages.c:332:21: error: invalid suffix "b111" on integer constant
messages.c:333:21: error: invalid suffix "b111" on integer constant

May be fixed by adding compiler:c++11-lang to USES.
Comment 25 Dmitry Marakasov freebsd_committer 2014-08-28 00:40:19 UTC
Yes, and I suggest to change PORTVERSION to e.g. 0.1.3.git20140828.

As there are no tagged official releases, it's very likely that the port will be updated multiple times while official version stays 0.1.3. Each update must have unique distfile name (or users will run into fetch and checksum errors), so POERVERSION should contain date. The nice feature of this scheme is that

0.1.2 < 0.1.3.git20140828 < 0.1.3

so if official version is finally tagged, you may update snapshot version to it without PORTEPOCH bump.
Comment 26 Ivan Klymenko 2014-08-28 11:15:02 UTC
Created attachment 146440 [details]
shar file port net-im/uTox
Comment 27 commit-hook freebsd_committer 2014-08-28 12:19:32 UTC
A commit references this bug:

Author: amdmi3
Date: Thu Aug 28 12:19:14 UTC 2014
New revision: 366399
URL: http://svnweb.freebsd.org/changeset/ports/366399

Log:
  uTox is lightweight Tox (https://github.com/irungentoo/ProjectTox-Core)
  client written in C.

  Simple and convenient program for confidential communication.

  Still early in development, though it already supports some of the most
  important features, like file transfers, A/V, group chats, and DNS Discovery.

  There are also binaries for other OS: Linux, Android, OS X and Windows, which
  makes it possible to communicate between users of different OS.

  WWW: http://utox.org/

  PR:		192954
  Submitted by:	fidaj@ukr.net

Changes:
  head/net-im/Makefile
  head/net-im/uTox/
  head/net-im/uTox/Makefile
  head/net-im/uTox/distinfo
  head/net-im/uTox/pkg-descr
  head/net-im/uTox/pkg-plist
Comment 28 Ivan Klymenko 2014-08-28 12:27:31 UTC
Thanks to all.