Bug 193057 - dns/unbound module not correct module version for Python support.
Summary: dns/unbound module not correct module version for Python support.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
: 193080 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-27 06:14 UTC by jaretbartsch
Modified: 2014-08-28 10:07 UTC (History)
3 users (show)

See Also:


Attachments
Fix build/package with PYTHON option enabled (1004 bytes, patch)
2014-08-27 06:16 UTC, Kubilay Kocak
koobs: maintainer-approval? (sem)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jaretbartsch 2014-08-27 06:14:12 UTC
When compiling dns/unbound from FreeBSD ports there is a module version issue where the later module is not being installed. It attempts to install _unbound.so.4, but only leaves us with _unbound.so.3 which results in a failed port compile of dns/unbound.

The failed port build is the result of selecting Python support in the 'make config' options.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2014-08-27 06:16:13 UTC
Created attachment 146356 [details]
Fix build/package with PYTHON option enabled

Adding patch to fix pkg-plist with PYTHON option enabled.

Tested by reporter, confirmed fixed.
Comment 2 commit-hook freebsd_committer 2014-08-27 06:32:46 UTC
A commit references this bug:

Author: koobs
Date: Wed Aug 27 06:32:27 UTC 2014
New revision: 366293
URL: http://svnweb.freebsd.org/changeset/ports/366293

Log:
  dns/unbound: Fix packaging with PYTHON option enabled

  - Fix packaging with PYTHON option enabled

  While I'm here, pet portlint.

  PR:		193057
  Reported by:	Jaret Bartsch <jaretbartsch at yahoo dot ca>
  Reviewed by:	antoine
  Approved by:	portmgr (blanket: packaging)

Changes:
  head/dns/unbound/Makefile
  head/dns/unbound/pkg-plist
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2014-08-27 06:40:09 UTC
Thank you for your report Jaret!

Responsive Reporter, A++ Testing, Would commit again.
Comment 4 Jeroen 2014-08-28 10:07:05 UTC
*** Bug 193080 has been marked as a duplicate of this bug. ***