Bug 193073 - [PATCH]: devel/anjuta broken for version 2.32.1.1_13: autogen 5 not found
Summary: [PATCH]: devel/anjuta broken for version 2.32.1.1_13: autogen 5 not found
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2014-08-27 17:33 UTC by Jimmy Kelley
Modified: 2015-06-11 03:16 UTC (History)
2 users (show)

See Also:


Attachments
New patch file for the anjuta port (1.02 KB, text/x-csrc)
2014-08-27 17:33 UTC, Jimmy Kelley
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy Kelley 2014-08-27 17:33:46 UTC
Created attachment 146383 [details]
New patch file for the anjuta port

The port devel/anjuta seems to be broken.

When one tries to create a new project the following error occurs:
Could not find autogen version 5; please install the autogen package. You can get it from http://autogen.sourceforge.net.

The problem is that a runtime check of the autogen version on the system (using "autogen -v") is looking for a specific string that the autogen FreeBSD port does not generate.

Attached is a patch file for the devel/anjuta port that fixes the problem.
Comment 1 Tilman Keskinoz freebsd_committer 2014-08-29 10:52:39 UTC
over to maintainers
Comment 2 John Marino freebsd_committer 2014-09-20 18:00:44 UTC
This gnome@ port is under a maintainer time-out.  Moving to patch-ready; approval from gnome@ no longer required
Comment 3 Jimmy Kelley 2015-01-24 12:56:56 UTC
Going on 4 months for maintainer timeout...
Comment 4 commit-hook freebsd_committer 2015-06-11 03:12:37 UTC
A commit references this bug:

Author: kwm
Date: Thu Jun 11 03:12:01 UTC 2015
New revision: 389156
URL: https://svnweb.freebsd.org/changeset/ports/389156

Log:
  Update anjuta to 3.14.1
  Update anjuta-extras to 3.10.0.

  This unbreak the build of these ports and fixed a run-time issues
  with autogen [1]

  PR:	185575 [1]
  PR:	193073 [1]
  Submitted by:	Ivan Klymenko, Jimmy Kelley
  Network sponsored by:	BSDCan and UoO

Changes:
  head/devel/anjuta/Makefile
  head/devel/anjuta/distinfo
  head/devel/anjuta/files/patch-Makefile.in
  head/devel/anjuta/files/patch-doc__Makefile.in
  head/devel/anjuta/files/patch-libanjuta_Makefile.in
  head/devel/anjuta/files/patch-libanjuta_anjuta-launcher.c
  head/devel/anjuta/files/patch-libanjuta_anjuta-utils.c
  head/devel/anjuta/files/patch-plugins_gdb_debugger.c
  head/devel/anjuta/files/patch-plugins_symbol-db_symbol-db-engine-core.c
  head/devel/anjuta/files/patch-plugins_symbol-db_symbol-db-prefs.h
  head/devel/anjuta/pkg-plist
  head/devel/anjuta-extras/Makefile
  head/devel/anjuta-extras/distinfo
  head/devel/anjuta-extras/files/patch-plugins__scintilla__scintilla__Makefile.in
  head/devel/anjuta-extras/files/patch-plugins_scintilla_scintilla_src_SplitVector.h
  head/devel/anjuta-extras/pkg-plist