Bug 193086 - devel/ode: update to version 0.13
Summary: devel/ode: update to version 0.13
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Dmitry Marakasov
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2014-08-28 01:24 UTC by Pedro F. Giffuni
Modified: 2014-11-24 23:53 UTC (History)
2 users (show)

See Also:


Attachments
devel/ode update patch (2.94 KB, patch)
2014-08-28 01:24 UTC, Pedro F. Giffuni
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro F. Giffuni freebsd_committer 2014-08-28 01:24:30 UTC
Created attachment 146428 [details]
devel/ode update patch

ODE version 0.11.1 was released in 2009-05-24 so the changes are significant.

Dropped the Gyroscopic option since that is not an option anymore: it's the default.
Simplified the build replacements.
Add a regression-test target, which is rather useful.
Comment 1 Tilman Keskinoz freebsd_committer 2014-08-29 10:58:23 UTC
over to maintainer
Comment 2 John Marino freebsd_committer 2014-09-20 18:01:41 UTC
PR is suffering a maintainer timeout.  Move to "patch-ready" as maintainer approval no longer required.
Comment 3 Dmitry Marakasov freebsd_committer 2014-11-24 13:17:00 UTC
As this timeouted, take. I'm currently testing existing ode consumers for compatibility with newer version.
Comment 4 Dmitry Marakasov freebsd_committer 2014-11-24 23:53:08 UTC
Committed, thanks!
Comment 5 commit-hook freebsd_committer 2014-11-24 23:53:23 UTC
A commit references this bug:

Author: amdmi3
Date: Mon Nov 24 23:53:03 UTC 2014
New revision: 373385
URL: https://svnweb.freebsd.org/changeset/ports/373385

Log:
  - Update devel/ode to 0.13
  - Bump dependent ports

  PR:		193086
  Submitted by:	pfg
  Approved by:	maintainer timeout (acm, almost 3 months)

Changes:
  head/devel/ode/Makefile
  head/devel/ode/distinfo
  head/devel/ode/pkg-plist
  head/devel/py-ode/Makefile
  head/games/gillo/Makefile
  head/games/stormbaancoureur/Makefile
  head/games/xmoto/Makefile
  head/graphics/py-soya3d/Makefile