Bug 193183 - [STAGE] net/beacon: Request MAINTAINERship, pkg-descr cleanup
Summary: [STAGE] net/beacon: Request MAINTAINERship, pkg-descr cleanup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: John Marino
URL:
Keywords: easy, needs-qa
Depends on:
Blocks:
 
Reported: 2014-08-30 22:48 UTC by Chris Hutchinson
Modified: 2014-09-08 23:44 UTC (History)
3 users (show)

See Also:


Attachments
net/beacon [maintainer] STAGE pkg-descr cleanup (1.61 KB, patch)
2014-08-30 22:48 UTC, Chris Hutchinson
no flags Details | Diff
net/beacon STAGE MAINTAINER attempt (1.72 KB, patch)
2014-09-05 00:50 UTC, Chris Hutchinson
no flags Details | Diff
net/beacon QA output for 2014-09-03.diff (also attached) (35.18 KB, text/plain)
2014-09-05 00:52 UTC, Chris Hutchinson
no flags Details
net/beacon [request maintainer] STAGE, svn diff (2.00 KB, patch)
2014-09-06 08:03 UTC, Chris Hutchinson
no flags Details | Diff
net/beacon [request maintainer] STAGE LICENSE (2.99 KB, patch)
2014-09-07 07:50 UTC, Chris Hutchinson
no flags Details | Diff
net/beacon Requisite QA for 2014-09-06.diff, also attached (34.58 KB, text/plain)
2014-09-07 07:52 UTC, Chris Hutchinson
no flags Details
net/beacon [request maintainer] STAGE LICENSE minus MANCOMPRESSED (3.25 KB, patch)
2014-09-08 14:17 UTC, Chris Hutchinson
no flags Details | Diff
[request maintainer] STAGE LICENSE no perllocal.pod(.gz) (3.34 KB, patch)
2014-09-08 19:56 UTC, Chris Hutchinson
no flags Details | Diff
net/beacon [request maintainer] STAGE LICENSE nuke perllocal* (3.29 KB, patch)
2014-09-08 20:39 UTC, Chris Hutchinson
no flags Details | Diff
net/beacon FIX hardcoded perl version from last diff (3.31 KB, patch)
2014-09-08 23:44 UTC, Chris Hutchinson
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2014-08-30 22:48:00 UTC
Created attachment 146577 [details]
net/beacon [maintainer] STAGE pkg-descr cleanup

net/beacon

adds MAINTAINER, STAGEDIR
modifies pkg-descr (minor cleanup)

trivial; see svn(1) diff(1), for details.

--Chris
Comment 1 John Marino freebsd_committer 2014-08-30 23:02:39 UTC
I'm not even going to look at this without: 

make check-plist
make stage-qa
make portlint
Comment 2 John Marino freebsd_committer 2014-08-30 23:02:56 UTC
actually it is just "portlint"
Comment 3 John Marino freebsd_committer 2014-08-31 06:39:39 UTC
This PR has no obvious issues like the ones I rejected, but I still insist on proof of testing to move this out of triage.
Comment 4 Chris Hutchinson 2014-09-05 00:50:21 UTC
Created attachment 146838 [details]
net/beacon STAGE MAINTAINER attempt

net/beacon

requests MAINTAINER
adds STAGEDIR

As [rightfully] requested. Here is the QA output, as well as my
attempt to overcome the issues. I have it down to one file (see below).

NOTE This still needs work.
Please find 2014-09-03.diff, attached. As well as net-beacon-QA-output,
also attached.

I've spent quite some time on the issue with dealing with
the .packlist file. I have everything else in place, to get this port
workin, as intended. But would appreciate advice on dealing with that
file.

Thank you for all your time, and considerarion.

--Chris
Comment 5 Chris Hutchinson 2014-09-05 00:52:20 UTC
Created attachment 146839 [details]
net/beacon QA output for 2014-09-03.diff (also attached)

net/beacon

net-beacon-QA-output

This is the QA output for the 2014-09-03.diff, also attached.

Thank you for all your time, and consideration.

--Chris
Comment 6 John Marino freebsd_committer 2014-09-05 06:04:49 UTC
ask on the freebsd-python@ mailing list.  I don't know why .packlist is needed, I'd probably be tempted to remove it.
Comment 7 Chris Hutchinson 2014-09-05 07:17:43 UTC
(In reply to John Marino from comment #6)
> ask on the freebsd-python@ mailing list.  I don't know why .packlist is
> needed, I'd probably be tempted to remove it.

Thank you, very much, John. This is actually a Perl packaging issue.
I'm on the perl@ list, and I remember some discussion on there being
an issue with them, when sunpoet changed the versioning scheme for
FreeBSD's Perl (BSDpan). It was at 5.15, I believe. I'll search
the list for the solution. Failing that, I'll send an email to
sunpoet.

Thanks, again, John.

--Chris
Comment 8 Marcus von Appen freebsd_committer freebsd_triage 2014-09-05 21:39:38 UTC
You may give the packlist flag (see /usr/ports/Uses/perl5.mk for details) a try. Maybe it gets the .packlist out of the way properly for your update.
Comment 9 Chris Hutchinson 2014-09-06 00:01:22 UTC
(In reply to Marcus von Appen from comment #8)
> You may give the packlist flag (see /usr/ports/Uses/perl5.mk for details) a
> try. Maybe it gets the .packlist out of the way properly for your update.

Hello, Marcus, and thanks for the response!

I went to the perl@ list, last night, where I remembered there being an
issue with .packlist some time ago. I quickly found that the following:

USE_PERL5+=	fixpacklist

solves it. :)

Thank you, again, Marcus. For your thoughtful reply.

--Chris
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-06 03:24:35 UTC
If you could update your patch with the packlist patch, that would great.

Additional minor nit, while you're there:

 * Strip trailing slash from pkg-descr WWW: URL
Comment 11 Chris Hutchinson 2014-09-06 03:32:43 UTC
(In reply to Kubilay Kocak from comment #10)
> If you could update your patch with the packlist patch, that would great.
> 
> Additional minor nit, while you're there:
> 
>  * Strip trailing slash from pkg-descr WWW: URL

Sure. Will do. But won't be till tomorrow. I had a couple
other additions I hadn't finished.

--Chris
Comment 12 Chris Hutchinson 2014-09-06 03:36:08 UTC
(In reply to C Hutchinson from comment #11)
> (In reply to Kubilay Kocak from comment #10)
> > If you could update your patch with the packlist patch, that would great.
> > 
> > Additional minor nit, while you're there:
> > 
> >  * Strip trailing slash from pkg-descr WWW: URL
> 
> Sure. Will do. But won't be till tomorrow. I had a couple
> other additions I hadn't finished.
> 
> --Chris

I have a nit, myself. How do I prevent the Perl pod files
from being compressed?

--Chris
Comment 13 Chris Hutchinson 2014-09-06 08:03:04 UTC
Created attachment 146900 [details]
net/beacon [request maintainer] STAGE, svn diff

net/beacon

adds STAGE
fixes .packlist, missing rc.d entry
removes trailing slash in WWW entry
requests MAINTAINER

Please see 2014-09-05.diff, attached.

--Chris
Comment 14 Kubilay Kocak freebsd_committer freebsd_triage 2014-09-06 08:35:47 UTC
 * I believe MANCOMPRESSED only applies when using INSTALL_MAN
 * I don't believe MANCOMPRESSED needs and can used within a target
 * It also defaults to no (according to Mk/bsd.port.mk)

But more important, MANCOMPRESSED doesn't do anything anymore. You can remove it.

Updating patches without updating QA results only wastes your time
Updating patches that dont resolve issues only wasted your time

Moving forward:

1) Please resolve any outstanding issues (based on your testing) first
2) Update the patch according to new changes, if applicable
3) Update your QA results output once (2) is complete
4) Let us know its ready

Thank you for sticking it out, staying positive and learning!
Comment 15 Chris Hutchinson 2014-09-06 20:15:24 UTC
(In reply to Kubilay Kocak from comment #14)
>  * I believe MANCOMPRESSED only applies when using INSTALL_MAN
>  * I don't believe MANCOMPRESSED needs and can used within a target
>  * It also defaults to no (according to Mk/bsd.port.mk)
> 
> But more important, MANCOMPRESSED doesn't do anything anymore. You can
> remove it.
> 
> Updating patches without updating QA results only wastes your time
> Updating patches that dont resolve issues only wasted your time
> 
> Moving forward:
> 
> 1) Please resolve any outstanding issues (based on your testing) first
> 2) Update the patch according to new changes, if applicable
> 3) Update your QA results output once (2) is complete
> 4) Let us know its ready
> 
> Thank you for sticking it out, staying positive and learning!

Thank you, very much, Kubilay. For your taking the time to review
my submission(s).

Far be it, for _me_ to come off as any sort of expert on all this.
But I spent quite some time researching, and testing against
MANCOMPRESSED. I found without my additional entry

compress-man:
MANCOMPRESSED=    no

the plist line
perllocal.pod

became orphaned, and the addition of perllocal.pod.gz, also
became a problem. I found that adding the compress-man:
resolved this, and I no longer received complaints from
make(1) check-plist.

I'll be out all day (celebrating my birthday), so won't have
access to my "dev box", till later tonight, or tomorrow AM.
I'll post the QA output then.

Thanks, again, Kubilay.

--Chris
Comment 16 Chris Hutchinson 2014-09-07 07:50:42 UTC
Created attachment 146979 [details]
net/beacon [request maintainer] STAGE LICENSE

net/beacon

adds MAINTAINER, STAGEDIR, LICENSE, LICENSE_FILE

Please see 2014-09-06.diff, attached, for details.
See also net-beacon-output, for requisite QA log.

Thank you, for all your time, and consideration.

--Chris
Comment 17 Chris Hutchinson 2014-09-07 07:52:43 UTC
Created attachment 146980 [details]
net/beacon Requisite QA for 2014-09-06.diff, also attached

net/beacon

Requisite QA log, for 2014-09-06.diff, also attached.

--Chris
Comment 18 John Marino freebsd_committer 2014-09-08 13:09:45 UTC
(In reply to C Hutchinson from comment #15)
> (In reply to Kubilay Kocak from comment #14)
> >  * I believe MANCOMPRESSED only applies when using INSTALL_MAN
> >  * I don't believe MANCOMPRESSED needs and can used within a target
> >  * It also defaults to no (according to Mk/bsd.port.mk)
> > 
> > But more important, MANCOMPRESSED doesn't do anything anymore. You can
> > remove it.

> Far be it, for _me_ to come off as any sort of expert on all this.
> But I spent quite some time researching, and testing against
> MANCOMPRESSED. I found without my additional entry
> 
> compress-man:
> MANCOMPRESSED=    no
> 
> the plist line
> perllocal.pod
> 
> became orphaned, and the addition of perllocal.pod.gz, also
> became a problem. I found that adding the compress-man:
> resolved this, and I no longer received complaints from
> make(1) check-plist.


Kubilay is correct.  Regardless of what check-plist is says (and we already know that it gives misleading information and some things that successfully shut it up are wrong), MANCOMPRESSED should not be used.

What about just removing perllocal.pod from the pkg-plist?  why do we need it?
Comment 19 Chris Hutchinson 2014-09-08 13:44:14 UTC
(In reply to John Marino from comment #18)
> (In reply to C Hutchinson from comment #15)
> > (In reply to Kubilay Kocak from comment #14)
> > >  * I believe MANCOMPRESSED only applies when using INSTALL_MAN
> > >  * I don't believe MANCOMPRESSED needs and can used within a target
> > >  * It also defaults to no (according to Mk/bsd.port.mk)
> > > 
> > > But more important, MANCOMPRESSED doesn't do anything anymore. You can
> > > remove it.
> 
> > Far be it, for _me_ to come off as any sort of expert on all this.
> > But I spent quite some time researching, and testing against
> > MANCOMPRESSED. I found without my additional entry
> > 
> > compress-man:
> > MANCOMPRESSED=    no
> > 
> > the plist line
> > perllocal.pod
> > 
> > became orphaned, and the addition of perllocal.pod.gz, also
> > became a problem. I found that adding the compress-man:
> > resolved this, and I no longer received complaints from
> > make(1) check-plist.
> 
> 
> Kubilay is correct.  Regardless of what check-plist is says (and we already
> know that it gives misleading information and some things that successfully
> shut it up are wrong), MANCOMPRESSED should not be used.
> 
> What about just removing perllocal.pod from the pkg-plist?  why do we need
> it?

Thanks for your input John.
I'll re-visit this, and update diff, as needed/required. In just a few
minutes.

--Chris
Comment 20 Chris Hutchinson 2014-09-08 14:05:23 UTC
(In reply to John Marino from comment #18)
> (In reply to C Hutchinson from comment #15)
> > (In reply to Kubilay Kocak from comment #14)
> > >  * I believe MANCOMPRESSED only applies when using INSTALL_MAN
> > >  * I don't believe MANCOMPRESSED needs and can used within a target
> > >  * It also defaults to no (according to Mk/bsd.port.mk)
> > > 
> > > But more important, MANCOMPRESSED doesn't do anything anymore. You can
> > > remove it.
> 
> > Far be it, for _me_ to come off as any sort of expert on all this.
> > But I spent quite some time researching, and testing against
> > MANCOMPRESSED. I found without my additional entry
> > 
> > compress-man:
> > MANCOMPRESSED=    no
> > 
> > the plist line
> > perllocal.pod
> > 
> > became orphaned, and the addition of perllocal.pod.gz, also
> > became a problem. I found that adding the compress-man:
> > resolved this, and I no longer received complaints from
> > make(1) check-plist.
> 
> 
> Kubilay is correct.  Regardless of what check-plist is says (and we already
> know that it gives misleading information and some things that successfully
> shut it up are wrong), MANCOMPRESSED should not be used.
> 
> What about just removing perllocal.pod from the pkg-plist?  why do we need
> it?

OK. Just revisited...

check-plist returns the following, if perllocal.pod is removed from
pkg-plist:

Error: Orphaned: lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod

Which was my point for

compress-man:
MANCOMPRESSED=    no

meaning
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod

is created

without
compress-man:
MANCOMPRESSED=    no

I naturally get
lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod.gz

While I have no illusions about my being the new kid on the block.
I can't help but ask; why is not squashing perllocal.pod a bad thing(tm)?

I'll post an additional diff, citing perllocal.pod.gz, and removing
perllocal.pod, and let you decide. But I would greatly appreciate
reason(s) why my addition of MANCOMPRESSED is a bad thing(tm). :)

Thanks, John.

--Chris
Comment 21 John Marino freebsd_committer 2014-09-08 14:14:39 UTC
(In reply to C Hutchinson from comment #20)
> I naturally get
> lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod.gz

so add that to the pkg-plist then, right?


> While I have no illusions about my being the new kid on the block.
> I can't help but ask; why is not squashing perllocal.pod a bad thing(tm)?

Because MANCOMPRESSED is undocumented, it's not supposed to do anything, and it could be removed tomorrow.  It is pre-stage code.  It was also for man pages, and nothing to do with perl/pod.

> 
> I'll post an additional diff, citing perllocal.pod.gz, and removing
> perllocal.pod, and let you decide. But I would greatly appreciate
> reason(s) why my addition of MANCOMPRESSED is a bad thing(tm). :)

I'll let you answer this one by showing me where in the porter's handbook it says to use MANCOMPRESSED or where in Mk/ is MANCOMPRESSED documented for staged ports.
Comment 22 Chris Hutchinson 2014-09-08 14:17:56 UTC
Created attachment 147064 [details]
net/beacon [request maintainer] STAGE LICENSE minus MANCOMPRESSED

net/beacon

This diff (2104-09-07.diff) only removes MANCOMPRESSED from Makefile,
and changes perllocal.pod ==> perllocal.pod.gz, in pkg-plist as per JM.

Both work identically. So use whichever you like best. :)

Thanks.

--Chris
Comment 23 John Marino freebsd_committer 2014-09-08 14:29:37 UTC
can you tell use what perllocal.pod.gz does and why we need it?
Or why it's bad that it's compressed instead of plain text?

Why do we care about this file?
Comment 24 Chris Hutchinson 2014-09-08 14:32:00 UTC
(In reply to John Marino from comment #21)
> (In reply to C Hutchinson from comment #20)
> > I naturally get
> > lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod.gz
> 
> so add that to the pkg-plist then, right?
...
> > I'll post an additional diff, citing perllocal.pod.gz, and removing
> > perllocal.pod, and let you decide. But I would greatly appreciate
> > reason(s) why my addition of MANCOMPRESSED is a bad thing(tm). :)
> 
> I'll let you answer this one by showing me where in the porter's handbook it
> says to use MANCOMPRESSED or where in Mk/ is MANCOMPRESSED documented for
> staged ports.

Not to be argumentative. Just sayin'...
I only learned about MANCOMPRESSED from the porters documentation, when
I ran up against this issue. However. I became frustrated, when it
didn't work as anticipated/documented. It wasn't until I discovered
that the documentation omitted compress-man: as a prerequisite. That
it worked as intended.
Again. Just sayin' if you, and Kubilay, say it may not work tomorrow.
So be it. I'll do without it, today. :)

Thanks for taking the time to explain it all, John.

--Chris
Comment 25 Chris Hutchinson 2014-09-08 14:34:51 UTC
(In reply to John Marino from comment #23)
> can you tell use what perllocal.pod.gz does and why we need it?
> Or why it's bad that it's compressed instead of plain text?
> 
> Why do we care about this file?

I (we) don't. But check-plist, and the port do. :)

--Chris
Comment 26 John Marino freebsd_committer 2014-09-08 14:38:59 UTC
(In reply to C Hutchinson from comment #25)
> (In reply to John Marino from comment #23)
> > can you tell use what perllocal.pod.gz does and why we need it?
> > Or why it's bad that it's compressed instead of plain text?
> > 
> > Why do we care about this file?
> 
> I (we) don't. But check-plist, and the port do. :)


This is a completely bogus answer.
If I don't want perllocal.pod.gz in the port, then I simply remove it in the post-install target.  I'm not forced to keep it.

As the maintainer, you should know exactly why this file is needed, or if it's needed.  If it's not, then just remove it and be done with it.


> I only learned about MANCOMPRESSED from the porters documentation, when
> I ran up against this issue. However. I became frustrated, when it
> didn't work as anticipated/documented. It wasn't until I discovered
> that the documentation omitted compress-man: as a prerequisite. That
> it worked as intended.

I have never ever seen "compress-man" before.  I've never used it.  The documentation omits it because you aren't supposed to use it is my guess.  If I haven't seen it before, where are you getting told to use it?
Comment 27 Chris Hutchinson 2014-09-08 15:49:21 UTC
(In reply to John Marino from comment #26)
> (In reply to C Hutchinson from comment #25)
> > (In reply to John Marino from comment #23)
> > > can you tell use what perllocal.pod.gz does and why we need it?
> > > Or why it's bad that it's compressed instead of plain text?
> > > 
> > > Why do we care about this file?
> > 
> > I (we) don't. But check-plist, and the port do. :)
> 
> 
> This is a completely bogus answer.
> If I don't want perllocal.pod.gz in the port, then I simply remove it in the
> post-install target.  I'm not forced to keep it.
> 
> As the maintainer, you should know exactly why this file is needed, or if
> it's needed.  If it's not, then just remove it and be done with it.

Sorry. Yes. Of course. It was intended tongue-in-cheek. I didn't know
you really cared.
It's a perlbrew||cpanminus -ism. I cobbled a Perl script to clean up this
very thing. But since it's empty (of documentation), it's harmless. So
I didn't think it worth bothering with. If it bothers you. I can deal
with the Module' extra entry, and bump it's version, to reflect that.
But IMHO, in the here-and-now. It doesn't really seem necessary.
Personally, I'm glad that this showed up. As I gained some useful
information, where man(1) && perldoc(1) pages are concerned, when
dealing with ports.

> 
> 
> > I only learned about MANCOMPRESSED from the porters documentation, when
> > I ran up against this issue. However. I became frustrated, when it
> > didn't work as anticipated/documented. It wasn't until I discovered
> > that the documentation omitted compress-man: as a prerequisite. That
> > it worked as intended.
> 
> I have never ever seen "compress-man" before.  I've never used it.  The
> documentation omits it because you aren't supposed to use it is my guess. 
> If I haven't seen it before, where are you getting told to use it?

I found compress-man: in many (recent STAGE'd ports). A quick grep(1) of
the ports tree, will reveal what I'm saying.
But don't worry. I have no intention of using it in the future. :)

Thanks for taking the time to review, and critique my submissions, John.

--Chris
Comment 28 John Marino freebsd_committer 2014-09-08 16:08:23 UTC
I did some research.
compress-man target is essentially an internal target.  It can be overridden.  Your definition of MANCOMPRESSED here did nothing.

I think if you had:
compress-man:
YOUR_MAMA_IS=UGLY

it would have the same effect.  (Try it!)
It basically blocked the default "compress-man" target from executing.  
by the way, anything after a target has to be indented.  I'm not sure why make(1) didn't scream at you.


> It's a perlbrew||cpanminus -ism. I cobbled a Perl script to clean up this
> very thing. But since it's empty (of documentation), it's harmless. So
> I didn't think it worth bothering with. If it bothers you. I can deal
> with the Module' extra entry, and bump it's version, to reflect that.
> But IMHO, in the here-and-now. It doesn't really seem necessary.
> Personally, I'm glad that this showed up. As I gained some useful
> information, where man(1) && perldoc(1) pages are concerned, when
> dealing with ports.

I don't really follow.
If you don't install this file, does anything break or malfunction?
Comment 29 Chris Hutchinson 2014-09-08 16:37:01 UTC
(In reply to John Marino from comment #28)
> I did some research.
> compress-man target is essentially an internal target.  It can be
> overridden.  Your definition of MANCOMPRESSED here did nothing.
> 
> I think if you had:
> compress-man:
> YOUR_MAMA_IS=UGLY
> 
> it would have the same effect.  (Try it!)
> It basically blocked the default "compress-man" target from executing.  
> by the way, anything after a target has to be indented.  I'm not sure why
> make(1) didn't scream at you.
Ahh. So this (compress-man:) is an [unintended] _feature_. :)
Meaning; If I use
compress-man:
MANCOMPRESSED=	no

man(1) && perldoc(1) pages are left un-gzipped && copied to their
intended destination(s) -- really, I tried it. UNindented.
BUT if I omit that block, the man(1) && perldoc(1) pages, are packed
in their intended destination(s) -- really, I tried it. :)
In both cases, the files DO get installed. Either  gzipped | UNgzipped;
depending upon the whether MANCOMPRESSED is defined, or not.

I have no explanation for it all. I just only discovered it. It might
be interesting to take the time to find, and unwind the logic that even
[still] permits this. But my plate [as you've already discovered] is nearly
overflowing, as it is. :)

P.S. _love_ the YOUR_MAMA_IS=UGLY example. :) Good thing I'm not
sensitive, that way. ;)

> 
> 
> > It's a perlbrew||cpanminus -ism. I cobbled a Perl script to clean up this
> > very thing. But since it's empty (of documentation), it's harmless. So
> > I didn't think it worth bothering with. If it bothers you. I can deal
> > with the Module' extra entry, and bump it's version, to reflect that.
> > But IMHO, in the here-and-now. It doesn't really seem necessary.
> > Personally, I'm glad that this showed up. As I gained some useful
> > information, where man(1) && perldoc(1) pages are concerned, when
> > dealing with ports.
> 
> I don't really follow.
> If you don't install this file, does anything break or malfunction?

No. No issue, at all. It's [supposed] to only be appended to, as|if needed.
Go ahead, and issue a perldoc perllocal. You may, or may not get something.
Depending if there's any contents|exists, in your [Perl] install(s).


Thanks, John.

--Chris
Comment 30 John Marino freebsd_committer 2014-09-08 16:47:30 UTC
(In reply to C Hutchinson from comment #29)
> man(1) && perldoc(1) pages are left un-gzipped && copied to their
> intended destination(s) -- really, I tried it. UNindented.
> BUT if I omit that block, the man(1) && perldoc(1) pages, are packed
> in their intended destination(s) -- really, I tried it. :)

If you omit the block, then the default "compress-man" target runs, as you would expect.  If you define "compress-man:", it doesn't matter what comes after because it will skip the default target and run it instead.


> In both cases, the files DO get installed. Either  gzipped | UNgzipped;
> depending upon the whether MANCOMPRESSED is defined, or not.


That's no surprise.  It doesn't affect installation, only compression.



> I have no explanation for it all. I just only discovered it. It might
> be interesting to take the time to find, and unwind the logic that even
> [still] permits this. But my plate [as you've already discovered] is nearly
> overflowing, as it is. :)

The logic is in Mk/bsd.port.mk.
The point I was making is that the contents of your target (MANCOMPRESSED=yes) did nothing.  The affect was from the definition of the target (the "compress-man:" line)


> No. No issue, at all. It's [supposed] to only be appended to, as|if needed.
> Go ahead, and issue a perldoc perllocal. You may, or may not get something.
> Depending if there's any contents|exists, in your [Perl] install(s).

Modify this file is not permitted (it has to have same contents at deinstallation as it does at installation)
If it's designed to be modified, then just remove it from $STAGEDIR in a post-install target and remove it from pkg-plist.  It is not useful (according to you) so just don't install it at all.
Comment 31 Chris Hutchinson 2014-09-08 18:41:29 UTC
(In reply to John Marino from comment #30)
> (In reply to C Hutchinson from comment #29)
> > man(1) && perldoc(1) pages are left un-gzipped && copied to their
> > intended destination(s) -- really, I tried it. UNindented.
> > BUT if I omit that block, the man(1) && perldoc(1) pages, are packed
> > in their intended destination(s) -- really, I tried it. :)
> 
> If you omit the block, then the default "compress-man" target runs, as you
> would expect.  If you define "compress-man:", it doesn't matter what comes
> after because it will skip the default target and run it instead.
> 
> 
> > In both cases, the files DO get installed. Either  gzipped | UNgzipped;
> > depending upon the whether MANCOMPRESSED is defined, or not.
> 
> 
> That's no surprise.  It doesn't affect installation, only compression.
> 
> 
> 
> > I have no explanation for it all. I just only discovered it. It might
> > be interesting to take the time to find, and unwind the logic that even
> > [still] permits this. But my plate [as you've already discovered] is nearly
> > overflowing, as it is. :)
> 
> The logic is in Mk/bsd.port.mk.
> The point I was making is that the contents of your target
> (MANCOMPRESSED=yes) did nothing.  The affect was from the definition of the
> target (the "compress-man:" line)
> 
> 
> > No. No issue, at all. It's [supposed] to only be appended to, as|if needed.
> > Go ahead, and issue a perldoc perllocal. You may, or may not get something.
> > Depending if there's any contents|exists, in your [Perl] install(s).
> 
> Modify this file is not permitted (it has to have same contents at
> deinstallation as it does at installation)
> If it's designed to be modified, then just remove it from $STAGEDIR in a
> post-install target and remove it from pkg-plist.  It is not useful
> (according to you) so just don't install it at all.

The file is created as part of the standard MakeMaker process. In this case
it has no [real] value.
FWIW -- I'll provide the "official" explaination;
 The perllocal.pod contains a list of locally-installed modules not
included with the standard distribution.
 If you download and install Perl and then install several CPAN modules,
only the CPAN modules will be listed in perllocal.
 It's updated during the "make install" process, by code in
ExtUtils::MakeMaker.

That said. As I see it. I can attempt a kludge that removes the perllocal
pod(.gz), and hope Perl doesn't complain. Or I can create a new patch;
files/patch-Net-Multicast-Beacon-Makefile.perl
that nukes the following lines:

doc_perl_install :: all
    $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
    -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
    -$(NOECHO) $(DOC_INSTALL) \
        "Module" "$(NAME)" \
        "installed into" "$(INSTALLPRIVLIB)" \
        LINKTYPE "$(LINKTYPE)" \
        VERSION "$(VERSION)" \
        EXE_FILES "$(EXE_FILES)" \
        >> $(DESTINSTALLARCHLIB)/perllocal.pod

doc_site_install :: all
    $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
    -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
    -$(NOECHO) $(DOC_INSTALL) \
        "Module" "$(NAME)" \
        "installed into" "$(INSTALLSITELIB)" \
        LINKTYPE "$(LINKTYPE)" \
        VERSION "$(VERSION)" \
        EXE_FILES "$(EXE_FILES)" \
        >> $(DESTINSTALLARCHLIB)/perllocal.pod

doc_vendor_install :: all
    $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
    -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
    -$(NOECHO) $(DOC_INSTALL) \
    "Module" "$(NAME)" \
        "installed into" "$(INSTALLVENDORLIB)" \
        LINKTYPE "$(LINKTYPE)" \
        VERSION "$(VERSION)" \
        EXE_FILES "$(EXE_FILES)" \
        >> $(DESTINSTALLARCHLIB)/perllocal.pod

which are responsible for it's creation.

Thanks, John.

--Chris
Comment 32 John Marino freebsd_committer 2014-09-08 19:18:28 UTC
Just remove it in the post-install target (which already exists) and save yourself the patch.
Comment 33 Chris Hutchinson 2014-09-08 19:56:19 UTC
Created attachment 147080 [details]
[request maintainer] STAGE LICENSE no perllocal.pod(.gz)

net/beacon

OK all the requested changes are in.

no more MANCOMPRESSED, perllocal.pod(.gz)
No complaints from check-plist || portlint

See 2014-09-08.diff, attached, for details.

Thank you for all your time, and consideration.

--Chris
Comment 34 Chris Hutchinson 2014-09-08 19:57:18 UTC
(In reply to John Marino from comment #32)
> Just remove it in the post-install target (which already exists) and save
> yourself the patch.

Heh. Just like me, to over-complicate things.

Thanks, John. That did it. :)

--Chris
Comment 35 John Marino freebsd_committer 2014-09-08 20:05:36 UTC
I don't get your fix at all:

${FIND} ${STAGEDIR} -name 'perllocal.pod' -delete
${FIND} ${STAGEDIR} -name 'perllocal.pod.gz' -delete

I have a lot of questions.
1) it either ends in pod or pod.gz, why do you cover both bases?  obviously one command is never used
2) why are you using find?  How many files are there?

If the answer is "1", then use ${RM} ${STAGEDIR}${PREFIX} .... instead
Comment 36 Chris Hutchinson 2014-09-08 20:23:35 UTC
(In reply to John Marino from comment #35)
> I don't get your fix at all:
> 
> ${FIND} ${STAGEDIR} -name 'perllocal.pod' -delete
> ${FIND} ${STAGEDIR} -name 'perllocal.pod.gz' -delete
> 
> I have a lot of questions.
> 1) it either ends in pod or pod.gz, why do you cover both bases?  obviously
> one command is never used
> 2) why are you using find?  How many files are there?
> 
> If the answer is "1", then use ${RM} ${STAGEDIR}${PREFIX} .... instead

I _knew_ this question was coming. So why didn't I address it
beforehand?
OK. Indeed, a _pertinent_ question. I was puzzled, myself. Here's
how it went;

${FIND} ${STAGEDIR} -name 'perllocal.pod' -delete

check-plist complains that perllocal.pod.gz is orphaned.
Crap! That's right. I don't have that man-compressed: nonsense in
there, anymore.

${FIND} ${STAGEDIR} -name 'perllocal.pod.gz' -delete

check-plist complains about perllocal.pod being orphaned. Grr...

Fine! It looks silly. But let's see how it flies;

${FIND} ${STAGEDIR} -name 'perllocal.pod' -delete
${FIND} ${STAGEDIR} -name 'perllocal.pod.gz' -delete

No complaints from either check-plist, or portlint.
I'm growing weary of all this, by now. So begrudgingly, I submit it.

<sigh> I'll poke at it some more, and see if I can better determine
the issue. I _suspect_ it's because both files existed, at one time.
So pkg, or make preserved that information.

I'll get back with something more elegant. :)

--Chris

P.S. I got the ${FIND} script out of Mk/Uses/perl5.mk
It is used to clobber empty .bs files.
Comment 37 Chris Hutchinson 2014-09-08 20:39:19 UTC
Created attachment 147086 [details]
net/beacon [request maintainer] STAGE LICENSE nuke perllocal*

net/beacon

OK. As requested. Something a bit more presentable. :)

Same as last one, but cleaner, more elegant? ;)

Hope you like it.

See 2014-09-08.diff, for all the gory details.

Thanks!

--Chris
Comment 38 John Marino freebsd_committer 2014-09-08 23:14:50 UTC
it didn't work.
I'll fix it.  I've already tweaked this a lot.
Comment 39 John Marino freebsd_committer 2014-09-08 23:15:43 UTC
FYI, the error was not using ${PERL_VER} and ${PERL_ARCH}.  You used the hardcoded values which are specific to your system
Comment 40 Chris Hutchinson 2014-09-08 23:24:14 UTC
(In reply to John Marino from comment #39)
> FYI, the error was not using ${PERL_VER} and ${PERL_ARCH}.  You used the
> hardcoded values which are specific to your system

CRAP!
${RM} ${STAGEDIR}${PREFIX}/lib/perl5/5.14/mach/perllocal*

I _can't_ believe it. :(

5.14, ugh...

I told you I was getting weary. But no excuse.

%$@#%$#^%$
Comment 41 commit-hook freebsd_committer 2014-09-08 23:26:56 UTC
A commit references this bug:

Author: marino
Date: Mon Sep  8 23:26:10 UTC 2014
New revision: 367710
URL: http://svnweb.freebsd.org/changeset/ports/367710

Log:
  Stage net/beacon and assign maintainership to submitter

  PR:		193183
  Submitted by:	Chris Hutchinson
  Tweaked by:	marino

Changes:
  head/net/beacon/Makefile
  head/net/beacon/pkg-descr
  head/net/beacon/pkg-plist
Comment 42 John Marino freebsd_committer 2014-09-08 23:28:44 UTC
This didn't require many fixes but there were some, like @sample was missing.  I also used modern options framework.  You should review what I added (and rejected)
Comment 43 Chris Hutchinson 2014-09-08 23:44:11 UTC
Created attachment 147087 [details]
net/beacon FIX hardcoded perl version from last diff

net/beacon

I know -- too little, too late.
But in an effort to hopefully prove I actually know how to
do it correctly. I offer this diff (2104-09-08-FIXED.diff).

<sigh>
I have nothing to say.

--Chris