Bug 193429 - graphics/mypaint: ImportError: /usr/local/lib/mypaint/_mypaintlib.so: Undefined symbol "_ZN10BufferCompIL20BufferCompOutputType1ELj16384E12HueBlendModeE9blendfuncE"
Summary: graphics/mypaint: ImportError: /usr/local/lib/mypaint/_mypaintlib.so: Undefin...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
Depends on:
Blocks: 188382
  Show dependency treegraph
 
Reported: 2014-09-07 13:48 UTC by Jan Beich
Modified: 2015-01-28 13:42 UTC (History)
0 users

See Also:


Attachments
force gcc build (421 bytes, patch)
2014-09-07 13:48 UTC, Jan Beich
no flags Details | Diff
|poudriere testport -P| log (9.3R i386) (233.12 KB, text/plain)
2015-01-22 19:11 UTC, Jan Beich
no flags Details
|poudriere testport| log (9.3R i386) (232.45 KB, text/plain)
2015-01-22 20:08 UTC, Jan Beich
no flags Details
|poudriere testport -P| log for 8.4R amd64 (233.25 KB, text/plain)
2015-01-22 20:10 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-09-07 13:48:11 UTC
Created attachment 147009 [details]
force gcc build

On clang-enabled systems such as FreeBSD 10.0R fails to start with

$ HOME=/tmp mypaint

We are not correctly installed or compiled!
script: "/usr/local/bin/mypaint"
deduced prefix: "/usr/local"
lib_shared: "/usr/local/share/mypaint/"
lib_compiled: "/usr/local/lib/mypaint/"

Traceback (most recent call last):
  File "/usr/local/bin/mypaint", line 170, in <module>
    datapath, extradata, confpath, localepath, localepath_brushlib = get_paths()
  File "/usr/local/bin/mypaint", line 111, in get_paths
    from lib import mypaintlib
  File "/usr/local/share/mypaint/lib/mypaintlib.py", line 25, in <module>
    _mypaintlib = swig_import_helper()
  File "/usr/local/share/mypaint/lib/mypaintlib.py", line 17, in swig_import_helper
    import _mypaintlib
ImportError: /usr/local/lib/mypaint/_mypaintlib.so: Undefined symbol "_ZN10BufferCompIL20BufferCompOutputType1ELj16384E12HueBlendModeE9blendfuncE"

http://clang.debian.net/logs/2014-09-03/mypaint_1.1.0-3_unstable_clang.log
Comment 1 Dmitry Marakasov freebsd_committer 2014-09-11 14:12:10 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=193561
Comment 2 Dmitry Marakasov freebsd_committer 2014-09-11 14:13:01 UTC
Please disregard previous comment. Should'be been:

I've released maintainership of mypaint, release the PR as well.
Comment 3 John Marino freebsd_committer 2014-10-31 09:38:40 UTC
This should have been released to "open", not "triage".
Comment 4 Jan Beich freebsd_committer 2015-01-22 19:11:12 UTC
Created attachment 152023 [details]
|poudriere testport -P| log (9.3R i386)
Comment 5 Jan Beich freebsd_committer 2015-01-22 20:08:12 UTC
Created attachment 152026 [details]
|poudriere testport| log (9.3R i386)
Comment 6 Jan Beich freebsd_committer 2015-01-22 20:10:02 UTC
Created attachment 152027 [details]
|poudriere testport -P| log for 8.4R amd64
Comment 7 commit-hook freebsd_committer 2015-01-28 13:40:36 UTC
A commit references this bug:

Author: jbeich
Date: Wed Jan 28 13:39:42 UTC 2015
New revision: 378057
URL: https://svnweb.freebsd.org/changeset/ports/378057

Log:
  Build using lang/gcc* to avoid runtime issues with old -lgcc_s or Clang

  Absence of RPATH leads to mypaint loading old libgcc_s.so.1 from base
  first which later breaks |import numpy| as libgfortran wants newer version.
  On 10.0+ the issue is masked by Clang failing to instantiate some templates.

  PR:		188382
  PR:		193429
  Differential Revision:	https://reviews.freebsd.org/D1616
  Approved by:	bapt (mentor)

Changes:
  head/graphics/mypaint/Makefile