Bug 193504 - [NEW PORT] finance/quickfix: open source FIX protocol implementation
Summary: [NEW PORT] finance/quickfix: open source FIX protocol implementation
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-09 20:57 UTC by m.tsatsenko
Modified: 2018-02-25 19:34 UTC (History)
3 users (show)

See Also:


Attachments
shar (34.73 KB, text/plain)
2014-09-09 20:57 UTC, m.tsatsenko
no flags Details
fixed port (35.82 KB, text/plain)
2014-09-13 18:19 UTC, m.tsatsenko
no flags Details
latest port (35.82 KB, patch)
2014-11-05 20:57 UTC, m.tsatsenko
no flags Details | Diff
fixed port (35.54 KB, patch)
2014-11-18 09:26 UTC, m.tsatsenko
no flags Details | Diff
fixed port (35.94 KB, patch)
2015-07-14 21:45 UTC, m.tsatsenko
no flags Details | Diff
latest port (35.93 KB, text/plain)
2016-07-01 21:58 UTC, m.tsatsenko
no flags Details
the port (36.02 KB, application/x-shar)
2016-12-09 22:17 UTC, m.tsatsenko
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.tsatsenko 2014-09-09 20:57:26 UTC
Created attachment 147143 [details]
shar

QuickFix is open source FIX protocol implementation

WWW: http://www.quickfixengine.org/

Build logs: https://redports.org/buildarchive/20140907233806-22706/
Comment 1 m.tsatsenko 2014-09-12 23:59:31 UTC
Nevermind. 
I just discovered a several issues with the port. Working to fix them now
Comment 2 m.tsatsenko 2014-09-13 18:19:30 UTC
Created attachment 147277 [details]
fixed port

fixed python support
fixed -lcompat issue
fixed shared lib installation
Comment 3 John Marino freebsd_committer 2014-10-31 18:23:25 UTC
1) you are masking the post-install strip command with "@", so remove that character

2) do you have any poudriere logs proving this new port has been properly tested?  e.g. poudriere must perform stage-qa checks
Comment 4 m.tsatsenko 2014-11-05 20:57:25 UTC
Created attachment 149094 [details]
latest port

- Removed @ char before $STRIP_CMD
Comment 5 m.tsatsenko 2014-11-05 21:02:36 UTC
Currently I do not have build logs with stage-qa as redports.org does not support it. Although I can provide logs from my own build server in a next few days.
Comment 6 Pawel Pekala freebsd_committer 2014-11-08 17:08:46 UTC
1) Port build fails when Ruby option is on, please see log:

http://people.freebsd.org/~pawel/buildlogs/quickfix-1.14.0.log

2) USE_PYTHON is old, please convert to USES=python

3) Options block should be last, after build|lib|run depends then
USES, HAS_CONFIGURE, USE_* etc

Other than that port seems to build on all supported release nicely.
Comment 7 m.tsatsenko 2014-11-18 09:26:04 UTC
Created attachment 149552 [details]
fixed port

Thanks for feedback
Updated port attached.
Changes:
- Fixed ruby support
- reorder Makefile
- Cleanup plist

And the last: I do not have any usage of  USE_PYTHON.
Comment 8 Pawel Pekala freebsd_committer 2014-11-21 22:53:49 UTC
Ruby options fails with plist errors:

====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%DATADIR%%/quickfix40.rb
Error: Orphaned: %%DATADIR%%/quickfix41.rb
Error: Orphaned: %%DATADIR%%/quickfix42.rb
Error: Orphaned: %%DATADIR%%/quickfix43.rb
Error: Orphaned: %%DATADIR%%/quickfix44.rb
Error: Orphaned: %%DATADIR%%/quickfix50.rb
Error: Orphaned: %%DATADIR%%/quickfix50sp1.rb
Error: Orphaned: %%DATADIR%%/quickfix50sp2.rb
Error: Orphaned: %%DATADIR%%/quickfix_fields.rb
Error: Orphaned: %%DATADIR%%/quickfix_ruby.rb
Error: Orphaned: %%DATADIR%%/quickfixt11.rb
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1

This is strange files are already installed in RUBY_SITELIBDIR.
Comment 9 m.tsatsenko 2015-07-14 21:44:43 UTC
Sorry for very long response. I have missed your comment.
It seems that install target puts these files both under SITE_RUBY and DATADIR.
I Fixed plist to reflect that.
Comment 10 m.tsatsenko 2015-07-14 21:45:23 UTC
Created attachment 158773 [details]
fixed port
Comment 11 m.tsatsenko 2015-07-14 21:49:21 UTC
Build log: 
http://pkg.tsatsenko.ru/logs/bulk/101amd64-default/2015-07-15_01h42m31s/logs/quickfix-1.14.0.log

The port above has RUBY enabled by default for test builds. I am doubt we need it enabled by default in ports tree. I will submit final version without RUBY enabled by default.
Comment 12 Pawel Pekala freebsd_committer 2016-06-30 16:26:46 UTC
No promised final version timeout.
Comment 13 m.tsatsenko 2016-07-01 19:14:52 UTC
I am sorry. Somehow I have missed that PR.
And yes I am still interested in bringing the software to the ports tree. Right now I am running poudriere to ensure that the port doesnt have any build/install issues
Comment 14 m.tsatsenko 2016-07-01 21:58:26 UTC
Created attachment 172031 [details]
latest port

- Update to 1.14.3
- Modernize a bit
- Disable by default all of the options  except MYSQL

QA: 
poudriere 103amd64  - OK (with both all options enabled and disabled)
portlint - no errors
Comment 15 Pawel Pekala freebsd_committer 2016-07-02 14:05:27 UTC
.if ${PORT_OPTIONS:MRUBY}
	${STRIP_CMD} ${STAGEDIR}${RUBY_SITELIBDIR}/quickfix.so
.endif

This should be done in post-install target, right?

Build fails on 9:
http://people.freebsd.org/~pawel/buildlogs/quickfix-1.14.3-9amd64.log

There is problem in install phase when PYTHON=on:
http://people.freebsd.org/~pawel/buildlogs/quickfix-1.14.3-10amd64.log
Comment 16 m.tsatsenko 2016-07-24 13:44:49 UTC
Hello
Thanks for feedback.
I have fixed STRIP_CMD and build on 9.x issues. 
However I failed to reproduce python related problem. Will try again tomorrow.
Comment 17 m.tsatsenko 2016-12-09 22:17:15 UTC
Created attachment 177835 [details]
the port

- Fix build on 9.x
- Fix STRIP_CMD
- Fix python related issue
Comment 18 Walter Schwarzenfeld freebsd_triage 2018-01-12 10:56:40 UTC
Any advance here?
Comment 19 m.tsatsenko 2018-01-12 21:13:41 UTC
Hello.
I have corrected all of the known issues. No any action since then
Comment 20 Kurt Jaeger freebsd_committer 2018-01-13 17:27:17 UTC
testbuilds@work
Comment 21 Kurt Jaeger freebsd_committer 2018-01-13 17:46:11 UTC
fails to build on current (12amd64), see

http://people.freebsd.org/~pi/logs/finance__quickfix-cur-1515864999.txt

builds fine on 10.3-i386.

Testing on 11.1 pending other compile job.
Comment 22 Kurt Jaeger freebsd_committer 2018-01-13 17:48:01 UTC
btw, I added USES=iconv
Comment 23 Walter Schwarzenfeld freebsd_triage 2018-01-14 02:51:59 UTC
Builds also fine on 10.4 amd64.
Comment 24 m.tsatsenko 2018-01-23 15:13:19 UTC
Hello,
Thanks for running testbuilds. Regarding 12-CURRENT since I dont have access to a running CURRENT box at the moment I'd suggest to mark it broken on 12.x with an intention to address the issue later on. Most likely when it reaches BETA stage.
Thanks!
Comment 25 Kurt Jaeger freebsd_committer 2018-02-25 18:46:54 UTC
I think I found a build-fix.
Comment 26 commit-hook freebsd_committer 2018-02-25 19:34:12 UTC
A commit references this bug:

Author: pi
Date: Sun Feb 25 19:33:58 UTC 2018
New revision: 462973
URL: https://svnweb.freebsd.org/changeset/ports/462973

Log:
  New port: finance/quickfix

  The Financial Information Exchange (FIX) Protocol is a message
  standard developed to facilitate the electronic exchange of information
  related to securities transactions. It is intended for use between
  trading partners wishing to automate communications.

  QuickFIX is a free and open source implementation of the FIX protocol.

  WWW: http://www.fixprotocol.org/
  WWW: http://www.quickfixengine.org/

  PR:		193504
  Submitted by:	Mikhail Tsatsenko <m.tsatsenko@gmail.com>
  Reviewed by:	marino, pawel, w.schwarzenfeld@utanet.at

Changes:
  head/finance/Makefile
  head/finance/quickfix/
  head/finance/quickfix/Makefile
  head/finance/quickfix/distinfo
  head/finance/quickfix/files/
  head/finance/quickfix/files/patch-configure
  head/finance/quickfix/files/patch-src-python-Makefile.in
  head/finance/quickfix/files/patch-src-ruby-Makefile.in
  head/finance/quickfix/pkg-descr
  head/finance/quickfix/pkg-plist
Comment 27 Kurt Jaeger freebsd_committer 2018-02-25 19:34:23 UTC
Committed, thanks for your patience!