Bug 193521 - security/courier-authlib-base: courier-imap cannot find libcourierauth.so
Summary: security/courier-authlib-base: courier-imap cannot find libcourierauth.so
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-10 13:26 UTC by Nick Hilliard
Modified: 2014-09-11 13:49 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Hilliard 2014-09-10 13:26:12 UTC
the sep 7 update to courier-authlib has caused a shared library search failure:

Sep 10 14:08:20 blah imapd-ssl: Shared object "libcourierauth.so" not found, required by "imaplogin"

It should be possible to fix this by adding the following into the Makefile for courier-authlib-base:

--
USE_LDCONFIG=   ${PREFIX}/lib/courier-authlib
--
Comment 1 commit-hook freebsd_committer 2014-09-11 13:48:43 UTC
A commit references this bug:

Author: madpilot
Date: Thu Sep 11 13:48:30 UTC 2014
New revision: 367933
URL: http://svnweb.freebsd.org/changeset/ports/367933

Log:
  Add back USE_LDCONFIG for coourier-authlib-base only.

  This ports installs libraries needed by other fostware in it's own
  directory, so USE_LDCONFIG is needed heere or libraries will not
  be found.

  PR:		193521
  Submitted by:	nick@foobar.org
  Approved by:	portmgr (just fix it blanket)

Changes:
  head/security/courier-authlib-base/Makefile
Comment 2 Guido Falsi freebsd_committer 2014-09-11 13:49:11 UTC
Thanks for the report, fix committed in r367933.