Bug 193603 - www/w3m port build fails (latest head)
Summary: www/w3m port build fails (latest head)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: MANTANI Nobutaka
URL:
Keywords:
: 193602 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-13 12:25 UTC by Elimar Riesebieter
Modified: 2014-10-10 09:30 UTC (History)
1 user (show)

See Also:
riesebie: maintainer-feedback? (nobutaka)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elimar Riesebieter 2014-09-13 12:25:34 UTC
PORTNAME=w3m
PORTVERSION=0.5.3
PORTREVISION=4

/usr/bin/ld: : invalid DSO for symbol `XGetWindowAttributes' definition
/usr/local/lib/libX11.so.6: could not read symbols: Bad value
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** Error code 1

According to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=605761 I created a patch which fixed the build. Patch attached.

Elimar
Comment 1 Bugzilla Automation freebsd_committer 2014-09-13 12:25:34 UTC
Auto-assigned to maintainer nobutaka@FreeBSD.org
Comment 2 commit-hook freebsd_committer 2014-09-15 11:35:10 UTC
A commit references this bug:

Author: nobutaka
Date: Mon Sep 15 11:34:48 UTC 2014
New revision: 368261
URL: http://svnweb.freebsd.org/changeset/ports/368261

Log:
  Fix build error with INLINE_IMAGE option.

  PR:		ports/185045, ports/193603
  Submitted by:	cmt@burggraben.net, Radim Kolar <hsn@sendmail.cz>, Elimar Riesebieter <riesebie@lxtec.de>

Changes:
  head/www/w3m/Makefile
Comment 3 MANTANI Nobutaka freebsd_committer 2014-09-15 11:39:18 UTC
Fix committed.
Comment 4 John Marino freebsd_committer 2014-10-10 09:30:14 UTC
*** Bug 193602 has been marked as a duplicate of this bug. ***