Bug 193622 - regular kernel panic in the graphics subsystem (possible nvidia.ko issue), FreeBSD 10-BETA1
Summary: regular kernel panic in the graphics subsystem (possible nvidia.ko issue), Fr...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-STABLE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-13 22:47 UTC by olevole
Modified: 2015-07-07 15:08 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olevole 2014-09-13 22:47:52 UTC
FreeBSD 10.1-BETA1 #0 r271487M amd64

Quite often the system panics on activity in Xorg (eg opening new tab in firefox, close the window, etc)

This problem is absent in FreeBSD 10.0-RELEASE.

kgdb kernel.debug /var/crash/vmcore.0
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...

Unread portion of the kernel message buffer:
panic: vm_fault: fault on nofault entry, addr: fffffe00087b5000
cpuid = 4
KDB: stack backtrace:
#0 0xffffffff80942170 at kdb_backtrace+0x60
#1 0xffffffff80906d35 at panic+0x155
#2 0xffffffff80b8c01f at vm_fault_hold+0x1bcf
#3 0xffffffff80b8a407 at vm_fault+0x77
#4 0xffffffff80d1326c at trap_pfault+0x19c
#5 0xffffffff80d12a3a at trap+0x47a
#6 0xffffffff80cf8982 at calltrap+0x8
Uptime: 1h51m12s
Dumping 1539 out of 8042 MB:..2%..11%..21%..31%..41%..51%..61%..71%..81%..91%

Reading symbols from /boot/kernel/zfs.ko.symbols...done.
Loaded symbols for /boot/kernel/zfs.ko.symbols
Reading symbols from /boot/kernel/opensolaris.ko.symbols...done.
Loaded symbols for /boot/kernel/opensolaris.ko.symbols
Reading symbols from /boot/kernel/ipfw.ko.symbols...done.
Loaded symbols for /boot/kernel/ipfw.ko.symbols
Reading symbols from /boot/kernel/pf.ko.symbols...done.
Loaded symbols for /boot/kernel/pf.ko.symbols
Reading symbols from /boot/kernel/aesni.ko.symbols...done.
Loaded symbols for /boot/kernel/aesni.ko.symbols
Reading symbols from /boot/kernel/crypto.ko.symbols...done.
Loaded symbols for /boot/kernel/crypto.ko.symbols
Reading symbols from /boot/kernel/cryptodev.ko.symbols...done.
Loaded symbols for /boot/kernel/cryptodev.ko.symbols
Reading symbols from /boot/kernel/linprocfs.ko.symbols...done.
Loaded symbols for /boot/kernel/linprocfs.ko.symbols
Reading symbols from /boot/kernel/linux.ko.symbols...done.
Loaded symbols for /boot/kernel/linux.ko.symbols
Reading symbols from /boot/kernel/linsysfs.ko.symbols...done.
Loaded symbols for /boot/kernel/linsysfs.ko.symbols
Reading symbols from /boot/kernel/if_bridge.ko.symbols...done.
Loaded symbols for /boot/kernel/if_bridge.ko.symbols
Reading symbols from /boot/kernel/bridgestp.ko.symbols...done.
Loaded symbols for /boot/kernel/bridgestp.ko.symbols
Reading symbols from /boot/kernel/if_tap.ko.symbols...done.
Loaded symbols for /boot/kernel/if_tap.ko.symbols
Reading symbols from /boot/kernel/vmm.ko.symbols...done.
Loaded symbols for /boot/kernel/vmm.ko.symbols
Reading symbols from /boot/kernel/nmdm.ko.symbols...done.
Loaded symbols for /boot/kernel/nmdm.ko.symbols
Reading symbols from /boot/modules/vboxdrv.ko...done.
Loaded symbols for /boot/modules/vboxdrv.ko
Reading symbols from /boot/modules/nvidia.ko...done.
Loaded symbols for /boot/modules/nvidia.ko
Reading symbols from /boot/kernel/cc_htcp.ko.symbols...done.
Loaded symbols for /boot/kernel/cc_htcp.ko.symbols
Reading symbols from /boot/kernel/cpuctl.ko.symbols...done.
Loaded symbols for /boot/kernel/cpuctl.ko.symbols
Reading symbols from /boot/kernel/aio.ko.symbols...done.
Loaded symbols for /boot/kernel/aio.ko.symbols
Reading symbols from /boot/kernel/coretemp.ko.symbols...done.
Loaded symbols for /boot/kernel/coretemp.ko.symbols
Reading symbols from /boot/kernel/accf_data.ko.symbols...done.
Loaded symbols for /boot/kernel/accf_data.ko.symbols
Reading symbols from /boot/kernel/accf_http.ko.symbols...done.
Loaded symbols for /boot/kernel/accf_http.ko.symbols
Reading symbols from /boot/kernel/ums.ko.symbols...done.
Loaded symbols for /boot/kernel/ums.ko.symbols
Reading symbols from /boot/kernel/uhid.ko.symbols...done.
Loaded symbols for /boot/kernel/uhid.ko.symbols
Reading symbols from /boot/modules/vboxnetflt.ko...done.
Loaded symbols for /boot/modules/vboxnetflt.ko
Reading symbols from /boot/kernel/netgraph.ko.symbols...done.
Loaded symbols for /boot/kernel/netgraph.ko.symbols
Reading symbols from /boot/kernel/ng_ether.ko.symbols...done.
Loaded symbols for /boot/kernel/ng_ether.ko.symbols
Reading symbols from /boot/modules/vboxnetadp.ko...done.
Loaded symbols for /boot/modules/vboxnetadp.ko
Reading symbols from /boot/kernel/nullfs.ko.symbols...done.
Loaded symbols for /boot/kernel/nullfs.ko.symbols
Reading symbols from /boot/kernel/fdescfs.ko.symbols...done.
Loaded symbols for /boot/kernel/fdescfs.ko.symbols
#0  doadump (textdump=<value optimized out>) at pcpu.h:219
219             __asm("movq %%gs:%1,%0" : "=r" (td)
(kgdb) bt
#0  doadump (textdump=<value optimized out>) at pcpu.h:219
#1  0xffffffff809069b2 in kern_reboot (howto=260) at /usr/src/sys/kern/kern_shutdown.c:452
#2  0xffffffff80906d74 in panic (fmt=<value optimized out>) at /usr/src/sys/kern/kern_shutdown.c:759
#3  0xffffffff80b8c01f in vm_fault_hold (map=<value optimized out>, vaddr=<value optimized out>, fault_type=<value optimized out>, fault_flags=<value optimized out>, 
    m_hold=<value optimized out>) at /usr/src/sys/vm/vm_fault.c:277
#4  0xffffffff80b8a407 in vm_fault (map=0xfffff80002000000, vaddr=<value optimized out>, fault_type=1 '\001', fault_flags=0) at /usr/src/sys/vm/vm_fault.c:217
#5  0xffffffff80d1326c in trap_pfault (frame=0xfffffe023275b640, usermode=0) at /usr/src/sys/amd64/amd64/trap.c:752
#6  0xffffffff80d12a3a in trap (frame=0xfffffe023275b640) at /usr/src/sys/amd64/amd64/trap.c:440
#7  0xffffffff80cf8982 in calltrap () at /usr/src/sys/amd64/amd64/exception.S:232
#8  0xffffffff8203f8ab in _nv000233rm () from /boot/modules/nvidia.ko
#9  0xfffffe0010c8e000 in ?? ()
#10 0xfffff8000caaf600 in ?? ()
#11 0xfffff8002d551400 in ?? ()
#12 0xfffff8002d551400 in ?? ()
#13 0xfffff8000caaf600 in ?? ()
#14 0xffffffff82575bb6 in _nv000799rm () from /boot/modules/nvidia.ko
#15 0xfffffe0010c8e000 in ?? ()
#16 0xfffff8000caaf600 in ?? ()
#17 0xfffffe023275b830 in ?? ()
#18 0xfffff8002d551400 in ?? ()
#19 0xfffff8000caaf600 in ?? ()
#20 0xffffffff82577ee2 in rm_free_unused_clients () from /boot/modules/nvidia.ko
#21 0x0000000000018b6c in ?? ()
#22 0x13939b4350193e78 in ?? ()
#23 0x13939b443e846678 in ?? ()
#24 0x13939b443e846678 in ?? ()
#25 0x13939b43c74ed278 in ?? ()
#26 0x0000000000000000 in ?? ()
Current language:  auto; currently minimal
Comment 1 Jan Beich freebsd_committer 2014-09-28 19:49:02 UTC
What type of card? Do you use vt(4) console?

nvidia-driver-343.22 with GeForce GT 640 (GK107 or 0x0fc1) on 11.0-CURRENT amd64 here. The panic often happens during high ZFS I/O load when either VT is switched or an OpenGL app closed/opened. vt(4) because syscons(4) fails to gracefully dump a core in X11.

panic: vm_fault: fault on nofault entry, addr: fffffe0005ec1000
cpuid = 0
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2b/frame 0xfffffe01250cbd60
kdb_backtrace() at kdb_backtrace+0x39/frame 0xfffffe01250cbe10
vpanic() at vpanic+0x189/frame 0xfffffe01250cbe90
panic() at panic+0x43/frame 0xfffffe01250cbef0
vm_fault_hold() at vm_fault_hold+0x1c19/frame 0xfffffe01250cc140
vm_fault() at vm_fault+0x77/frame 0xfffffe01250cc180
trap_pfault() at trap_pfault+0x1e1/frame 0xfffffe01250cc220
trap() at trap+0x6f1/frame 0xfffffe01250cc570
calltrap() at calltrap+0x8/frame 0xfffffe01250cc570
--- trap 0xc, rip = 0xffffffff818a23aa, rsp = 0xfffffe01250cc630, rbp = 0xfffffe002db39f98 ---
_nv000224rm() at _nv000224rm+0x3a/frame 0xfffffe002db39f98

I couldn't gather |show locks| or |show alllocks|, only unrelated warnings from INVARIANTS and WITNESS.

panic: mutex os.lock_mtx not owned at nvidia_os.c:772
cpuid = 0
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2b/frame 0xfffffe0124fef630
kdb_backtrace() at kdb_backtrace+0x39/frame 0xfffffe0124fef6e0
vpanic() at vpanic+0x189/frame 0xfffffe0124fef760
panic() at panic+0x43/frame 0xfffffe0124fef7c0
__mtx_assert() at __mtx_assert+0xc2/frame 0xfffffe0124fef7d0
os_free_spinlock() at os_free_spinlock+0x2c/frame 0xfffffe0124fef7f0
_nv014282rm() at _nv014282rm+0x9/frame 0xfffffe000e619fe8
dmapbase() at 0xfffff8001a0da000/frame 0xfffffe0005e0e000
dmapbase() at 0xfffff8001a0cc800

acquiring duplicate lock of same type: "os.lock_sx"
 1st os.lock_sx @ nvidia_os.c:608
 2nd os.lock_sx @ nvidia_os.c:608
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2b/frame 0xfffffe01251cf600
kdb_backtrace() at kdb_backtrace+0x39/frame 0xfffffe01251cf6b0
witness_checkorder() at witness_checkorder+0xc4a/frame 0xfffffe01251cf740
_sx_xlock() at _sx_xlock+0x47/frame 0xfffffe01251cf780
os_acquire_mutex() at os_acquire_mutex+0x32/frame 0xfffffe01251cf7a0
_nv014147rm() at _nv014147rm+0x18/frame 0xfffffe003d63fe90
dmapbase() at 0xfffff800445b3c80

acquiring duplicate lock of same type: "os.lock_mtx"
 1st os.lock_mtx @ nvidia_os.c:782
 2nd os.lock_mtx @ nvidia_os.c:782
KDB: stack backtrace:
db_trace_self_wrapper() at db_trace_self_wrapper+0x2b/frame 0xfffffe01251cf1e0
kdb_backtrace() at kdb_backtrace+0x39/frame 0xfffffe01251cf290
witness_checkorder() at witness_checkorder+0xc4a/frame 0xfffffe01251cf320
__mtx_lock_flags() at __mtx_lock_flags+0x48/frame 0xfffffe01251cf360
os_acquire_spinlock() at os_acquire_spinlock+0x1b/frame 0xfffffe01251cf370
_nv017635rm() at _nv017635rm+0x185/frame 0xfffffe003d6a2ef8
Comment 2 olevole 2014-09-28 20:52:00 UTC
My card: GeForce GTX 760

Yes, I have vt(4) enabled in kernel.

Indeed, the problem is more common when the system is loaded with something (the video or audio playback). Currently my system is reinstalled on ZFS and I meet a problem, but if I'm not mistaken, on the UFS I got the same problem.
Comment 3 Marcus von Appen freebsd_committer freebsd_triage 2015-02-18 11:54:19 UTC
Updated 10.1-BETA and 10.1-RC versioned bugs to 10.1-STABLE.
Comment 4 Glen Barber freebsd_committer 2015-07-07 14:45:38 UTC
Is this still an issue?
Comment 5 olevole 2015-07-07 15:05:00 UTC
(In reply to Glen Barber from comment #4)

This problem already fixed and PR is not relevant
Comment 6 Glen Barber freebsd_committer 2015-07-07 15:08:47 UTC
Thank you for confirming, and for the report.