Bug 193752 - www/squid: broken transparent proxy with pf
Summary: www/squid: broken transparent proxy with pf
Status: Closed DUPLICATE of bug 193705
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-18 17:42 UTC by Konstantin Belousov
Modified: 2014-09-19 20:47 UTC (History)
1 user (show)

See Also:


Attachments
fix to pass --with-nat-devpf for pf-transparent (453 bytes, patch)
2014-09-18 17:42 UTC, Konstantin Belousov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Belousov freebsd_committer 2014-09-18 17:42:17 UTC
The transparent proxy with pf in squid 3.4.7_1 port is broken.  The port needs to pass --with-nat-devpf to configure so that the correct code for our pf(4) is used to get the pre-redirected dst for the connections.
Comment 1 Konstantin Belousov freebsd_committer 2014-09-18 17:42:56 UTC
Created attachment 147453 [details]
fix to pass --with-nat-devpf for pf-transparent
Comment 2 Guido Falsi freebsd_committer 2014-09-18 18:44:35 UTC
The problem was reported, with some others, in a previous bug report. I'm marking this one as duplicate and "triangulate" with the other PR.

Thanks for the report!

*** This bug has been marked as a duplicate of bug 193705 ***
Comment 3 commit-hook freebsd_committer 2014-09-19 20:47:10 UTC
A commit references this bug:

Author: madpilot
Date: Fri Sep 19 20:46:14 UTC 2014
New revision: 368596
URL: http://svnweb.freebsd.org/changeset/ports/368596

Log:
  - Make diskd and rock storage schemes options (diskd enabled by default) [1]
  - Add note in pkg-message about diskd needing some tuning [1]
  - Fix transparent proxy with PF [1] [2]
  - Fix a pair of typos [1]

  PR:		193705 [1], 193752 [2]
  Submitted by:	arcade@b1t.name [1], kib@ [2]

Changes:
  head/www/squid/Makefile
  head/www/squid/files/pkg-message.in
  head/www/squid/pkg-plist