Bug 193756 - /etc/rc.conf syslogd_flags ignored on boot
Summary: /etc/rc.conf syslogd_flags ignored on boot
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 10.1-STABLE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-18 20:25 UTC by mikej
Modified: 2015-07-07 15:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikej 2014-09-18 20:25:22 UTC
Setting syslogd_flags="" or syslogd_flags="<value>" in /etc/rc.conf is ignored on boot and instead you get the default flag value "-s" as defined in /etc/defaults/rc.conf. Other init scripts that I tested behave as expected and honor their _flags in /etc/rc.conf

Killing syslogd process "killall -9 syslogd" and restarting with "/etc/rc.d/syslogd start" set flags as expected
Comment 1 mikej 2014-09-18 20:38:10 UTC
I also noted that there is no DEBUG output in /var/messages for syslogd on boot when rc_debug="YES" is defined in /etc/rc.conf
Comment 2 mikej 2014-09-18 20:50:39 UTC
FreeBSD charon 10.1-BETA1 FreeBSD 10.1-BETA1
Comment 3 Marcus von Appen freebsd_committer freebsd_triage 2015-02-18 11:54:21 UTC
Updated 10.1-BETA and 10.1-RC versioned bugs to 10.1-STABLE.
Comment 4 Glen Barber freebsd_committer 2015-07-07 15:19:54 UTC
I am unsure when this was resolved, but I cannot reproduce this behavior.

Thank you for the report.