Bug 193862 - audio/linux-c6-{flac,libsndfile,alsa-plugins-pulseaudio,pulseaudio-libs}: fix depends, comment/conflicts in flac
Summary: audio/linux-c6-{flac,libsndfile,alsa-plugins-pulseaudio,pulseaudio-libs}: fix...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Johannes Jost Meixner
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2014-09-23 07:42 UTC by Jan Beich
Modified: 2014-09-23 12:06 UTC (History)
1 user (show)

See Also:


Attachments
fix (1.99 KB, patch)
2014-09-23 07:42 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-09-23 07:42:25 UTC
Created attachment 147588 [details]
fix

linux-c6-flac/Makefile:COMMENT=                Audio system for the KDE integrated X11 desktop (Linux CentOS ${LINUX_DIST_VER})
linux-c6-flac/Makefile:CONFLICTS=              linux-arts-[0-9]* linux-f10-arts-[0-9]*

$ readelf -d $(make -V WRKSRC -C linux-c6-flac)/usr/lib/libFLAC.so.8 | fgrep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libm.so.6]
 0x00000001 (NEEDED)                     Shared library: [libogg.so.0]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]

$ readelf -d $(make -V WRKSRC -C linux-c6-libsndfile)/usr/lib/libsndfile.so.1 | fgrep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libFLAC.so.8]
 0x00000001 (NEEDED)                     Shared library: [libvorbisenc.so.2]
 0x00000001 (NEEDED)                     Shared library: [libvorbis.so.0]
 0x00000001 (NEEDED)                     Shared library: [libogg.so.0]
 0x00000001 (NEEDED)                     Shared library: [libm.so.6]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]

$ readelf -d $(make -V WRKSRC -C linux-c6-pluseaudio-libs)/usr/lib/libpulse.so.0 | fgrep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libpulsecommon-0.9.21.so]
 0x00000001 (NEEDED)                     Shared library: [libX11.so.6]
 0x00000001 (NEEDED)                     Shared library: [libSM.so.6]
 0x00000001 (NEEDED)                     Shared library: [libICE.so.6]
 0x00000001 (NEEDED)                     Shared library: [libXtst.so.6]
 0x00000001 (NEEDED)                     Shared library: [libwrap.so.0]
 0x00000001 (NEEDED)                     Shared library: [libsndfile.so.1]
 0x00000001 (NEEDED)                     Shared library: [libasyncns.so.0]
 0x00000001 (NEEDED)                     Shared library: [libdbus-1.so.3]
 0x00000001 (NEEDED)                     Shared library: [libpthread.so.0]
 0x00000001 (NEEDED)                     Shared library: [librt.so.1]
 0x00000001 (NEEDED)                     Shared library: [libdl.so.2]
 0x00000001 (NEEDED)                     Shared library: [libm.so.6]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]

$ readelf -d $(make -V WRKSRC -C linux-c6-alsa-plugins-pulseaudio)/usr/lib/alsa-lib/libasound_module_pcm_pulse.so | fgrep NEEDED
 0x00000001 (NEEDED)                     Shared library: [libpulse.so.0]
 0x00000001 (NEEDED)                     Shared library: [libasound.so.2]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]
Comment 1 Jan Beich freebsd_committer 2014-09-23 07:45:26 UTC
(In reply to Jan Beich from comment #0)
> $ readelf -d $(make -V WRKSRC -C
> linux-c6-pluseaudio-libs)/usr/lib/libpulse.so.0 | fgrep NEEDED
>  0x00000001 (NEEDED)                     Shared library:
> [libpulsecommon-0.9.21.so]
>  0x00000001 (NEEDED)                     Shared library: [libX11.so.6]
>  0x00000001 (NEEDED)                     Shared library: [libSM.so.6]
>  0x00000001 (NEEDED)                     Shared library: [libICE.so.6]
>  0x00000001 (NEEDED)                     Shared library: [libXtst.so.6]
>  0x00000001 (NEEDED)                     Shared library: [libwrap.so.0]
>  0x00000001 (NEEDED)                     Shared library: [libsndfile.so.1]
>  0x00000001 (NEEDED)                     Shared library: [libasyncns.so.0]

See bug 193861 for similar fix in f10 port. That bug was already there before xmj@ landed c6.

>  0x00000001 (NEEDED)                     Shared library: [libdbus-1.so.3]
>  0x00000001 (NEEDED)                     Shared library: [libpthread.so.0]
>  0x00000001 (NEEDED)                     Shared library: [librt.so.1]
>  0x00000001 (NEEDED)                     Shared library: [libdl.so.2]
>  0x00000001 (NEEDED)                     Shared library: [libm.so.6]
>  0x00000001 (NEEDED)                     Shared library: [libc.so.6]
Comment 2 commit-hook freebsd_committer 2014-09-23 12:02:30 UTC
A commit references this bug:

Author: xmj
Date: Tue Sep 23 12:01:34 UTC 2014
New revision: 369048
URL: http://svnweb.freebsd.org/changeset/ports/369048

Log:
  Add missing deps, fix COMMENT/CONFLICTS

  Add missing dependencies to
  audio/linux-c6-{flac,libsndfile,alsa-plugins-pulseaudio,pulseaudio-libs}; set
  proper COMMENT and CONFLICTS in audio/linux-c6-flac (both of which I missed in
  r368845).

  PR:		193862
  Differential Revision:	https://reviews.freebsd.org/D816
  Submitted by:	Jan Beich <jbeich@vfemail.net>
  Approved by:	koobs (mentor)

Changes:
  head/audio/linux-c6-alsa-plugins-pulseaudio/Makefile
  head/audio/linux-c6-flac/Makefile
  head/audio/linux-c6-libsndfile/Makefile
  head/audio/linux-c6-pulseaudio-libs/Makefile