Bug 193864 - libpam fix breaks saslauthd
Summary: libpam fix breaks saslauthd
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-23 08:20 UTC by lampa
Modified: 2017-06-12 19:31 UTC (History)
2 users (show)

See Also:
mva: maintainer-feedback? (ume)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lampa 2014-09-23 08:20:16 UTC
https://svnweb.freebsd.org/base?view=revision&revision=271256
https://svnweb.freebsd.org/base?view=revision&revision=271767
This pam_login_access fix breaks cyrus-sasl-saslauthd, now pam_sm_acct_mgmt() fails when PAM_TTY nor PAM_RHOST is set. Saslauthd doesn't set any.
Comment 1 Marcus von Appen freebsd_committer freebsd_triage 2014-09-27 08:19:58 UTC
Assign to maintainer.
Comment 2 Hajimu UMEMOTO freebsd_committer 2014-09-27 17:58:22 UTC
It seems that this issue is not for individual ports but for pam.
Comment 3 lampa 2014-09-29 11:30:19 UTC
This can be fixed by providing example /etc/pam.d/smtp config or rather
by MFC of this:
https://docs.freebsd.org/cgi/getmsg.cgi?fetch=214064+0+current/svn-src-head
It looks like 193927 is duplicate of this.

Petr Lampa
Comment 4 Oliver 2014-09-29 15:48:01 UTC
Rev 272282 work fbsd-8.4-stable

Before libpam was broken in combination with cyrus-sasl2-saslauthd und courier-authlib-base-0.66.1_2
Comment 5 Hajimu UMEMOTO freebsd_committer 2017-06-12 14:36:04 UTC
Is there still this problem?
Comment 7 Oliver 2017-06-12 15:23:04 UTC
Fixed