Bug 193938 - www/squid: squid-3.4.8_1 leaking memory
Summary: www/squid: squid-3.4.8_1 leaking memory
Status: Closed DUPLICATE of bug 194726
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-26 05:07 UTC by Victor Sudakov
Modified: 2014-10-31 22:13 UTC (History)
5 users (show)

See Also:


Attachments
Add patches from upstream (1008 bytes, patch)
2014-10-20 07:13 UTC, timp87
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Sudakov 2014-09-26 05:07:31 UTC
squid-3.4.8_1 (www/squid) is leaking memory at the rate of several Mbytes per minute.

The settings are more than modest:

cache_mem 128 MB
cache_dir ufs /webcache/cache 512 16 256
memory_pools off # neither "on" nor "off" have any effect on leaking.
Comment 1 garrych 2014-10-01 13:10:38 UTC
I confirm this issue. Rollbacked to 3.3.13_2
Comment 2 timp87 2014-10-20 07:13:17 UTC
Created attachment 148492 [details]
Add patches from upstream

Hi! Would it help you?
Comment 3 John Marino freebsd_committer 2014-10-31 17:32:43 UTC
timp87, is there documentation you can point to that would give us confidence to commit your patch without waiting for the reporter to come back?  it appears he won't given how much time has passed.
Comment 4 timp87 2014-10-31 17:38:31 UTC
Hi, John!
My patch is a small amount of what has been done several days ago.
I think we should wait a couple of days for official release of squid 3.4.9 which contains even more memory leak fixes. Here is a link http://www.squid-cache.org/Versions/v3/3.4/changesets/SQUID_3_4_9.html
I'll make a new PR then.

Don't know what to do with this PR.
Comment 5 John Marino freebsd_committer 2014-10-31 17:40:59 UTC
When the submit a new PR, add me to CC and note that this PR needs to closed.  I'll take care of closing it.
Comment 6 John Marino freebsd_committer 2014-10-31 22:08:17 UTC

*** This bug has been marked as a duplicate of bug 194726 ***
Comment 7 commit-hook freebsd_committer 2014-10-31 22:13:07 UTC
A commit references this bug:

Author: marino
Date: Fri Oct 31 22:12:36 UTC 2014
New revision: 371944
URL: https://svnweb.freebsd.org/changeset/ports/371944

Log:
  www/squid: Upgrade version 3.4.8 => 3.4.9

  This update should address some memory leak issues

  PR:		193938
  PR:		194726
  Submitted by:	timp87 (gmail)

Changes:
  head/www/squid/Makefile
  head/www/squid/distinfo
  head/www/squid/pkg-plist