Bug 193966 - [PATCH] Mk/Uses/python.mk: Fix awk issue in add-plist-post with python 3+
Summary: [PATCH] Mk/Uses/python.mk: Fix awk issue in add-plist-post with python 3+
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Marcus von Appen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-27 06:56 UTC by corsmith
Modified: 2014-09-27 07:28 UTC (History)
0 users

See Also:


Attachments
svn diff showing the fix (495 bytes, text/plain)
2014-09-27 06:56 UTC, corsmith
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description corsmith 2014-09-27 06:56:52 UTC
Created attachment 147712 [details]
svn diff showing the fix

Some ports fail to build generating awk errors when using python3.4 as the default python.

For example:

===> Staging rc.d startup script(s)
/usr/bin/awk: syntax error at source line 1
 context is
         >>>  <<< 
/usr/bin/awk: bailing out at source line 1
*** Error code 2

Stop.
make: stopped in /usr/ports/net-mgmt/net-snmp

This is caused by an awk script that has an END section with no body.

Patch against Mk/Uses/python.mk is attached
Comment 1 Marcus von Appen freebsd_committer freebsd_triage 2014-09-27 07:28:00 UTC
Fixed in ports r369376. Thanks!
Comment 2 commit-hook freebsd_committer 2014-09-27 07:28:09 UTC
A commit references this bug:

Author: mva
Date: Sat Sep 27 07:27:27 UTC 2014
New revision: 369376
URL: https://svnweb.freebsd.org/changeset/ports/369376

Log:
  - Fix awk issue in add-plist-post, if python 3.x is the default

  PR:		193966
  Submitted by:	corsmith@gmail.com
  With hat: 	python@

Changes:
  head/Mk/Uses/python.mk